Closed Bug 996382 Opened 7 years ago Closed 2 years ago

[Sora][Browser]The information won't display when playing a song

Categories

(Web Compatibility :: Mobile, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: sync-1, Assigned: yliu)

References

()

Details

(Whiteboard: [country-cn] [contactready] [js] [serversniff])

Attachments

(2 files)

Mozilla build ID:20140404164003
 
 DEFECT DESCRIPTION:
  The information won't display when playing a song on line
 
  REPRODUCING PROCEDURES:
  Preconditon:
  1.network is ok
  Step:
  1.launch browser->open"www.baidu.com"->tap[download]->tap[Android user enter
 in]->tap[music]->select one song->waiting for it start to play->it won't playing-->KO1
  2.tap pause button->tap play button->the song start to playing->tap [back key]->back to previous webpage->the information about the song is not display-->KO2
 
  EXPECTED BEHAVIOUR:
  KO1:the song can automatic play
  KO2:the information about the song can display
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
  free test
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
  moderate
 
  REPRODUCING RATE:
  5/5
  For FT PR, Please list reference mobile's behavior:
  v1.1 has the same behavior
 ++++++++++ end of initial bug #650700 description ++++++++++
 
 		
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Attached file jrdlog_650700.rar
Component: Gaia::Browser → Mobile
Product: Firefox OS → Tech Evangelism
Whiteboard: [country-cn] [notcontactready] [js]
I can’t reproduce this bug with FFOS v1.3. 

http://www.baidu.com and http://music.baidu.com both send desktop sites to my device. It’s not consistent with the mobile sites displayed on Safari IOS. I'm not sure if this is related to the locale, but it seems i get the different UI as the reporter described in this bug.
Flags: needinfo?(sync-1)
Mozilla/5.0 (Mobile;ALCATELOneTouch4019X/SVN 02001;rv:28.0)Gecko/28.0 Firefox /28.0
Hmmm this user agent is not supposed to be correct. It should be something like

    "Mozilla/5.0 (Mobile; ALCATELOneTouch4019X; rv:28.0) Gecko/28.0 Firefox/28.0"

Buri, is it a really deployed user agent?


Using "Mozilla/5.0 (Mobile; ALCATELOneTouch4019X; rv:28.0) Gecko/28.0 Firefox/28.0", 
we receive a content which triggers a pseudo XHTML content. 
Content-Type: application/xhtml+xml;charset=utf-8

The response starts with 

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE html PUBLIC "-//WAPFORUM//DTD XHTML Mobile 1.0//EN" "http://www.wapforum.org/DTD/xhtml-mobile10.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"><!--STATUS OK--><head>

The server is nginx/1.2.4

And I believe it is again the Bug 997668. In this case the people are seeing "Alcatel" and identifies as a Mobile. If I use a Firefox for Android UA I get yet another site. 


As for the normal user agent     
   "Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0"

indeed yliu is right and we receive the Desktop site.
Flags: needinfo?(buri.blff)
For the other part of the bug,
Using "Mozilla/5.0 (Mobile; ALCATELOneTouch4019X; rv:28.0) Gecko/28.0 Firefox/28.0" User agent string.

1. On entering http://www.baidu.com/
2. Receiving the page described in Comment #5 (WAPFORUM//DTD XHTML Mobile 1.0)
3. Selecting "下载" leads to 
   http://duokoo.baidu.com/d/?fr=home&ssid=0&from=844b&bd_page_type=1&uid=0&pu=sz%40240_320%2Cta%40middle____&itj=212
4. Selecting "Android用户请进入>>" leads to 
   http://duokoo.baidu.com/adl/?r=1&R=571&ssid=0&from=844b&bd_page_type=1&uid=4C3EC836B5C8ABB29D075D9DFA92F9AE%3AFG%3D1&pu=sz%40240_320%2Cta%40middle____&fr=home&v=2&netFlag=cmnet&dkfrc=18

Even before going further as the tester suggests, the site is utterly broken. It is using flexbox syntax for WebKit

for example: display: -webkit-box

So there are many more additional issues before tackling the issue of music listening. 

This site is sending very different sites depending on the User Agent Sniffing.
(In reply to Karl Dubost :karlcow from comment #5)
> Hmmm this user agent is not supposed to be correct. It should be something
> like
> 
>     "Mozilla/5.0 (Mobile; ALCATELOneTouch4019X; rv:28.0) Gecko/28.0
> Firefox/28.0"
> 
> Buri, is it a really deployed user agent?
> 
> 
> Using "Mozilla/5.0 (Mobile; ALCATELOneTouch4019X; rv:28.0) Gecko/28.0
> Firefox/28.0", 
> we receive a content which triggers a pseudo XHTML content. 
> Content-Type: application/xhtml+xml;charset=utf-8
> 
> The response starts with 
> 
> <?xml version="1.0" encoding="utf-8"?>
> <!DOCTYPE html PUBLIC "-//WAPFORUM//DTD XHTML Mobile 1.0//EN"
> "http://www.wapforum.org/DTD/xhtml-mobile10.dtd">
> <html xmlns="http://www.w3.org/1999/xhtml"><!--STATUS OK--><head>
> 
> The server is nginx/1.2.4
> 
> And I believe it is again the Bug 997668. In this case the people are seeing
> "Alcatel" and identifies as a Mobile. If I use a Firefox for Android UA I
> get yet another site. 
> 
> 
> As for the normal user agent     
>    "Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0"
> 
> indeed yliu is right and we receive the Desktop site.

Yes
Flags: needinfo?(buri.blff)
buri.blff@gmail.com,

You said yes to this:

"Mozilla/5.0 (Mobile;ALCATELOneTouch4019X/SVN 02001;rv:28.0)Gecko/28.0 Firefox /28.0"
                                         ^^^^^^^^^^                           ^
                                          issue                               issue  


or to this:
"Mozilla/5.0 (Mobile; ALCATELOneTouch4019X; rv:28.0) Gecko/28.0 Firefox/28.0"
Flags: needinfo?(buri.blff)
(In reply to Karl Dubost :karlcow from comment #8)
> buri.blff@gmail.com,
> 
> You said yes to this:
> 
> "Mozilla/5.0 (Mobile;ALCATELOneTouch4019X/SVN 02001;rv:28.0)Gecko/28.0
> Firefox /28.0"
>                                          ^^^^^^^^^^                         
> ^
>                                           issue                             
> issue  
> 
> 
> or to this:
> "Mozilla/5.0 (Mobile; ALCATELOneTouch4019X; rv:28.0) Gecko/28.0 Firefox/28.0"

That is our customization.
Flags: needinfo?(buri.blff)
Carries require the SVN in UA.
Buri,

Thanks so I understand that you are using
"Mozilla/5.0 (Mobile;ALCATELOneTouch4019X/SVN 02001;rv:28.0)Gecko/28.0 Firefox /28.0"

Three questions:

* is "Firefox /28.0" the real string?
* Do you know why the carriers asked for "SVN 02001"?

I'm asking because we want to be able to evolve the platform in a way that people do not rely on user agent sniffing. What is the business case for "SVN 02001"?

Thanks.
Flags: needinfo?(buri.blff)
Dear Viga,
 
 Please help to ask the question of comment #9.
The SVN issue is for business case. And I don't think it effects User Agent Sniffing.
The sniffer finds the key words like Android, Mobile... doesn't care SVN.
yliu,

After testing a bit more
http://www.otsukare.info/2014/05/27/ua-modifications

* Desktop        "Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0"
* fancy Mobile   "Mozilla/5.0 (Android; Mobile; rv:28.0) Gecko/28.0 Firefox/28.0"
* simple Mobile  "Mozilla/5.0 (Mobile; ALCATELOneTouch4019X; rv:28.0) Gecko/28.0 Firefox/28.0"
                 "Mozilla/5.0 (Mobile;ALCATELOneTouch4019X/SVN 02001;rv:28.0)Gecko/28.0 Firefox /28.0"

We need to ask baidu to send the same version that they send to Android devices (this will not fix everything).
Flags: needinfo?(yliu)
Hi weijia,

(In reply to weijia from comment #13)
> The SVN issue is for business case. 

Yes, and I would like to know what is the business case :) That was my question.


> And I don't think it effects User Agent Sniffing.
> The sniffer finds the key words like Android, Mobile... doesn't care SVN.

The keyword which modify the user agent sniffing here is "ALCATELOneTouch4019X" see
http://www.otsukare.info/2014/05/27/ua-modifications



Also for future testing it would be good to put both the User Agent which has been used
and the URIs reached during the test, it helps to understand the contest of the bug.

If I follow the instruction given by the tester I guess that we are testing in fact.
http://duokoo.baidu.com/d/
(In reply to Karl Dubost :karlcow from comment #15)
> Hi weijia,
> 
> (In reply to weijia from comment #13)
> > The SVN issue is for business case. 
> 
> Yes, and I would like to know what is the business case :) That was my
> question.
> 
> 
> > And I don't think it effects User Agent Sniffing.
> > The sniffer finds the key words like Android, Mobile... doesn't care SVN.
> 
> The keyword which modify the user agent sniffing here is
> "ALCATELOneTouch4019X" see
> http://www.otsukare.info/2014/05/27/ua-modifications
> 
> 
> 
> Also for future testing it would be good to put both the User Agent which
> has been used
> and the URIs reached during the test, it helps to understand the contest of
> the bug.
> 
> If I follow the instruction given by the tester I guess that we are testing
> in fact.
> http://duokoo.baidu.com/d/

Karl, Thanks for sharing your test. The SVN is the internal version number.
It's weired the sinffer test ALCATELOneTouch4019X... What special things did for this
string...
(In reply to Karl Dubost :karlcow from comment #14)
> yliu,
> 
> After testing a bit more
> http://www.otsukare.info/2014/05/27/ua-modifications
> 
> * Desktop        "Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0"
> * fancy Mobile   "Mozilla/5.0 (Android; Mobile; rv:28.0) Gecko/28.0
> Firefox/28.0"
> * simple Mobile  "Mozilla/5.0 (Mobile; ALCATELOneTouch4019X; rv:28.0)
> Gecko/28.0 Firefox/28.0"
>                  "Mozilla/5.0 (Mobile;ALCATELOneTouch4019X/SVN
> 02001;rv:28.0)Gecko/28.0 Firefox /28.0"
> 
> We need to ask baidu to send the same version that they send to Android
> devices (this will not fix everything).

Hi Karl,

I will try to contact Baidu and ask them to do so. Thanks for your help!
Flags: needinfo?(yliu)
Weijia,

(In reply to weijia from comment #16)
> Karl, Thanks for sharing your test. The SVN is the internal version number.
> It's weired the sinffer test ALCATELOneTouch4019X... What special things did
> for this
> string...

I'm not surprised. ^_^  This is the reason why we are so fighting back on more tokens in the UA string. 

To make a long story short, the more we put tokens (*any token*) to identify devices, the more Web developers use them to try to redirect the devices to a certain user experience instead of using features detection techniques.

It's why it's broken. For the SVN part, you can be sure that if it's a way for developers to start identify this specific device/OS combination, they will use it. Basically, the more we provide tokens, the more we are shooting in our own feet. It's why I'm asking what is the business case :) You haven't told me yet. ;)

See my blog, it's all about this kind of issues. http://www.otsukare.info/
In China for example, there is usage of nginx with a long collection of keywords to redirect devices to… simplified mobile versions of sites.
See 
http://www.otsukare.info/2014/05/26/nginx-wap-sniffing-china
and http://www.92csz.com/39/124.html


Hope it helps to understand the issue.
The SVN is the operator internal version number.
weijia,
A couple of questions:

1. Do you know if this string is the intended released string for Production devices.
   "Mozilla/5.0 (Mobile;ALCATELOneTouch4019X/SVN 02001;rv:28.0)Gecko/28.0 Firefox /28.0"

2. Could you fix the string for the mistakes it contains?
   * add a space after "Mobile;"
   * add a space before "rv:"
   * add a space before "Gecko"
   * remove the space in "Firefox /28"
   "Mozilla/5.0 (Mobile; ALCATELOneTouch4019X/SVN 02001; rv:28.0) Gecko/28.0 Firefox/28.0"

   Better
   "Mozilla/5.0 (Mobile; ALCATELOneTouch4019X; rv:28.0) Gecko/28.0 Firefox/28.0"

   Recommended:
   "Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0"

3. Web sites testing should be done with the User Agent strings planned in released devices not test devices. The reason is that Web sites are highly sensitive to the UA string. Could you ask testers to test only with the planned final UA string.

Thanks ^_^
Assignee: nobody → yliu
Status: NEW → ASSIGNED
Flags: needinfo?(liweijia)
Whiteboard: [country-cn] [notcontactready] [js] → [country-cn] [contactready] [js] [serversniff]
Yes, it's the UA in release device. I can correct some mistakes you mentioned. But SVN is a must,
Maybe in a good format. Any idea how can I add a right format SVN?

Thanks
Flags: needinfo?(liweijia)
Weijia,

1. SVN Usage. 
   You said: "The SVN is the operator internal version number."
   But I want to know what is used for? If you do not know could you send me the contact information of the person who is requiring it. (in private is fine).


2. Our recommendations are clear and documented.
   https://developer.mozilla.org/en-US/docs/Web/HTTP/Gecko_user_agent_string_reference#Firefox_OS


I already explained in Comment #18 how 
* it will create issues in the future for users (and operators/devices manufacturers) 
* it will make our job harder.

Note that there is a volunteer community working hard to try to get these things fixed and by doing this we are not helping their work. Just for the record. ^_^
Further documented requirements for device id inclusion in the UA. 
https://wiki.mozilla.org/B2G/User_Agent/Device_Model_Inclusion_Requirements

Specifically of note in this case,

"Do not use slash ("/"), semicolon (";"), round brackets or any whitespace."
"Do not include a "build id" in addition to the device name."
I just test by removing customized UA string. The problem still exists.
Weijia,

(In reply to weijia from comment #24)
> I just test by removing customized UA string. The problem still exists.

Yes it's normal. Read Comment #5, Comment #6 and Comment #14


Do you mean you used this one?
"Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0"

By using this one, you will receive the desktop site on www.baidu.com. It's normal it's why we have a bug BUT We now have a stable and logical story for baidu, which says when you see this UA string, send us the touch version of the site.

The issue with custom UA string (like the one you proposed) is that our story is becoming weak, and we fall into many traps. For example currently with the Alcatel keyword, we are sent to the simple Web mobile instead of the Touch version. It creates fragmentation and unnecessary code to maintain.

We don't want to have to contact baidu each time there is a new device. It is not a good use of the community time. Custom UA strings have also secondary effects on database such as WURFL, mobidetect, etc and other scripts.
Hi Jack

Could you let know who requests to put SVN into the User Agent string? That is violate our UA string requirements

Thanks
Flags: needinfo?(liuyongming)
Hi Vance,

Have already send message to internal team and ask them to make sure that customer aware of mozilla rules for UA string customization.

Thanks.
Flags: needinfo?(liuyongming)
Flags: needinfo?(sync-1)
Flags: needinfo?(buri.blff)
link all Fire C (codename: Sora) bugs to a meta one.
Closing the issue based on the meta bug that has the resolution Wontfix.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Priority: P2 → P5
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.