Closed Bug 996487 Opened 6 years ago Closed 6 years ago

Intermittent B2G test_convolverNodeChannelCount.html,test_mixingRules.html,test_pannerNodeTail.html | application timed out after 330.0 seconds with no output | application crashed [@ pthread_mutex_lock]

Categories

(Core :: Web Audio, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31
Tracking Status
firefox29 --- unaffected
firefox30 --- unaffected
firefox31 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: cbook, Assigned: jesup)

References

()

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

b2g_emulator_vm mozilla-inbound opt test mochitest-4 on 2014-04-14 23:59:33 PDT for push 1accd58e429e

slave: tst-linux64-spot-339

https://tbpl.mozilla.org/php/getParsedLog.php?id=37819898&tree=Mozilla-Inbound

B2GRunner TEST-UNEXPECTED-FAIL | /tests/content/media/webaudio/test/test_pannerNodeTail.html | application timed out after 330.0 seconds with no output


PROCESS-CRASH | /tests/content/media/webaudio/test/test_pannerNodeTail.html | application crashed [@ pthread_mutex_lock]

00:23:02     INFO -                    0.0.0 Linux 2.6.29-00302-g586075d #31 Mon Feb 24 10:28:23 PST 2014 armv7l Android/full/generic:4.0.4.0.4.0.4/OPENMASTER/eng.cltbld.20140415.014322:eng/test-keys
00:23:02     INFO -  CPU: arm
00:23:02     INFO -       0 CPUs
00:23:02     INFO -  Crash reason:  SIGSEGV
00:23:02     INFO -  Crash address: 0x5a5a5a5a
00:23:02     INFO -  Thread 18 (crashed)
00:23:02     INFO -   0  libc.so!pthread_mutex_lock [pthread.c : 1036 + 0x0]
00:23:02     INFO -       r4 = 0x5a5a5a5a    r5 = 0x44fffc18    r6 = 0x00000000    r7 = 0x00000000
00:23:02     INFO -       r8 = 0x00000000    r9 = 0x00000000   r10 = 0x430fc060    fp = 0x00000000
00:23:02     INFO -       sp = 0x44fffbc0    lr = 0x40014ecb    pc = 0x40056248
00:23:02     INFO -      Found by: given as instruction pointer in context
00:23:02     INFO -   1  libmozglue.so!__wrap_pthread_mutex_lock [Nuwa.cpp:1accd58e429e : 1076 + 0x5]
00:23:02     INFO -       r4 = 0x00000000    r5 = 0x44fffc18    r6 = 0x00000000    r7 = 0x00000000
00:23:02     INFO -       r8 = 0x00000000    r9 = 0x00000000   r10 = 0x430fc060    fp = 0x00000000
00:23:02     INFO -       sp = 0x44fffbe0    pc = 0x40014ecb
00:23:02     INFO -      Found by: call frame info
00:23:02     INFO -   2  libnss3.so!PR_Lock [ptsynch.c:1accd58e429e : 177 + 0x3]
00:23:02     INFO -       r4 = 0x5a5a5a5a    r5 = 0x44fffc18    r6 = 0x00000000    r7 = 0x00000000
00:23:02     INFO -       r8 = 0x00000000    r9 = 0x00000000   r10 = 0x430fc060    fp = 0x00000000
00:23:02     INFO -       sp = 0x44fffc00    pc = 0x420d71e1
00:23:02     INFO -      Found by: call frame info
00:23:02     INFO -   3  libxul.so!nsThread::GetObserver(nsIThreadObserver**) [Mutex.h : 70 + 0x3]
00:23:02     INFO -       r4 = 0x449845c0    r5 = 0x44fffc18    r6 = 0x00000000    r7 = 0x00000000
00:23:02     INFO -       r8 = 0x00000000    r9 = 0x00000000   r10 = 0x430fc060    fp = 0x00000000
00:23:02     INFO -       sp = 0x44fffc08    pc = 0x405edb1d
00:23:02     INFO -      Found by: call frame info
00:23:02     INFO -   4  libxul.so!nsThread::PutEvent(nsIRunnable*, nsThread::nsNestedEventTarget*) [nsThread.h:1accd58e429e : 76 + 0x7]
00:23:02     INFO -       r4 = 0x449845c0    r5 = 0x8007000e    r6 = 0x00000000    r7 = 0x00000000
00:23:02     INFO -       r8 = 0x00000000    r9 = 0x00000000   r10 = 0x430fc060    fp = 0x00000000
00:23:02     INFO -       sp = 0x44fffc18    pc = 0x405edb75
00:23:02     INFO -      Found by: call frame info
00:23:02     INFO -   5  libxul.so!nsThread::DispatchInternal(nsIRunnable*, unsigned int, nsThread::nsNestedEventTarget*) [nsThread.cpp:1accd58e429e : 472 + 0x9]
00:23:02     INFO -       r4 = 0x449845c0    r5 = 0x44fffcf4    r6 = 0x4334d4c0    r7 = 0x00000000
00:23:02     INFO -       r8 = 0x00000000    r9 = 0x00000000   r10 = 0x430fc060    fp = 0x00000000
00:23:02     INFO -       sp = 0x44fffc30    pc = 0x405ee21b
00:23:02     INFO -      Found by: call frame info
00:23:02     INFO -   6  libxul.so!nsThread::Dispatch(nsIRunnable*, unsigned int) [nsThread.cpp:1accd58e429e : 483 + 0x5]
https://tbpl.mozilla.org/php/getParsedLog.php?id=37861141&tree=B2g-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=37863681&tree=B2g-Inbound
Summary: Intermittent test_pannerNodeTail.html | application timed out after 330.0 seconds with no output → Intermittent test_convolverNodeChannelCount.html,test_pannerNodeTail.html | application timed out after 330.0 seconds with no output | application crashed [@ pthread_mutex_lock]
(In reply to Carsten Book [:Tomcat] from comment #0)

The HRTFDatabaseLoader thread is still doing ffts to interpolate head response
impulse responses in the logs of comment 0 and comment 1 at least.
test_pannerNodeTail.html will wait for this to complete.

That is not happening when test_convolverNodeChannelCount.html times out
(based on the log in comment 6).

This may have a similar underlying cause to bug 994351.
Summary: Intermittent test_convolverNodeChannelCount.html,test_pannerNodeTail.html | application timed out after 330.0 seconds with no output | application crashed [@ pthread_mutex_lock] → Intermittent b2g emulator test_convolverNodeChannelCount.html,test_pannerNodeTail.html | application timed out after 330.0 seconds with no output | application crashed [@ pthread_mutex_lock]
OS: Android → Gonk (Firefox OS)
https://tbpl.mozilla.org/php/getParsedLog.php?id=37937501&tree=Mozilla-Inbound
Summary: Intermittent b2g emulator test_convolverNodeChannelCount.html,test_pannerNodeTail.html | application timed out after 330.0 seconds with no output | application crashed [@ pthread_mutex_lock] → Intermittent B2G test_convolverNodeChannelCount.html,test_mixingRules.html,test_pannerNodeTail.html | application timed out after 330.0 seconds with no output | application crashed [@ pthread_mutex_lock]
Bug 965677 also has a number of reports of the test_convolverNodeChannelCount.html timeout.  The earliest seems to be 40260af420a7.

Bug 965677 comment 486 also has a timeout in test_pannerNodeAbove.html.
Bug 965677 comment 489 is a timeout in test_nodeToParamConnection.html.

Retriggers confirm bug 919215 as the trigger.
Blocks: 919215
Keywords: regression
This is a dup of a bug in XPCOM NS_NewNamedThread, and I just landed the fix:
Bug 997286

Just marking dependency for now; when that merges we can close this (for easier starring)

Thanks Karl!
No longer blocks: 919215
Depends on: 997286
Duplicate of this bug: 997645
Fix merged, dupping
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 997286
(In reply to Randell Jesup [:jesup] from comment #41)
> *** This bug has been marked as a duplicate of bug 997286 ***

I disagree :)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
ryan: all the failures are on b2g-inbound.... does it have the fix for this?
Flags: needinfo?(ryanvm)
m-c was merged to b-i on Friday, Saturday, and Sunday, so yes.
Flags: needinfo?(ryanvm)
Sigh.  Too much hurry to release things.
Comment on attachment 8409818 [details] [diff] [review]
don't null out mThread while committing thread suicide

one last time..... :-(
Attachment #8409818 - Flags: review?(benjamin)
Duplicate of this bug: 998939
Attachment #8409818 - Flags: review?(benjamin) → review+
https://hg.mozilla.org/mozilla-central/rev/d4df499022c9
Assignee: nobody → rjesup
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.