Closed Bug 996853 Opened 6 years ago Closed 6 years ago

Intermittent media-element-source-seek-1.html | Exited with code -1073741819 during test run

Categories

(Core :: Audio/Video, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31

People

(Reporter: jesup, Assigned: jesup)

References

()

Details

(Keywords: crash)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #991504 +++

Further fallout from bug 818822:
There are more places where AUDIO_FORMAT_SILENCE isn't checked for, either in a switch (MediaPipeline.cpp) or isn't checked at all (AudioSegment.cpp/WriteTo()).

shadeslayer ran into these on vline.com using the Mute button.

I have a patch that fixes those two.
Attachment #8407132 - Flags: review?(roc)
Duplicate of this bug: 996797
Seems to fix the issue I was having. Thanks Randell!
Duplicate of this bug: 997398
Blocks: 997348
Blocks: 997533
https://hg.mozilla.org/mozilla-central/rev/903bbde3a7c4
Assignee: nobody → rjesup
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
No longer blocks: 997533
No longer blocks: 997348
You need to log in before you can comment on or make changes to this bug.