Closed Bug 997149 Opened 6 years ago Closed 5 years ago

Gonk video-size-values fallback on preview-size-values does not work as expected

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 987068

People

(Reporter: gerard-majax, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached patch Quick hackSplinter Review
Enabling video recording mode on Nexus S and Desire Z makes the Camera app not working.

After some investigation, I found out that the |video-size-values| camera parameter would fail because it is non-existent.

As far as I understand this code, this case is expected to be correctly handled by |nsGonkCameraControl::Get| at http://dxr.mozilla.org/mozilla-central/source/dom/camera/GonkCameraControl.cpp#374

Adding debug to the code, I do see this path being hit and handled properly at least once. But at some point later, SetVideoSize() gets called and we trigger another request for |video-size-values| and the proper |preview-size-values| replacement is not being done.

This results in no recording size being used, and recording broken.

Quick hack attached does the trick of bringing back the recording mode on Nexus S.
Attachment #8407508 - Flags: feedback?(mhabicher)
Blocks: b2g-nexuss
Blocks: 997150
I believe this is/will be addressed in bug 987068.
See Also: → 987068
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 987068
You need to log in before you can comment on or make changes to this bug.