Closed Bug 997453 Opened 6 years ago Closed 2 years ago

[B2G][Tarako][Email] The X at the end of text fields (to clear the field) has difficulty detecting presses / taps.

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED WONTFIX
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: jmitchell, Unassigned)

Details

(Whiteboard: [tarako-exploratory])

Attachments

(2 files)

Attached video EmailX.mp4
Description:
Starting the email app for the first time you are presented with 3 text fields to set up a new account. When a field is active there is an X at the far right of it to clear the field. This X is difficult to trigger; often it will think the user is pressing outside the area and close the currently opened text field and keyboard. I tested this on the Buri 1.3 and while the X field is the same area, it seemed much more responsive for me and triggered properly for me almost every time. 
This also occurs with the X at the end of the search mail field.
Other instances of this X seem more sensitive (such as the E.Me search bar) and have no trouble detecting my tapping. 

Repro Steps: Prerequisite - no email set-up yet
1) Update a Tarako to BuildID: 20140415004002
2) Open email app
3) Enter text into one of the fields
4) Attempt to push the X at the end of the text field
5) Repeat steps 3 and 4 a few times

Actual:
The text field and keyboard are closed
Expected:
The X will be more sensitive, maybe a larger collision-area, and detect my tapping to clear the text field.

1.3T Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140415004002
Gaia: 44ff6248c28ff83b9ad1161847a176399f93d3bb
Gecko: 28aea220e338
Version: 28.1
Firmware Version: SP6821

Repro frequency: 60%
See attached: EmailX.mp4, logcat.txt

This does NOT repro with the 1.3 Buri
1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140414004002
Gaia: 8b92c56267fe50772095f1f25d6cc1f9c9966eb4
Gecko: 3e26908fca71
Version: 28.0
Firmware Version: V1.2-device.cfg
Attached file logcat.txt
Does this happen on other UIs in the operating system?
Keywords: qawanted
QA Contact: rpribble
I am not seeing this in any other UIs on the Tarako v1.3T MOZ ril.

Environmental Variables:
Device: Tarako v1.3T MOZ ril
BuildID: 20140415004002
Gaia: 44ff6248c28ff83b9ad1161847a176399f93d3bb
Gecko: 28aea220e338
Version: 28.1
Firmware Version: sp8810

X's in other UIs work as expected.

Note: When the issue occurs in the 'new account' page of the email app, the area or amount of the screen being touched seems to be relevant. For example, I see the issue far more frequently if I use the broad flat of my thumb, whereas if I use my fingertip the issue occurs far less frequently. So it seems that people with larger fingers will see this issue. ;)
Keywords: qawanted
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.