Closed Bug 997540 Opened 6 years ago Closed 5 years ago

on ebay, JavaScript loaded 100 times each time you scroll at the bottom

Categories

(Web Compatibility :: Desktop, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: karlcow, Unassigned)

References

()

Details

(Whiteboard: [country-all] [contactready] [js])

Step to reproduce:

0. Open a Firefox window, no cache, no cookies, entirely clean.
1. Start the Network panel in Developer Tools (just to monitor the issue. It doesn't impact the issue at stake)
2. Go to http://www.ebay.com/itm/PRE-SALE-ZTE-OPEN-C-4-Firefox-OS-1-3-Dual-Core-3G-Smartphone-EU-standard-/121306346377?_trksid=p2054897.l5658
3. Wait for the page to be entirely loaded.
4. Scroll toward the bottom
5. New resources start to be loaded.
6. Reach the bottom of the page
7. Scroll up again, the same resources are being reloaded with a flickering effect.
8. Reload the page (no issues anymore on scroll).


Some comments and analysis:

Using Nightly 30.0a1 (2014-02-10), 
Using Nightly 31.0a1 (2014-03-30), 
Using Nightly 31.0a1 (2014-04-16),
Using Aurora  30.0a2 (2014-04-14),
Using Stable  28,
I was able to reproduce once for each. 
At the next reload all issues have disappeared. I guess to exhibit the issue you need to clear all cookies and cache.

What is happening is that the one specific JS seems to be downloaded plenty of time. The issue is triggered each time you scroll in the window.

It's 35.30 KB. The reason it is being downloaded over and over is the parameter which are different. It's overkill. It gets downloaded 100 times.

For example:

http://reco.ebay.com/service/plmt/100009-100010-100047?guid=6d46e8851450a35869b1ec3cffdb36d9&itm=121306346377&bWidth=1015&fmt=html&locale=en-US&usrSt=4&srchCtxt=%28dmLCat%3D-1%7CsrCnt%3D0%7CmCCatId%3D0%7CminPrice%3D-1.0%7CmaxPrice%3D-1.0%7CcrncyId%3D840%7CfShip%3D0%7Cetrs%3D0%29&usrSi=JP&slr=1186221881&ctg=9355&si=0&_qi=t6ulcpjqcj9%3Fuk%601d70f%2Bdagb&callback=jQuery1710976050097493771_1397697736928&_=1397697755857

http://reco.ebay.com/service/plmt/100009-100010-100047?guid=6d46e8851450a35869b1ec3cffdb36d9&itm=121306346377&bWidth=1015&fmt=html&locale=en-US&usrSt=4&srchCtxt=%28dmLCat%3D-1%7CsrCnt%3D0%7CmCCatId%3D0%7CminPrice%3D-1.0%7CmaxPrice%3D-1.0%7CcrncyId%3D840%7CfShip%3D0%7Cetrs%3D0%29&usrSi=JP&slr=1186221881&ctg=9355&si=0&_qi=t6ulcpjqcj9%3Fuk%601d70f%2Bdagb&callback=jQuery1710976050097493771_1397697736929&_=1397697755926

The content is a kind of pseudo-JSON file starting with a JQuery string.
Whiteboard: [country-all] [contactready] [js]
This is not the case anymore.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.