If page loading interrupted, page will never load correctly

VERIFIED FIXED in M11

Status

P1
major
VERIFIED FIXED
20 years ago
14 years ago

People

(Reporter: cpratt, Assigned: radha)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [HELP WANTED] Waiting QA input)

(Reporter)

Description

20 years ago
Build ID: 1999071417
Platform: Windows 98 (can't test Mac OS or Linux just now, but presumably this
is also a problem on those platforms)

To reproduce:
- Launch apprunner
- Before your default home page has finished loading, enter another URL in the
Location: control and press Enter to load it. You may need to do this over a
dialup connection to give yourself enough time.
- Wait for the other page to finish loading, and then quit apprunner.
- Launch apprunner again.

Result:
Two major problems:
1) Any page component that had not loaded when you first viewed this (default
home) page will not now load. For example, if mozillazine.org is your default
home page, and you loaded another page before its images loaded, the images will
never load again.
2) The Location: control will remain blank.

Expected result:
1) Even if the page has never previously been successfully loaded, it should be
loaded on subsequent attempts (ie we should pretend we had never loaded or tried
to load it before).
2) The Location: control should show the URL correctly.

Updated

20 years ago
Assignee: don → radha
Priority: P3 → P1
Target Milestone: M11

Updated

20 years ago
Status: NEW → ASSIGNED
Whiteboard: Waiting QA input
Can QA confirm if this is still happening?
(Reporter)

Comment 2

20 years ago
I'm guessing that at this point it's a mystery fix. I can't reproduce it over
Ethernet at the moment, using the 1999090808 build under NT. beppe, if you can
perhaps try this over a dial-up connection using Windows 9x... if it works for
you, I think we can safely mark this as fixed for now.
Whiteboard: Waiting QA input → [NEED HELP] Waiting QA input

Updated

20 years ago
Whiteboard: [NEED HELP] Waiting QA input → [HELP WANTED] Waiting QA input

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
QA Contact: beppe → cpratt
Resolution: --- → FIXED

Comment 3

20 years ago
setting Pratt as QA contact and marking it fixed
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

20 years ago
Verifying as fixed.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.