Closed Bug 997768 Opened 6 years ago Closed 6 years ago

UI telemetry for top sites

Categories

(Firefox for Android :: Awesomescreen, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 32
Tracking Status
firefox32 --- verified
firefox33 --- verified

People

(Reporter: lucasr, Unassigned)

References

Details

Attachments

(1 file)

More specifically, instrument access to different types of websites on the grid view (blank, top, suggested, pinned).
Depends on: 977196
Comment on attachment 8416563 [details] [diff] [review]
Use SUGGESTION telemetry method for suggested sites (r=mfinkle)

This way we can track interaction with suggested sites by fetching 'loadurl' events with method 'SUGGESTION' while a 'homepanel' session is active. Let me know if there's a better way to frame it.
Attachment #8416563 - Flags: review?(mark.finkle)
Attachment #8416563 - Flags: review?(mark.finkle) → review+
Depends on: 997782
https://hg.mozilla.org/mozilla-central/rev/cc4134859783
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Tapping once on any suggested sites will output the following probe:
SendUIEvent: event = loadurl.1 method = suggestion timestamp = 1694628 extras = 0
Tap it again and it will output the following probe:
SendUIEvent: event = loadurl.1 method = griditem timestamp = 1699423 extras = 0

Is this the correct behavior?
Flags: needinfo?(lucasr.at.mozilla)
(In reply to Flaviu Cos, QA [:flaviu] from comment #5)
> Tapping once on any suggested sites will output the following probe:
> SendUIEvent: event = loadurl.1 method = suggestion timestamp = 1694628
> extras = 0
> Tap it again and it will output the following probe:
> SendUIEvent: event = loadurl.1 method = griditem timestamp = 1699423 extras
> = 0
> 
> Is this the correct behavior?

Yes, the suggested site will become an ordinary history item after being tapped for the first time. The special image is still used though (that's by design, see bug 1009587).
Flags: needinfo?(lucasr.at.mozilla)
Based on comment 6 will mark the bug as Verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.