Closed Bug 998058 Opened 8 years ago Closed 7 years ago

Zooming out of about:newtab shrinks grid to rows*(columns-1)

Categories

(Firefox :: New Tab Page, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1036284

People

(Reporter: elbart, Unassigned)

References

Details

STR:
Open about:newtab
Zoom out of the page with either Ctrl+MouseWheelDown or Ctrl+'-' a few times

ER:
Grid becomes smaller, but still shows 3*3 (default) tiles

AR:
Grid becomes smaller, but is now showing only 2 columns with 3 rows each.


Changing browser.newtabpage.(rows|columns) shows that whatever the values, the grid, when zooming out, is always rows*(columns-1) with a minimum of one column.

Regression range:

Last good revision: 5c0673441fc8 (2014-03-25)
First bad revision: 140ac04d7454 (2014-03-26)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5c0673441fc8&tochange=140ac04d7454

Last good revision: fa098f9fe89c
First bad revision: 7462bee51ec6
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=fa098f9fe89c&tochange=7462bee51ec6

Suspected:
ed1b7cda3ffa	Ed Lee — Bug 980014 - Allow new tab grid layout to reduce rows/columns if the window can't fit 3x3 [r=adw]
Blocks: 980014
(In reply to Elbart from comment #0)

> Last good revision: fa098f9fe89c
> First bad revision: 7462bee51ec6
> Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=fa098f9fe89c&tochange=7462bee51ec6


Sorry, this is the correct m-i range:

Last good revision: daada068c02f
First bad revision: ed1b7cda3ffa
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=daada068c02f&tochange=ed1b7cda3ffa
Blocks: tiles-dev
Flags: firefox-backlog?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: firefox-backlog? → firefox-backlog+
Mass-move to Firefox::New Tab Page.

Filter on new-tab-page-component.
Component: Tabbed Browser → New Tab Page
Is this bug still happening? For me I see default 3x4 then zoom out once and see 3x5 (which is the max rows/cols with the default pref.)
(In reply to Ed Lee :Mardak from comment #3)
> Is this bug still happening?

Not for me, probably since bug 1036284.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1036284
Flags: firefox-backlog+ → firefox-backlog-
You need to log in before you can comment on or make changes to this bug.