Closed Bug 998114 Opened 6 years ago Closed 6 years ago

[B2G] [Tarako] [Browser] Attempting to access the help page while maps.google.com is on another tab crashes the device

Categories

(Firefox OS Graveyard :: Performance, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3T affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: ckreinbring, Unassigned)

Details

(Whiteboard: [tarako-bug-bash-1.3T], LMK)

Attachments

(2 files)

Description:
Attempting to access the help page from the Google Maps site will first show an unable to load error message, the crash the device when the user attempts to reload the page.

Repro Steps:
1) Update a Tarako to BuildID: 20140417004002
2) Launch the browser and navigate to http://maps.google.com
3) If a prompt to share the device location appears, select Deny.
4) Tap the My Location icon (large dot inside a crosshair) then tap Help on the error message that appears.
5) When an error message appears, tap Reload and observe the device's reaction.

Actual:
Firefox OS crashes, no crash log appears to be generated.

Expected:
The error message appears again, or the help page loads, or the browser closes.

1.3T Environmental Variables:
Device: Tarako 1.3T Mozilla RIL
BuildID: 20140417004002
Gaia: a8d2d399f2939f4845abaa0df57abab241a2c782
Gecko: d97dad54cb61
Version: 28.1
Firmware Version: sp6821

Notes:
Repro frequency: 100%
See attached logcat and firewatch logs
Whiteboard: [tarako-bug-bash-1.3T]
Some questions:

1. Can we get an about:memory report?
2. Does this reproduce on 1.3?
Component: Gaia::Browser → Performance
Keywords: qawanted
HI ckreinbring@qanalydocs.com,

Please check out Jason's questions and give some feedback.
Assignee: nobody → ckreinbring
Assignee: ckreinbring → nobody
QA Contact: ckreinbring
From the log, it should be LMK problem. It seems loading map will consume a lot of memory (the geolocation information from google map is too big) and trigger LMK.

04-17 16:18:00.856: I/log(3210): <4>0[ 1604.635458] lowmem_shrink select 3047 (Browser), adj 2, size 10061, to kill
Whiteboard: [tarako-bug-bash-1.3T] → [tarako-bug-bash-1.3T], LMK
I have worked with the reporter but was unable to reproduce this issue on both today's build and the build it was discovered on. 

1.3T Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140428014001
Gaia: 8895b180ed636069473703d0e7b73086989601ce
Gecko: 7caf4b5abfce
Version: 28.1
Firmware Version: sp6821

The help screen loaded slowly but without an error.

This also did not reproduce on 1.3 Buri.

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140425024003
Gaia: 32a9e3db738e0b3bc44a4d4d5c16512a2617a2cf
Gecko: c96b0cf6343f
Version: 28.0
Firmware Version: v1.2-device.cfg

The help screen loaded quickly after opening the page without errors.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.