Closed Bug 998220 Opened 6 years ago Closed 6 years ago

Supprt encoded frame with NALU size larger than RTP packet size in WebRTC RTP sender/receiver

Categories

(Core :: WebRTC: Audio/Video, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 985254

People

(Reporter: jhlin, Unassigned)

References

(Depends on 1 open bug)

Details

Per bug 911046 comment 101, to support RFC-6184 packetization mode 1, RTP sender/receiver need FU-A fragmentation/reassembling & STAP-A aggregation/disassembling.
Depends on: 997947
No longer depends on: 911046
Depends on: 911046
Looks like there is already a patch under review in WebRTC.org: https://webrtc-codereview.appspot.com/11239004/. It doesn't aggregate SPS/PPS AFAICT, but that seems not mandatory anyway.
bug 985254 is going to merge the WebRTC.org patch.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 985254
You need to log in before you can comment on or make changes to this bug.