[B2G] [Tarako] [Browser] Cannot load YouTube comment sections on video pages

RESOLVED FIXED

Status

defect
P1
normal
RESOLVED FIXED
5 years ago
6 months ago

People

(Reporter: ckreinbring, Assigned: fzzzy)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v1.3 unaffected, b2g-v1.3T affected)

Details

(Whiteboard: [tarako-exploratory])

Attachments

(2 attachments)

Description:
A user attempting to load the comments section of a YouTube video is unable to do so, receiving an error page instead.  Tapping Reload will reload the page with the suggested videos section showing.

Repro Steps:
1) Update a Tarako to BuildID: 20140418014001
2) Launch the Browser app and navigate to http://youtube.com
3) Navigate to a video that has comments then tap the Comments tab.
4) Observe the device as it attempts to load the comments section.

Actual:
After a few seconds of loading, a "Well, this is embarrassing" error page appears.

Expected:
After a few seconds of loading, the Suggested Videos section is replaced with the Comments section.

Environmental Variables:
Device: Tarako 1.3t Moz RIL
BuildID: 20140418014001
Gaia: f0872318d46781bb59d0a13a2e1fffb115b8ca2b
Gecko: 32bb713e6d0d
Version: 28.1
Firmware Version: sp6821a-4-18

Notes:
Repro frequency: 100%
See attached logcat and firewatch logs
Component: Gaia::Browser → Preinstalled B2G Apps
Product: Firefox OS → Tech Evangelism
Also repros on Buri 1.3 mozilla RIL.

Device: Buri 1.3 Mozilla RIL
BuildID: 20140418024004
Gaia: 4aae5c8e9ac9a3d7ea7e83172dda6e11169cd677
Gecko: 0fd9f6fe8832
Version: 28.0
Firmware Version: v1.2-device.cfg
Please review and provide potential fix date.  Thank you
Assignee: nobody → dpreston
Status: NEW → ASSIGNED
Priority: -- → P1
Marvin - Is YouTube a must have for Tarako or not?
Flags: needinfo?(mkhoo)
Sorry for late Jason, yes, YouTube is considered to be preloaded.

BR,
Marvin
Flags: needinfo?(mkhoo)
blocking-b2g: --- → 1.3T?
Youtube functionality is a hard requirement for Spreadtrum acceptance of 1.3T
Clearing the nom here - this is a TE problem, which is something we won't block on.
blocking-b2g: 1.3T? → ---
Flags: needinfo?(nhirata.bugzilla)
What exactly happened on 1.3? Can you clarify what behavior you saw?
Flags: needinfo?(ckreinbring)
When I tapped on the comments tab on a video, the highlight would switch from the Suggested Videos tab to the Comments tab and a Loading text and spinner appeared.  After about 15-20 seconds, the error page mentioned in the Actual result appeared.

I just tried again today, and YouTube's mobile UI appears to have changed.  However, scrolling to the bottom of a video's page and tapping the Comments bar brings up a pane with a Loading message and a spinner above it.  The message and spinner remain even after waiting for about 10 minutes.
Flags: needinfo?(ckreinbring)
If the mobile UI changed, then we should retest on tarako today. Can you check this again?
Flags: needinfo?(ckreinbring)
The results of the retest are shown in comment 9.

BuildID: 20140508014002
Gaia: 8969848adfdd8b0cfdfdf072f99b20505385482c
Gecko: 1d997ccbf79c
Platform Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29
Flags: needinfo?(ckreinbring)
I'm really confused. Are you saying that comment 9's test results are the same for Tarako & 1.3 Buri?
Flags: needinfo?(ckreinbring)
No, comment 9's results are from the the latest Tarako build.  The latest Buri 1.3 build is able to load the comments section after a few seconds of loading.

Build ID: 20140505024001
Gecko: https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/bf3fe474bf50
Gaia: 667539f1ed4becc45b182a5f1046221d3eeb9e7c
Platform Version: 28.0
Firmware Version: V1.2-device.cfg
Flags: needinfo?(ckreinbring)
Ok - so that means this isn't reproducing on 1.3, so fixing the flag here.
Component: Preinstalled B2G Apps → Performance
Product: Tech Evangelism → Firefox OS
blocking-b2g: --- → 1.3T?
Assignee: dpreston → nobody
No longer blocks: b2g-youtube
Looks like the UA is set the same for Buri and Tarako on today's build.

Tarako when scrolling youtube comments is getting killed :
05-09 10:33:15.691: E/OomLogger(86): [Kill]: lowmem_shrink select 530 (YouTube), adj 2, size 16699, to kill
05-09 10:33:15.691: E/OomLogger(86): [Kill]: lowmem_shrink send sigkill to 530 (YouTube), adj 2, size 16699
Flags: needinfo?(nhirata.bugzilla)
Keywords: perf
Trying to create a profile of the comment section has proven to be difficult.  Youtube will get killed when trying to stabilize the b2g process once in the comment section; I could only get the profile before clicking on the comments so I'm unsure how useful the profile is:
https://drive.google.com/file/d/0B_0LdM1CVycIUmNVRU4yVVlQRHc/edit?usp=sharing
ni? Thinker on the last few comments. Is there anything on the platform that can be done? thanks
Flags: needinfo?(tlee)
We need more information to determine what to do as next.  Since profiling is difficult on Tarako devices, I suggest to do profiling and get_about_memory on devices with more memory for youtube app.
Flags: needinfo?(tlee)
Whiteboard: [tarako-exploratory] → [tarako-exploratory][c=memory p= u= s=]
Bhavana,

In FxOS Perf's triage today we noticed that this bug hasn't been +'d or -'d via the 1.3T Triage. Was it missed or is there another reason why?

Thanks,
FxOS Perf Team
Flags: needinfo?(bbajaj)
Priority: P1 → P2
Whiteboard: [tarako-exploratory][c=memory p= u= s=] → [c=memory p= s= u=tarako] [MemShrink] [tarako-exploratory]
I think I'm going to move this back into the TE component, as a lot of these Tarako issues appear to be on the app side.
Blocks: b2g-youtube
blocking-b2g: 1.3T? → ---
Component: Performance → Preinstalled B2G Apps
Keywords: perf
Product: Firefox OS → Tech Evangelism
Whiteboard: [c=memory p= s= u=tarako] [MemShrink] [tarako-exploratory] → [c=memory p= s= u=tarako] [tarako-exploratory]
Fixing the flags back to what Nicole had originally.
Assignee: nobody → dpreston
Priority: P2 → P1
I don't see any "Show comments" feature at the bottom of the page when loading videos in Tarako. It works on the Geeksphone.
Whiteboard: [c=memory p= s= u=tarako] [tarako-exploratory] → [tarako-exploratory]
I can't repro this on a build from 5/7; I am able to see the "Show comments" ui and load comments successfully.

ckreinbring can you re-test please?
Flags: needinfo?(ckreinbring)
Flags: needinfo?(ckreinbring)
Keywords: qawanted
This is outside the scope of our QA Wanted queries, so this needs to be directly tested here.
Flags: needinfo?(jzimbrick)
Keywords: qawanted
Flags: needinfo?(bbajaj)
I think jzimbrick left, so I'm switching the needinfo to Peter.
Flags: needinfo?(jzimbrick) → needinfo?(pbylenga)
I am seeing variable results based on the size of the comment section. In the popular video section I was able to load the comments on the video 'First Lady Michelle Obama wants you to show her how you move' which only had 39 comments. However, when I tried to load a larger comment section - such as 'This is where I leave you - official trailer' with 568 comments it crashes after a few seconds with the previously mentioned "Well, this is embarrassing" error message.
Flags: needinfo?(pbylenga)
Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140530033326
Gaia: 1cd5f640a586a2f8c46af8f9de85b2792d511f1d
Gecko: 6b1345332108
Version: 28.1
Firmware Version: sp6821a-gonk-4.0-5-12
An example URL of a video with excessive comments that should get the error message is:

http://m.youtube.com/watch?v=rOyZojbYUEA

'Jinga Cat' video with 3,000+ comments
Joshua, that is really useful information. Thank you very much.
YT now has a Tarako and is going to look into what they may be able to do to fix this.
YouTube wasn't able to reproduce this on a Tarako with a build from 6/16. I can't repro with the same build.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.