Closed Bug 998447 Opened 5 years ago Closed 2 years ago

[B2G][Tarako][Settings]Passcode lock screen loads unexpectedly

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(tracking-b2g:backlog, b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED WONTFIX
tracking-b2g backlog
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: mclemmons, Unassigned)

References

()

Details

(Whiteboard: [tarako-exploratory] [perf-reviewed])

Attachments

(2 files)

Attached file Logcat Passcode Page
User taps Settings App, Screen lock button, and enable Passcode lock, the Passcode page loads in a bizarre way. For less than 1 second, the Passcode entry page displays, then the screen goes white, the keyboard pops up and finally the Passcode entry page returns fully and in a stable manner. 

Repro Steps:
1) Updated Tarako to BuildID: 20140418014001
2) Tap Settings App and select Screen Lock
3) Tap Passcode lock button to enable 

Actual:
For less than 1 second, the Passcode entry page displays, then the screen goes white, the keyboard pops up and finally the Passcode entry page returns fully and in a stable manner.

Expected:
Passcode entry page displays in a normal and stable manner 

Repro Rate; 10/10 = 100 percent
Other: See attached – logcat, Firewatch, video clip

Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140418014001
Gaia: f0872318d46781bb59d0a13a2e1fffb115b8ca2b
Gecko: 32bb713e6d0d
Version: 28.1
Firmware Version: sp6821
Attached file Firewatch for Passcode
This issue does not reproduce on Buri 1.3. Following the STR from Comment 0, the Passcode entry page loads in a stable manner every time (10 attempts, 10 successes)

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140418024004
Gaia: 4aae5c8e9ac9a3d7ea7e83172dda6e11169cd677
Gecko: 0fd9f6fe8832
Version: 28.0
Firmware: v1.2-device.cfg
Not a regression - this is likely a tarako-specific bug.
Keywords: footprint, perf
Whiteboard: [tarako-exploratory] → [tarako-exploratory],[c=memory p= s= u=] [MemShrink]
At this point, I'm not sure if I would consider this a blocker.  Functionally it works.  Visually it sucks.
Placing in for backlog as a papercut.  May have to revisit to see if we can somehow profile this.
blocking-b2g: --- → backlog
Whiteboard: [tarako-exploratory],[c=memory p= s= u=] [MemShrink] → [tarako-exploratory],[c=memory p= s= u=]
Taking off perf from this since the memory aspect isn't well-established. If we do know for sure this is LMK, please go ahead and re-add perf to keyword (and removed perf-reviewed) so it goes back into our triage.
Keywords: perf
Whiteboard: [tarako-exploratory],[c=memory p= s= u=] → [tarako-exploratory] [perf-reviewed]
Keywords: footprint
blocking-b2g: backlog → ---
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.