Closed Bug 998494 Opened 10 years ago Closed 3 years ago

Tweak wording of tab restore preference and summary text

Categories

(Firefox for Android Graveyard :: General, enhancement)

All
Android
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: rnewman, Unassigned)

References

Details

(Keywords: polish)

      No description provided.
Blocks: 1063114
It looks like we already do this... rnewman, what are you thinking here?
Flags: needinfo?(rnewman)
Resolving this as WORKSFORME. Reopen with more details if you think this is still a problem.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Let's morph this bug and use it to tweak wording.

Right now we have "Tabs": "Always restore" / "Don't restore after quitting Nightly".

Those should really be explanatory regardless of which one you chose -- i.e., consistent -- even if the summary isn't identical to the option string.

For example, this would be clearer:


   Tabs
   Always restore when opening Nightly

than what we have now:

   Tabs
   Always restore

because it's not clear when the "always" action occurs. It doesn't (yet) address what "restore" means, or why "Always". (You restore my Sync tabs every time I tap the Firefox icon?)

We could still show a shorter version in the picker:

   [ ] Always restore when opening Nightly
   [ ] Never restore


We should also question what "Always" means in this context, and whether a small tweak here would make this more understandable to newer users.
Status: RESOLVED → REOPENED
Flags: needinfo?(rnewman)
Resolution: WORKSFORME → ---
Summary: Settings: show current tab restore preference as descriptive text → Tweak wording of tab restore preference and summary text
We have completed our launch of our new Firefox on Android. The development of the new versions use GitHub for issue tracking. If the bug report still reproduces in a current version of [Firefox on Android nightly](https://play.google.com/store/apps/details?id=org.mozilla.fenix) an issue can be reported at the [Fenix GitHub project](https://github.com/mozilla-mobile/fenix/). If you want to discuss your report please use [Mozilla's chat](https://wiki.mozilla.org/Matrix#Connect_to_Matrix) server https://chat.mozilla.org and join the [#fenix](https://chat.mozilla.org/#/room/#fenix:mozilla.org) channel.
Status: REOPENED → RESOLVED
Closed: 10 years ago3 years ago
Resolution: --- → INCOMPLETE
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.