[B2G] [Browser] Camera placeholder icons do not line up with video suggestions

RESOLVED FIXED

Status

defect
P3
normal
RESOLVED FIXED
5 years ago
6 months ago

People

(Reporter: ckreinbring, Assigned: fzzzy)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v1.3 affected, b2g-v1.3T affected)

Details

(Whiteboard: [tarako-exploratory])

Attachments

(1 attachment)

Description:
When a list of suggested videos fail to load their preview pictures, the placeholder camera icons will be too large for the list and run into multiple search suggestions.

Repro Steps:
1) Update a Tarako to BuildID: 20140418014001
2) Launch the Browser app and navigate to http://youtube.com
3) Select a video and observe the video previews in the Suggested Videos section.
4) If the previews do not show the camera placeholder icon, tap one of the suggested videos and observe the suggested videos for that video.
5) If the previews show the camera placeholder icon, observe how well the icons line up with the video entries.

Actual:
The camera icons appear to be slightly larger than the preview area allows, causing the icons to run into multiple videos.

Expected:
The camera icons are the same size as the preview area, so each suggested video has their own camera placeholder icon.

Environmental Variables:
Device: Tarako 1.3t Mozilla RIL
BuildID: 20140418014001
Gaia: f0872318d46781bb59d0a13a2e1fffb115b8ca2b
Gecko: 32bb713e6d0d
Version: 28.1
Firmware Version: sp6821a-4-18

Notes:
Repro frequency: 100%
See attached screenshot
Also repros on Buri 1.3 Mozilla RIL

BuildID: 20140418024004
Gaia: 4aae5c8e9ac9a3d7ea7e83172dda6e11169cd677
Gecko: 0fd9f6fe8832
Version: 28.0
Firmware Version: v1.2-device.cfg
Blocks: b2g-youtube
Component: Gaia::Browser → Preinstalled B2G Apps
Product: Firefox OS → Tech Evangelism
Assignee: nobody → dpreston
Priority: -- → P3
Please review and provide potential fix date.  Thank you
Flags: needinfo?(dpreston)
Status: NEW → ASSIGNED
I'm having a hard time finding any videos with the placeholder icon any more. I know I used to be able to see them, but I've been browsing around for 20 minutes and I haven't seen a single placeholder video.

Perhaps YT made server side changes which give every video a preview graphic?

I will ask them about it.

Reproduction steps which include a video to search for which shows the placeholder graphic would also be useful.
Flags: needinfo?(dpreston) → needinfo?(ckreinbring)
There was no one video that always reproed the bug.  Usually selecting a suggested video a few times quickly would get the bug to repro.
Flags: needinfo?(ckreinbring)
I can't reproduce this after YT released their new layout. Please re-open if reliable STR are found.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.