Closed Bug 998502 Opened 7 years ago Closed 7 years ago

elements translated in z don't change display layers

Categories

(Core :: Graphics: Layers, defect)

31 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 810685

People

(Reporter: ftripier, Unassigned, NeedInfo)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.116 Safari/537.36

Steps to reproduce:

I gave my body tag transform-style: preserve-3d and no perspective. After appending an element with an identity transform to the body, I appended another with 3 translation in z (i.e. [1, 0, 0, 0, 0, 1, 0, 0, 0, 0, 1, 0, 0, 0, 3, 1]).


Actual results:

The element with translation in z remained displayed behind the element I appended first.


Expected results:

The element translated in z should have appeared in front of the element with no translation (occurs in chrome and safari).
Can you attach the HTML file? Thanks!
Flags: needinfo?(ftripier)
This looks like a dupe of bug 810685 and bug 861835. But, ftripier, maybe your testcase will still be useful.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 810685
You need to log in before you can comment on or make changes to this bug.