Feed preview is broken on SeaMonkey nightly

RESOLVED FIXED in seamonkey2.29

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: emk, Assigned: neil)

Tracking

Trunk
seamonkey2.29
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.27 unaffected, seamonkey2.28 fixed, seamonkey2.29 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Messages from the Error Console:
> Timestamp: 2014/04/20 9:31:31
> Error: Error: Permission denied to access property 'appendChild'
> Source File: resource://gre/components/FeedWriter.js
> Line: 968
> Timestamp: 2014/04/20 9:26:05
> Error: NS_ERROR_FAILURE: Failure
> Source File: chrome://communicator/content/feeds/subscribe.xml
> Line: 35
Posted patch Yak shaving (obsolete) — Splinter Review
I've always wanted to rip out that sandbox, now here's my chance.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8409421 - Flags: review?(iann_bugzilla)
Duplicate of this bug: 998360
Doesn't it regress bug 360529?
(In reply to Masatoshi Kimura from comment #5)
> Doesn't it regress bug 360529?

None of the test cases in that bug did anything when I tried them. (I think they're supposed to alert some privileged information?)

Mind you, most of this stuff predates X-rays, so it's ancient.
Comment on attachment 8409421 [details] [diff] [review]
Yak shaving

>+++ b/suite/feeds/src/FeedWriter.js

>   _setContentText: function setContentText(id, text) {
>+    this._document.getElementById(id).textContent = text;
>   },
Has this been left for add-on support as it is not used in the current patch (yet).

I also noticed that the Firefox version of this did some stuff with supporting XHTML in feed titles, see changeset http://hg.mozilla.org/mozilla-central/rev/e3126e00ec91
Should we doing this as part of this patch too?

r=me with those addressed.
Attachment #8409421 - Flags: review?(iann_bugzilla) → review+
OS: Windows 8.1 → All
Hardware: x86_64 → All
Version: unspecified → Trunk
I meant to remove _setContentText but I restored it to make it easier to port bug 436801 (which I didn't do that here because I have no test case).
Attachment #8409410 - Attachment is obsolete: true
Attachment #8409421 - Attachment is obsolete: true
Attachment #8409410 - Flags: review?(neil)
Attachment #8413443 - Flags: review?(iann_bugzilla)
Comment on attachment 8413443 [details] [diff] [review]
Updated for review comments

r=me
Attachment #8413443 - Flags: review?(iann_bugzilla) → review+
Duplicate of this bug: 1006664
Pushed comm-central changeset 7a929459a778.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.29
Comment on attachment 8413443 [details] [diff] [review]
Updated for review comments

[Approval Request Comment]
Regression caused by (bug #): 986730
User impact if declined: Feed preview does not work
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky): Could use attachment 8409410 [details] [diff] [review] instead.
String changes made by this patch: None
Attachment #8413443 - Flags: approval-comm-aurora?
Attachment #8413443 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.