Closed Bug 99889 Opened 19 years ago Closed 19 years ago

JavaScript fragment kills Mozilla...

Categories

(Core :: JavaScript Engine, defect, critical)

x86
Windows 2000
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 13350

People

(Reporter: schneid, Assigned: rogerl)

References

()

Details

I know that this code is not quite correct, but it should not hang the browser,
should it?

<html>
  <head>
    <title>MozDeath</title>
    <script language="JavaScript1.2">
    <!--
      while (true) {
        function pollLoop () {
        }
      }
    //-->
    </script>
  </head>
  <body>
  </body>
</html>
Confirming with Build ID 2001091508 win98
Mozilla completly hangs and must be killed
Well you put the browser in an infinite loop which is why it hangs the browser.

Anyway, the hang is bug 13350.

*** This bug has been marked as a duplicate of 13350 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Verified Duplicate - 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.