Closed Bug 998980 Opened 10 years ago Closed 10 years ago

Toggling "Match case" does not update Find Bar search results feedback accordingly (found/not found status text, red background) [switching on/off, enable, disable case sensitivity]

Categories

(Toolkit :: Find Toolbar, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1051187

People

(Reporter: thomas8, Unassigned)

References

(Depends on 1 open bug)

Details

+++ This bug was initially created as a clone of Bug #941229 +++

Occasionally, when I search for text on a page I won't find what I'm looking for because I left "Match Case" selected from an earlier search.
Unfortunately, removing "Match Case" does NOT update search results in find bar.

STR

1 on page having Foo, but not foo
2 enable "Match case" on find bar
3 search for "foo" (sic)
4 switch off "Match case"

Actual

nothing (find bar still claims with red background color and status msg that "foo" cannot be found although it's now case-insensitive)

Expected

switching off "Match case" should immediately re-evaluate the search and update "found/not found" feedback accordingly in find bar
Summary: Show a slightly different "Phrase not found" message when searching with Match Case option → Toggling "Match case" does not update Find Bar search results feedback accordingly (found/not found status text, red background) [switching on/off, enable, disable case sensitivity]
This is being worked on in bug 1051187
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.