Add-ons manager hidden tabs are always displayed

VERIFIED FIXED in Firefox 29

Status

()

defect
--
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: wip.the.gruik, Assigned: Gijs)

Tracking

({regression})

29 Branch
Firefox 31
All
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29+ verified, firefox30+ verified, firefox31+ verified)

Details

(Whiteboard: [Australis:P1])

Attachments

(2 attachments)

Posted image addons-manager.jpg
Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0
Fresh install, new profile, no add-on installed.

Reproducible with Firefox 29 beta9, on Windows XP only.
Not reproducible on Windows 7.

Steps to reproduce:
Open add-ons manager, either via the menu, Ctrl+Shift+A shortcut or the about:addons URL.

Actual results:
Tabs such as "Search", "Available Updates" or "Recent Updates" are visible.

Expected results:
Tabs such as "Search", "Available Updates" or "Recent Updates" should be hidden.

This seems to be a regression.
Are there any errors in the browser console?
Flags: needinfo?(wip.the.gruik)
I did the following :
  1. set the current selection to "Appearance"
  2. close the add-ons manager tab
  3. open the browser console (CTRL+SHIFT+J)
  4. clear the browser console
  5. open back the download manager (CTRL+SHIFT+A)
  6. no error whatsoever

The console only contains this line (all filters enabled except CSS Log) :
  file:///C:/Program%20Files/Mozilla%20Firefox/browser/extensions/%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D/icon.png
Flags: needinfo?(wip.the.gruik)
(In reply to wip.the.gruik from comment #2)
> I did the following :
>   1. set the current selection to "Appearance"
>   2. close the add-ons manager tab
>   3. open the browser console (CTRL+SHIFT+J)
>   4. clear the browser console
>   5. open back the download manager (CTRL+SHIFT+A)
>   6. no error whatsoever
> 
> The console only contains this line (all filters enabled except CSS Log) :
>  
> file:///C:/Program%20Files/Mozilla%20Firefox/browser/extensions/%7B972ce4c6-
> 7e08-4474-a285-3208198ce6fd%7D/icon.png

I can reproduce this, on beta9 as well as trunk. This is very odd. It WFM on Windows 8 and OS X as well, with the same beta. I'm about to head to sleep, but this seems very bad. It looks like it's because bug 980339 added %ifdefs, but that file actually isn't preprocessed so now there's just a bunch of CSS brokenness in the resulting file.
Blocks: 980339
Severity: minor → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Hardware: x86 → All
This fixes things. I'm not sure if we're comfortable taking this on beta. If not, I think we should back out the offending patch.
Attachment #8409851 - Flags: review?(jaws)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
As noted on IRC:  I believe we should either try to get the patch there for 29 release, or back out the original patch, because IMO the current state isn't something we should ship; it's a highly visible regression for our XP users (of which there are probably not many on nightly/aurora/beta, but many more on release...)
I'm told we're merging to release *now*. I think we should back bug 980339 out from release (in part because I'm not even sure WINDOWS_AERO is defined for toolkit/....//extensions.css, I assumed due diligence on the part of the patch author, and tested on XP (which worked - but might be broken on Win8 with this patch)). I won't be around to do it. Gavin/Justin/Lukas, if you agree, can one of you please do that? I won't be around until tomorrow, I'm afraid.
Flags: needinfo?(lsblakk)
Flags: needinfo?(gavin.sharp)
Flags: needinfo?(dolske)
Comment on attachment 8409851 [details] [diff] [review]
preprocess extensions.css,

r+ as this is just matching what aero does.
Attachment #8409851 - Flags: review?(jaws) → review+
(In reply to :Gijs Kruitbosch from comment #6)
> I'm told we're merging to release *now*. I think we should back bug 980339
> out from release (in part because I'm not even sure WINDOWS_AERO is defined
> for toolkit/....//extensions.css.

WINDOWS_AERO gets defined in toolkit/themes/windows/mozapps/extensions/extensions-aero.css which gets chosen from jar.mn for Vista and up.
We're going to back out bug 980339 on beta for 29. We can take the forward fix for 30/31.
Flags: needinfo?(lsblakk)
Flags: needinfo?(gavin.sharp)
Flags: needinfo?(dolske)
Whiteboard: [Australis:P1]
Sorry :/
(In reply to Tim Nguyen [:ntim] from comment #11)
> Sorry :/

Don't worry. All of us make mistakes. Sometimes the mistakes don't get caught for a while. Fortunately, we found this one just in time (thanks, wip.the.gruik!).

Landed the patch on fx-team:
remote:   https://hg.mozilla.org/integration/fx-team/rev/c40d3b63ea6f
Whiteboard: [Australis:P1] → [Australis:P1][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/c40d3b63ea6f
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P1][fixed-in-fx-team] → [Australis:P1]
Target Milestone: --- → Firefox 31
Attachment #8409851 - Flags: approval-mozilla-aurora+
Reproduced with Nightly from 2014-04-21 with steps from comment 0.
Verified fixed with Firefox 29 RC (Build ID: 20140421221237), 30 beta 1 (Build ID: 20140428174145) and latest Aurora 31.0a2 (Build ID: 20140504004003) on Windows XP x32 and x64:

Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 5.2; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 5.1; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (Windows NT 5.2; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0
Mozilla/5.0 (Windows NT 5.2; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
You need to log in before you can comment on or make changes to this bug.