Closed Bug 999203 Opened 6 years ago Closed 6 years ago

Tabs always restore from last time, even if preference is disabled

Categories

(Firefox for Android :: Awesomescreen, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox31 --- verified
fennec 31+ ---

People

(Reporter: mcomella, Assigned: bnicholson)

References

Details

(Keywords: regression)

Attachments

(1 file)

No description provided.
Environment: 
Device: Samsung Galaxy Note Tab (Android 4.1.2);
Build: Nightly 31.0a1 (2014-04-23);

Steps to reproduce:
1. Open a few tabs;
2. Restart firefox.

Expected result:
After restart only one about:home tab is opened.

Actual result:
All the opened tabs from step 1 are restored.
Last good revision: e71ed4135461
First bad revision: 7fe3ee0cf8be
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e71ed4135461&tochange=7fe3ee0cf8be
Keywords: regression
Probably

5a1b6dfdff18	Brian Nicholson — Bug 995741 - Restore tabs after crash. r=mfinkle
Blocks: 995741
tracking-fennec: --- → ?
Assignee: nobody → bnicholson
tracking-fennec: ? → 31+
Duplicate of this bug: 999205
I thought that PREFS_WAS_STOPPED was set only in CrashReporter to remember that we crashed, but it looks like it's used more generally to record whether we died in the background (http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/GeckoApp.java#2058).

Since PREFS_WAS_STOPPED won't help us, we need a separate pref for recording crashes.
Attachment #8412022 - Flags: review?(mark.finkle)
Attachment #8412022 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/542f5fb83cec
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
I still can reproduce this on Nightly (2014-04-25) using Nexus 5 (Android 4.4.2) and Galaxy Nexus (Android 4.2.1)
(In reply to cristina.madaras from comment #8)
> I still can reproduce this on Nightly (2014-04-25) using Nexus 5 (Android
> 4.4.2) and Galaxy Nexus (Android 4.2.1)

This didn't make today (04/25's) build. Try tomorrow's build.
Verified as fixed on:
Build: Nightly (2014-04-27)
Devices: Nexus 5 (Android 4.4.2) and Galaxy Nexus (Android 4.2.1)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.