Closed Bug 999402 Opened 8 years ago Closed 8 years ago

Firefox fails to build on PPC64 with error: ‘GetIonScript’ is not a member of ‘js::jit

Categories

(Core :: JavaScript Engine, defect)

PowerPC
Linux
defect
Not set
blocker

Tracking

()

RESOLVED DUPLICATE of bug 997992

People

(Reporter: gustavold, Unassigned)

References

Details

Building Firefox (mozilla-central) on PPC64 fails with the following error messages:

 1:44.84 In file included from /home/buildbot/buildbot/slave/runtests/build/obj-powerpc64-unknown-linux-gnu/js/src/Unified_cpp_js_src2.cpp:132:0:
 1:44.84 /home/buildbot/buildbot/slave/runtests/build/js/src/jsinfer.cpp: In member function ‘void js::types::TypeZone::sweep(js::FreeOp*, bool, bool*)’:
 1:44.84 /home/buildbot/buildbot/slave/runtests/build/js/src/jsinfer.cpp:4337:21: error: ‘GetIonScript’ is not a member of ‘js::jit’
 1:44.84                      jit::GetIonScript(script, output.mode())->recompileInfoRef() = uint32_t(-1);


For the full build log see: http://mozillaproject.osuosl.org:8010/builders/runtests/builds/1271/steps/shell/logs/stdio
Looks like this has been introduced by Bug 988619
Blocks: 988619
And looks like I missed a dupe. Sorry, closing.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 997992
You need to log in before you can comment on or make changes to this bug.