Closed Bug 999984 Opened 8 years ago Closed 6 years ago

mail.bg sends desktop site to Firefox OS

Categories

(Web Compatibility :: Mobile, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: hsteen, Unassigned)

References

()

Details

(Whiteboard: [country-bg][serversniff][contactready])

Attachments

(1 file)

This site intends to send smartphone users a different site (smart.dir.bg) but fails to detect Firefox OS devices as smartphones. Here's a HTTP traffic analysis to show how the browser detection works:

Firefox Android redirected to http://m.mail.bg, Firefox OS not redirected

Selected HTTP response headers:

Response for: 'Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1'
Response Status: 200
content-length: 0
content-type: text/html; charset=utf-8

Response for: 'Mozilla/5.0 (Android; Mobile; rv:26.0) Gecko/26.0 Firefox/26.0'
Response Status: 302
content-length: 0
location: http://m.mail.bg
content-type: text/html; charset=utf-8
Duplicate of this bug: 999976
Some contacts from the website:

Technical department: webmaster@mail.bg
Customer Support: support@mail.bg

http://corp.mail.bg/?page_id=84
fixed
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.