The default bug view has changed. See this FAQ.

[keyboard] Long word suggestions can move/shift keyboard partially off screen so it overflows

RESOLVED FIXED

Status

Firefox OS
Gaia::Keyboard
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: aryx, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 affected)

Details

(Whiteboard: dupme)

Attachments

(2 attachments)

+++ This bug was initially created as a clone of Bug #1000000 +++
So people can celebrate in bug 1000000

Firefox OS 2.0.0.0-prerelease 20140422025146 on Geeksphone Keon

Steps to reproduce:
0. Set language to German ("Deutsch").
1. Have word suggestions enabled.
2. Find a textarea for writing, e.g. https://pastebin.mozilla.org/
3. Type "Dampfs"

Actual result:
Keyboard content moved to the right and partially hidden
See Also: → bug 1000000
blocking-b2g: --- → 2.0?
status-b2g-v2.0: --- → affected
Created attachment 8410854 [details]
screenshot of issue

For the fix to this issue, see bug 1000000 comment 16 and bug 1000000 comment 17.
ni William, is this a regression?  I'm not seeing the same symptom on my older build from master.  When the word suggestion is long the text is supposed to shrink.
Flags: needinfo?(whsu)
Keywords: qawanted

Comment 3

3 years ago
Hi, Bruce,

Yes, this is a regression bug.
I cannot reproduce it on latest V1.3 and V1.4 builds.
But, I can reproduce it on newer V2.0 Hamachi build.
Thanks.

* Reproduce steps:
 1. Enable word suggestion on keyboard settings
 2. Enable "Deutsch" keyboard on settings app
 3. Launch browser app and visit "https://pastebin.mozilla.org/"
 4. Tap the text field
 5. Tap IME key to switch to "Deutsch" keyboard
 6. Input "Dampfs"
 7. Check the UI layout

* Actual result:
 - UI truncation happened

* Build information:
 + V1.3 =>> Result: "Cannot" reproduce
  - Gaia      32a9e3db738e0b3bc44a4d4d5c16512a2617a2cf
  - Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/d7b1e90008e5
  - BuildID   20140428024001
  - Version   28.0

 + v1.4 =>> Result: "Cannot" reproduce
  - Gaia      d23e479e8a4ce0bc620acb2d7e2f82801aa4d0ea
  - Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/36f67ce46855
  - BuildID   20140428000206
  - Version   30.0a2

 + Master(V2.0)=>> Result: "Can" reproduce
  - Gaia      f0463704888881b8ed1619e8d4b0d851b0e0311b
  - Gecko     https://hg.mozilla.org/mozilla-central/rev/1d0496e30feb
  - BuildID   20140422040203
  - Version   31.0a1

Also, attach the screenshots. FYI.
Flags: needinfo?(whsu)

Comment 4

3 years ago
Created attachment 8414398 [details]
Keyboard_Layout.png

Updated

3 years ago
Keywords: qawanted
I couldn't reproduce the issue with yesterday's master. I can confirm it is present with BuilID 20140422040203, though, so maybe some changes in between "fixed" this issue.
Flags: needinfo?(whsu)
According to comment above this issue was there but is already fixed, updating the status as so.

It could be good if we could find the the regressed bug (and the fixed bug) with bisection though.
Status: NEW → RESOLVED
blocking-b2g: 2.0? → ---
Last Resolved: 3 years ago
Keywords: regression
Resolution: --- → FIXED
Whiteboard: [good first bug][mentor=timdream][mentor=rudyl][mentor-lang=zh][lang=js] → dupme

Comment 7

3 years ago
Someone solved the bug.

Because I "can" reproduce it on following build
Gaia      d8904c5af6152f5d647a93a0c31227171ddecd87
Gecko     https://hg.mozilla.org/mozilla-central/rev/ac376a4e8174
BuildID   20140423040203
Version   31.0a1

But, I "cannot" reproduce it on following build.
Gaia      bbc76bcdc937bdbaf3935351ba2d532449c63bf8 
Gecko     https://hg.mozilla.org/mozilla-central/rev/33ca5e321046
BuildID   20140423160202
Version   31.0a1

Thanks!
Flags: needinfo?(whsu)
You need to log in before you can comment on or make changes to this bug.