Bug 1000000 (megabug)

Celebrate 1000000 bugs, bring your own drinks

VERIFIED WORKSFORME

Status

()

bugzilla.mozilla.org
General
P1
normal
VERIFIED WORKSFORME
3 years ago
22 days ago

People

(Reporter: aryx, Unassigned)

Tracking

(Blocks: 1 bug)

Production
Dependency tree / graph

Details

(Whiteboard: [bug moved to bug 1000025 to let people celebrate here][good first millionth boog])

Attachments

(6 attachments, 2 obsolete attachments)

Firefox OS 2.0.0.0-prerelease 20140422025146 on Geeksphone Keon

Steps to reproduce:
0. Set language to German ("Deutsch").
1. Have word suggestions enabled.
2. Find a textarea for writing, e.g. https://pastebin.mozilla.org/
3. Type "Dampfs"

Actual result:
Keyboard content moved to the right and partially hidden
OOOOOOOOOOOOOO
Keyboard bug take the Bug 1000000 !!
We need to file another bug to get a beer from :aryx
OOOOOOOOOOOOOO
I have been reproducing this since a couple of days, on several devices (Nexus S, Desire Z for instance).
In my case, language was French.
http://nooooooooooooooo.com/
Blocks: 949551
Happy 1 000 000 bug !
https://www.youtube.com/watch?v=J---aiyznGQ
NOOOOOOOOOO!!!!!
Created attachment 8410840 [details]
screenshot of issue
(In reply to Eric Chou [:ericchou] [:echou] from comment #3)
> We need to file another bug to get a beer from :aryx

filed bug 1000011
Guess who will close this bug as soon as possible? Rudy, will you?

Comment 13

3 years ago
happy 1000000 bug!
Invalid! Invalid!
Who want to fix this bug :)?
Whiteboard: [good first bug][mentor=timdream][mentor=rudyl][mentor-lang=zh][lang=js]
render.js:getScale apparently has a bug. We don't want to set overflow on these fields as they would cause more reflows I believe.
https://github.com/mozilla-b2g/gaia/blob/master/apps/keyboard/js/render.js#L934 might also not be correct. Should be (6 * (screenInPortraitMode() ? cachedWindowWidth / 32 : cachedWindowWidth / 64)). Could cause the issue.
There have been recommendations to refile this bug to let people celebrate 1 million bugs here, so I filed the issue again as bug 1000025.
blocking-b2g: 2.0? → ---
status-b2g-v2.0: affected → ---
Component: Gaia::Keyboard → General
Product: Firefox OS → bugzilla.mozilla.org
See Also: → bug 1000025
Summary: [keyboard] Long word suggestions can move/shift keyboard partially off screen so it overflows → Celebrate 1000000 bugs, bring your own drinks
Whiteboard: [good first bug][mentor=timdream][mentor=rudyl][mentor-lang=zh][lang=js] → [bug moved to bug 1000025 to let people celebrate here]
Version: unspecified → Production
Duplicate of this bug: 1000011
Created attachment 8410855 [details]
screenshot of celebration
Attachment #8410840 - Attachment is obsolete: true
https://www.youtube.com/watch?v=NwDWdWa_wiI
Need lots of myselfinformation about these.
Flags: needinfo?(mautematico)
I meant: about cheese.

(In reply to Mauricio Navarro Miranda from comment #22)
> Need lots of myselfinformation about these.
Flags: needinfo?(mautematico)
No longer blocks: 949551
(In reply to Mauricio Navarro Miranda from comment #23)
> I meant: about cheese.

about:cheese?
Do it!

Comment 25

3 years ago
Here, have some virtual cake :-)
countdown video!

http://youtu.be/q4xz3DHKBn8

feel free to send pull requests to me for 2,000,000!!
https://github.com/yurenju/bug-counter
and that guy on left corner was writing a commit for showing a cat if reach 1,000,000, but it happended too fast so he didn't send the pull request LOL
Happy bug 1000000 to everyone!
(In reply to Yuren [:yurenju][:小朱] (PTO during 4/28~5/2) from comment #27)
> and that guy on left corner was writing a commit for showing a cat if reach
> 1,000,000, but it happended too fast so he didn't send the pull request LOL

\O/ I am here!!!!!
http://i.imgur.com/H7wZpUS.jpg This is my cat named for "bug".
woot

Comment 31

3 years ago
Congrats! #IAmAMozillian

Comment 32

3 years ago
wow, awesome!

Comment 33

3 years ago
Shiny 7-digits era!
Mom, I'm here.  \0/

Comment 35

3 years ago
A party was suggested back in 1999 - see Bug 9940.
So, a million bugs in Mozilla software is something to celebrate? :P

Seriously though, congratulations everyone :)

Comment 38

3 years ago
Whhhhoooooooooohooo :))

Congrats to bugzilla people

Updated

3 years ago
Blocks: 9940
Blocks: 1000091
Yay! :D :D
Happy bug day all!  What I would like to know is how many bugs we have fixed/resolved.
(In reply to Joshua Smith [:joshua-s] from comment #40)
> Happy bug day all!  What I would like to know is how many bugs we have
> fixed/resolved.
About 400000.
Alias: megabug
Comment on attachment 8410855 [details]
screenshot of celebration

Looks good to me!
Attachment #8410855 - Flags: review+
Comment on attachment 8410855 [details]
screenshot of celebration

I like.
Attachment #8410855 - Flags: feedback+

Comment 44

3 years ago
Created attachment 8410980 [details]
1000000.jpg

Comment 45

3 years ago
Congratulations! :)
can you share your STR on getting the million bug lol
(In reply to Manish Goregaokar [:manishearth] from comment #36)
> So, a million bugs in Mozilla software is something to celebrate? :P

Just means we're alive and kicking :)
Depends on: 123
Priority: -- → P1
QA Contact: jwz

Updated

3 years ago
OS: Gonk (Firefox OS) → All
Hardware: ARM → All

Comment 48

3 years ago
Created attachment 8411035 [details]
onemillion.jpg
http://i.imgur.com/d7vi2.gif
http://media.tumblr.com/71d9240761e38246a27935334376141c/tumblr_inline_mu9lwrzQhw1raprkq.gif
http://i.imgur.com/N0Qe0.gif

Comment 50

3 years ago
R.E.M. waited for this since 1982:
<http://www.youtube.com/watch?v=T4OGVvFXBAU>

:-)
I wonder if I should be pedantic and point out that because of holes in the bug numbers (mostly from early testing when Bugzilla was first being developed) that the one millionth bug is actually bug 1000304 ? :) (which has yet to be filed as I type this)

Comment 52

3 years ago
A million bugs? Now I can see why people keep telling me Firefox is buggy =D

needinfo Johnathan to coordinate where the drinks shall go to ;-)
Flags: needinfo?(johnath)
Yaay! :D
Huzzah!!

Comment 55

3 years ago
Congratulations, Bugzilla!
NOOOOOOO NOT AGAIN! WHEN CAN WE MFBT 1 MILLION!1!1111!

https://bugzilla.mozilla.org/show_bug.cgi?id=900000 <- thwarted!
https://bugzilla.mozilla.org/show_bug.cgi?id=800000
https://bugzilla.mozilla.org/show_bug.cgi?id=700000
This is only the Mebibug.

The real Megabug will be bug 1048576  (0x100000).

http://en.wikipedia.org/wiki/Mebibyte
Though, come to think of it, I've got that mixed up :-P
Created attachment 8411128 [details]
party-time.gif
Comment on attachment 8411128 [details]
party-time.gif

Ready to merge!
Attachment #8411128 - Flags: review+
(In reply to Benoit Jacob [:bjacob] from comment #57)
> This is only the Mebibug.
> 
> The real Megabug will be bug 1048576  (0x100000).
> 
> http://en.wikipedia.org/wiki/Mebibyte

Nope, the opposite
(In reply to alex_mayorga from comment #52)
> A million bugs? Now I can see why people keep telling me Firefox is buggy =D
> 
> needinfo Johnathan to coordinate where the drinks shall go to ;-)

The summary says "byod" so I'm clearing needinfo, but someone have one for me!
Flags: needinfo?(johnath)

Comment 63

3 years ago
Clear steps to reproduce and a low barrier to participation, so flagging [good first bug].
Whiteboard: [bug moved to bug 1000025 to let people celebrate here] → [bug moved to bug 1000025 to let people celebrate here][good first bug]
Gerv, who won the competition?  Who came closest to the actual date of filing?

Comment 65

3 years ago
Party time B|
Created attachment 8411169 [details] [diff] [review]
WIP - fix All Teh Bugs, v1

This somehow got dropped from an earlier patch.

Comment 67

3 years ago
#arewefixed1000000bugs ;)

Comment 68

3 years ago
Created attachment 8411220 [details]
Buggie-1Million.png
Comment on attachment 8411169 [details] [diff] [review]
WIP - fix All Teh Bugs, v1

Review of attachment 8411169 [details] [diff] [review]:
-----------------------------------------------------------------

::: modules/libpref/src/init/all.js
@@ +4448,5 @@
>  pref("camera.control.autofocus_moving_callback.enabled", false);
>  pref("camera.control.face_detection.enabled", false);
> +
> +// Bug 1000000
> +pref("all.the.bugs.are.fixed", true);

Nit: I believe you misspelled bugz here.
This is awesome! :D

Comment 71

3 years ago
Comment on attachment 8411169 [details] [diff] [review]
WIP - fix All Teh Bugs, v1

Ship It! All Bug Are Belong To Us!
Attachment #8411169 - Flags: review+

Comment 72

3 years ago
(In reply to Mike Hoye [:mhoye] from comment #63)
> Clear steps to reproduce and a low barrier to participation, so flagging
> [good first bug].

But it's not the first bug, it's the one millionth boog!
Awesome :) :) :) Party time ;)
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #72)
> But it's not the first bug, it's the one millionth boog!

Fixed.
Whiteboard: [bug moved to bug 1000025 to let people celebrate here][good first bug] → [bug moved to bug 1000025 to let people celebrate here][good first millionth bug]

Comment 75

3 years ago
Correcting whiteboard.
Whiteboard: [bug moved to bug 1000025 to let people celebrate here][good first millionth bug] → [bug moved to bug 1000025 to let people celebrate here][good first millionth boog]

Updated

3 years ago
Blocks: 1000411
This reminded me of http://blog.gerv.net/2013/08/bugzilla-1000000-bug-sweepstake/

Comment 77

3 years ago
> 1000000 GET
> Comment 77 GET
w00t
There aren't 1 000 000 bugs in Bugzilla, they are all features!

Comment 80

3 years ago
Comment on attachment 8411169 [details] [diff] [review]
WIP - fix All Teh Bugs, v1

Review of attachment 8411169 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, but bugs should be boogs imo, don't want users getting confused :)

Comment 81

3 years ago
Yééé ! 1 000 000 !!!

A new world beginning!

Comment 82

3 years ago
Next step,

1 000 000 000

Congratulation's to all in Bugzilla (^_^)
It's a good chance for digging out some history of Mozilla Bugzilla.  It seems the oldest valid bug is bug 507, which was marked INVALID.  I wonder what's the oldest OPEN bug right now?
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #83)
> It's a good chance for digging out some history of Mozilla Bugzilla.  It
> seems the oldest valid bug is bug 507, which was marked INVALID.  I wonder
> what's the oldest OPEN bug right now?

Bug 540, and we have 57 bugs with bug id < 10000 remain OPEN.
yay!! Congrats to all in Bugzilla :)

Comment 86

3 years ago
Should we uplift the patch for this bug, https://bugzilla.mozilla.org/attachment.cgi?id=8411169, to fix all bug?
No longer depends on: 123
QA Contact: jwz

Comment 87

3 years ago
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #83)
> It's a good chance for digging out some history of Mozilla Bugzilla.  It
> seems the oldest valid bug is bug 507, which was marked INVALID.

xref Bug 35 - (firstBug) Navigator does not free preference hash table when exit.

Comment 88

3 years ago
(In reply to Ken Chang[:ken] from comment #86)
> Should we uplift the patch for this bug,
> https://bugzilla.mozilla.org/attachment.cgi?id=8411169, to fix all bug?

This needs to land on trunk first.
Created attachment 8411866 [details] [diff] [review]
WIP - fix All Teh Bugs, v2

Incorporating conflicting review feedback.
Attachment #8411169 - Attachment is obsolete: true
Everyone knows MegaBugs are traditionally measured in powers of 2, so our target is 1,048,576.  48K more to go, people.

In the absence of Brendan, I'm asserting I have more authority to decide this issue than bsmedberg.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID

Comment 91

3 years ago
Party: INVALID
Bug 1000000, yay! INVALID? Bah!

Comment 93

3 years ago
More like: "Party? WORKSFORME!"

Updated

3 years ago
Status: RESOLVED → VERIFIED
Resolution: INVALID → WORKSFORME
Congratulations, Bugzilla!

Comment 95

3 years ago
Ooh, Conga Rats :), just discovered :>

Comment 96

3 years ago
I supposed this bug report would exist, but I'm still quite impressed that you managed to time it correctly to get the right bug ID.  Now let's see if we reach 100 comments (we're close).

Doesn't work on 6-digit display; may have compatibility issues with i18n if the language doesn't have a word for "million".  Crashes on Firefox versions for architectures with less than 20 bits.

Wake me up when we reach a round bug number, such as 1048576.

Comment 97

3 years ago
Disregard; just realized you cheated by renaming the bug.  Cheaters.

Comment 98

3 years ago
It's not cheating, it's engineering ;-P

Comment 99

3 years ago
Beer for this bug :)

Comment 100

3 years ago
1000000 bugs and 100 comments!  Congratulations to the Mozilla team for their effort, and to all who help them making this community work.
Nice!!
You need to log in before you can comment on or make changes to this bug.