Closed Bug 1000252 Opened 6 years ago Closed 6 years ago

Update channel field has no information displayed

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: viorela, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached image screenshot.png
Update channel field from more info panel is not populated in the latest master build

# ENV:
Device: Hamachi
Gaia      d8904c5af6152f5d647a93a0c31227171ddecd87
Gecko     https://hg.mozilla.org/mozilla-central/rev/ac376a4e8174
BuildID   20140423040203
Version   31.0a1
ro.build.version.incremental=eng.tclxa.20131223.163538
ro.build.date=Mon Dec 23 16:36:04 CST 2013


Stacktrace:
Traceback (most recent call last):
File "/var/jenkins/workspace/b2g.hamachi.mozilla-central.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.6-py2.7.egg/marionette/marionette_test.py", line 163, in run
testMethod()
File "/var/jenkins/workspace/b2g.hamachi.mozilla-central.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_device_info.py", line 26, in test_that_device_info_is_populated
self.assertTrue(len(getattr(more_info, item)) > 0)
AssertionError: False is not true

This issue is reproducible locally, and also manually

# STR:
1. Flash your device with the latest v1.5 build
2. Launch Settings app
3. Tap Device Information, then More information

# Expected results:
The update channel field should be populated

# Actual results: 
The update channel field has no information displayed
Does this happen on 1.4?
blocking-b2g: --- → 2.0?
Keywords: qawanted, regression
No, this is not happening on v1.4 latest build.
Note: Finding a regression window in B2G Inbound Engineering for this bug is currently blocked by bug 1000617.  


Tinderbox Regression Window

Last Working

Environmental Variables: 
Device: Buri
BuildID: 20140422182655 
Gaia: 0a4d2dea25a7162ee43db3a0db817798b70e7521 
Gecko: 35737ab92f9e 
Version: 31.0a1 
Firmware Version: v1.2-device.cfg 

First Broken

Environmental Variables: 
Device: Buri 
BuildID: 20140422193155 
Gaia: d8904c5af6152f5d647a93a0c31227171ddecd87 
Gecko: ac376a4e8174 
Version: 31.0a1 
Firmware Version: v1.2-device.cfg 

Last Working Gaia First Broken Gecko: Issue DOES reproduce
Gaia: 0a4d2dea25a7162ee43db3a0db817798b70e7521 
Gecko: ac376a4e8174

First Broken Gaia Last Working Gecko: Issue does NOT reproduce.
Gaia: d8904c5af6152f5d647a93a0c31227171ddecd87 
Gecko: 35737ab92f9e

Gecko Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=35737ab92f9e&tochange=ac376a4e8174
QA Contact: jharvey
This was caused by bug 995206.

Jan - Can you take a look?
Blocks: 995206
Flags: needinfo?(janx)
I think this was actually caused by bug 984962, the gaia counterpart to bug 995206, which I landed too early (the gecko-part needed to land first, but it was backed out after I merged the gaia-part).

The gecko patch has re-landed since, and rolled to mozilla-central, so this failure should only have been temporary.

I can't reproduce it on latest Firefox OS. Viorela, can you please update and confirm that this problem was fixed?
Flags: needinfo?(janx) → needinfo?(viorela.ioia)
Leaving qawanted to check comment 5.
Keywords: qawanted
Issue does NOT reproduce in the latest Buri Master Build.

Update channel now displays the correct information.

Environmental Variables:
Device: Buri MOZ
BuildID: 20140425040203
Gaia: facd91d31db983a60c7f1035ca01b727c7a1de65
Gecko: 2b02d933c39a
Version: 31.0a1
Firmware Version: v1.2-device.cfg
Flags: needinfo?(viorela.ioia)
Keywords: qawanted
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
blocking-b2g: 2.0? → ---
You need to log in before you can comment on or make changes to this bug.