[B2G][Settings] Wifi cannot obtain IP address or forget network

VERIFIED FIXED

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: dharris, Assigned: vchang)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:1.3T+, b2g-v1.3 unaffected, b2g-v1.3T verified)

Details

(Whiteboard: [tarako-exploratory][ETA:4/30][depend on sprd305892][tarako_only], )

Attachments

(2 attachments)

Posted file Logcat, Firewatch
Description:
Wifi is trying to obtain IP address but never will. If the user tries to forget the network while this is happening, the network will say it is now connected. The wifi is not actually connected though, and the network cannot be forgotten by tapping 'forget network'

Prerequisites: Airplane mode is off, Wifi is not connected

Repro Steps:
1) Update a Tarako to BuildID: 20140423014003
2) Go to Settings App> Wifi> Select a network and connect to it
3) Go back to settings and turn on Airplane mode
4) Go back into Wifi and turn wifi back on (only tap on it one time, it may take a moment for it to turn on)
5) Tap on the network that was connected to in step 2
6) Tap on 'Forget network'

Actual:
Wifi now says it is connected when it is not, and tapping 'forget this network' does not forget the network

Expected:
Wifi stop trying to obtain IP address and network is forgotten

1.3t Environmental Variables:
Device: Tarako 1.3t
BuildID: 20140423014003
Gaia: 9aa9b04049f0291b124c50e0f9c3ce0e1f547725
Gecko: 5dc3e5ec4178
Version: 28.1
Firmware Version: sp6821

Keywords: Wi-Fi, Disable, Initializing

Repro frequency: 90%
See attached: Logcat, Firewatch, Video - https://www.youtube.com/watch?v=4IZYgeVWMPQ&edit=vd
The above issue does not occur on the Buri 1.3

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140422024003
Gaia: cab7de82832d00696807ae48ec277bd642b82a0a
Gecko: c35695cc384c
Version: 28.0
Firmware Version: v1.2-device.cfg
I think this might have to do with bug 999388? 
Just in case noming.
blocking-b2g: --- → 1.3T?
triage: 1.3T+ to fix wifi stability bug
ni? Vincent / James
blocking-b2g: 1.3T? → 1.3T+
Flags: needinfo?(vchang)
Flags: needinfo?(james.zhang)
Loop Xinhe.
Flags: needinfo?(james.zhang) → needinfo?(xinhe.yan)
Vincent, this look like API issue (API not returning the correct info). Would you mind take a look at it first and ni? me if it turn out to be an UI issue? Thanks!
Component: Gaia::Settings → Wifi
Vincent, if you find our friend can handle this bug afterwords, please directly reassign. Thanks.
Assignee: nobody → vchang
message "pbc wps failed" when the wifi is connected after data.
The only solution to power cycle the phone.
FFOS v1.4 is the error with the update of the day 25/04/2013.
Mobile Peak.
I think the root cause should be Bug 999388. Not sure if you could help to apply the patch in Bug 999388 and verify again ?
Flags: needinfo?(vchang)
Depends on: 999388
This patch should be applied to v1.3t only if partner helps to fix Bug 999388 in gonk/hal.
Attachment #8412360 - Flags: review?(chulee)
No idea how to patch me suggesting

It is the same mistake in the update v1.1 of the day 20/08/2013 (20,130,820,003,724).
By upgrading 20130822004058 day, the wifi problem disappears.
Whiteboard: [tarako-exploratory] → [tarako-exploratory][ETA:4/30]
Comment on attachment 8412360 [details] [diff] [review]
Patch v1.0 for v1.3t branch only. r=chulee

Review of attachment 8412360 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, but have to be confirmed after bug 999388 is resolved.
So f+ for now.
Attachment #8412360 - Flags: feedback+
Joe/Steven, can you please have a talk with partner? Without their fix, the patch of this bug isn't able to be landed.
Flags: needinfo?(styang)
Flags: needinfo?(jcheng)
Flags: needinfo?(james.zhang)
Flags: needinfo?(james.zhang)
Whiteboard: [tarako-exploratory][ETA:4/30] → [tarako-exploratory][ETA:4/30][depend on sprd305892]
Flags: needinfo?(jcheng)
Flags: needinfo?(styang)
Flags: needinfo?(xinhe.yan)
I have verified this patch together with the patches in Bug 997791 in Tarako. The wifi and wifi hotspot test results look good.  

https://bugzilla.mozilla.org/attachment.cgi?id=8409631
https://bugzilla.mozilla.org/attachment.cgi?id=8409632
https://bugzilla.mozilla.org/attachment.cgi?id=8410864
Comment on attachment 8412360 [details] [diff] [review]
Patch v1.0 for v1.3t branch only. r=chulee

Review of attachment 8412360 [details] [diff] [review]:
-----------------------------------------------------------------

r+ based on Comment 13.
Attachment #8412360 - Flags: review?(chulee) → review+
Attachment #8412360 - Attachment description: resetState.v1.0.patch → Patch v1.0 for v1.3t branch only. r=chulee
Keywords: checkin-needed
Whiteboard: [tarako-exploratory][ETA:4/30][depend on sprd305892] → [tarako-exploratory][ETA:4/30][depend on sprd305892][tarako-only]
Flags: needinfo?(fabrice)
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/6d4d970ee0e3
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(fabrice)
Resolution: --- → FIXED
Whiteboard: [tarako-exploratory][ETA:4/30][depend on sprd305892][tarako-only] → [tarako-exploratory][ETA:4/30][depend on sprd305892][tarako_only]
Verified as fixed on the latest Tarako build.

1.3T Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140602014001
Gaia: 335486c42498fa7a93c21e4d6121199728602ab8
Gecko: 55e4d83019e5
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29

Able to forget WiFi network as expected.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.