Closed Bug 999388 Opened 6 years ago Closed 6 years ago

[Wifi][tarako] CTRL-EVENT-TERMINATING is not sent from gonk after close wpa_supplicant connection

Categories

(Firefox OS Graveyard :: Vendcom, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T fixed)

RESOLVED FIXED
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- fixed

People

(Reporter: vchang, Assigned: jason.liu)

References

Details

(Whiteboard: [tarako_only][partner-blocker][sprd305892][POVB])

Attachments

(1 file)

The wpa_supplicant's behavior is quite different in Tarako platform. For instance, 
1. It doesn't send CTRL-EVENT-TERMINATING. 
2. closeSupplicantConnection command will receive CTRL-EVENT-TERMINATING event twice while connecting is in progress.
It causes many problems while we are trying to fix Bug 997791.
So we would like to backout the patches in bug 986365 and 993821 first because we don't observe the same bug in Tarako.
Assignee: nobody → vchang
blocking-b2g: --- → 1.3T?
Blocks: 997791
Comment on attachment 8410221 [details] [diff] [review]
Patch v1.0 for 1.3t branch only, don't merge to m-c and others branch

Review of attachment 8410221 [details] [diff] [review]:
-----------------------------------------------------------------

This is a workaround for tarako to meet the schedule.
If tarako want to use antoher branch, its gonk SHOULD be fixed first.
Also, if tarako fixed the issue during 1.3t duration, the patches being backouted by this patch might need to be stored.
Attachment #8410221 - Flags: review?(chulee) → review+
Chuck, can you be more specific about what should be fixed in GONK? Thanks
Whiteboard: [tarako_only]
Flags: needinfo?(chulee)
Gonk should send out CTRL-EVENT-TERMINATING after gecko terminates wpa_supplicant.
Flags: needinfo?(chulee)
hi James, can your team fix this in the gonk?
and in the team time, your team may take this patch in your branch to fix it temporarily. thanks
Flags: needinfo?(james.zhang)
Flags: needinfo?(james.zhang)
Whiteboard: [tarako_only] → [tarako_only][partner-blocker][sprd304785]
(In reply to Joe Cheng [:jcheng] from comment #5)
> hi James, can your team fix this in the gonk?
> and in the team time, your team may take this patch in your branch to fix it
> temporarily. thanks

Loop Xinhe.
Flags: needinfo?(xinhe.yan)
Don't do the backouts yet and lets wait for response in comment #6 by partner which is the right way to fix the bug
blocking-b2g: 1.3T? → 1.3T+
According to comment 2, 4 and 6, it is great that partner want to fix this bug. Change the component and assignee.
Assignee: vchang → xinhe.yan
Component: Wifi → Vendcom
Flags: needinfo?(xinhe.yan)
Blocks: 999363
Blocks: 1000518
Summary: [Wifi][tarako]backout patches in bug 986365 and 993821 for v1.3t branch → [Wifi][tarako] CTRL-EVENT-TERMINATING is not sent from gonk after close wpa_supplicant connection
Whiteboard: [tarako_only][partner-blocker][sprd304785] → [tarako_only][partner-blocker][sprd305892]
Whiteboard: [tarako_only][partner-blocker][sprd305892] → [tarako_only][partner-blocker][sprd305892][POVB]
Xinhe, do you mind providing some update here? thanks
Flags: needinfo?(xinhe.yan)
Jason&James already push this bug in our side, but I have no feedback now.
Flags: needinfo?(xinhe.yan)
Assignee: xinhe.yan → jason.liu
Duplicate of this bug: 1001387
We have worked around this issue.


commit 6e5aa4d4e5b5ba66ce3db24806a4b4017560801e
Author: Xinhe Yan <xinhe.yan@spreadtrum.com>
Date:   Sat May 3 14:54:30 2014 +0800

    Bug #305892 sleep one second to wait gecko receive CTRL-EVENT-TERMINATING
    
    [bug number  ] 305892
    [root cause  ]
    [changes     ]
    [side effects] unknown
    [self test   ] sp6821a
    [reviewers   ]
    
    Change-Id: I7dd0a01d02cf9a2dcac26c7fb33b9910aa23ff88
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This commit is in hardware/libhardware_legacy.
You need to log in before you can comment on or make changes to this bug.