Closed Bug 1001036 Opened 6 years ago Closed 2 years ago

[B2G][Tarako][Contacts][Gallery]User interface issue with Select option when attempting to add a picture to a new contact from Gallery

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 affected, b2g-v1.3T affected)

RESOLVED WONTFIX
Tracking Status
b2g-v1.3 --- affected
b2g-v1.3T --- affected

People

(Reporter: mclemmons, Unassigned)

References

()

Details

(Whiteboard: [tarako-exploratory])

Attachments

(4 files)

Attached file Firewatch log
User taps Contacts App and New Contact. User selects Add picture from within the Gallery App. When Gallery appears, the Select header is in white with a blue < sign. This is inconsistent with going directly through Gallery and the select option and the Select option is within a dark background with a blue x sign. 

Repro Steps:
1) Updated Tarako to BuildID: 20140424014003
2) Tap Contacts App, New Contact and Add a picture
3) Select Gallery

Actual:
The Select header is within a white background

Expected:
The Select header is within a dark background, similarly when user goes directly through the Gallery App

Notes: 
Repro frequency: (10/10, 100%) 
See attached: Logcat, Firewatch, Video clip = https://www.youtube.com/watch?v=CtnwpHff_XA

Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140424014003
Gaia: 706f474230432c8cb01e124aee2c055ec902aa1d
Gecko: 26ef3dded9ff
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac
This issue does reproduce on 1.3 Buri. Following the STR in Comment 0 the presentation displays the Select text in a white background within the header. 

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140424024004
Gaia: 32a9e3db738e0b3bc44a4d4d5c16512a2617a2cf
Gecko: 97ca2fdf3cf4
Version: 28.0
Firmware Version: v1.2-device.cfg
I'm not sure if this is as designed.  asking UX for input.
Flags: needinfo?(firefoxos-ux-bugzilla)
Flagging Tif on this. Tif, please reassign as appropriate.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(tshakespeare)
I'm flagging Amy Lee (visual designer) to confirm the white header with blue buttons. I believe this is part of the visual refresh and gallery hasn't been done it. Amy can you confirm?

For the interaction side of things (the back arrow instead of an X) - I am doing some investigations and will update when I'm done. Thanks!
Actually flagging Amy this time...see above comment
Flags: needinfo?(amlee)
(In reply to Tiffanie Shakespeare from comment #6)
> Actually flagging Amy this time...see above comment

Hi, 

This looks like a duplicate bug of Bug 1000050. I had replied to that bug about the headers. It should be dark (matching the one in gallery). 

Thanks!
Flags: needinfo?(amlee)
Attached image Select Photo screen
I can confirm that we should be using an X in both the select screen and the subsequent screen that is titled Crop.

Both should be updated to use the X instead of the <.
Flags: needinfo?(tshakespeare)
Attached image Crop Photo screen
This should also have the same visual design Amy mentions and use the X.
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.