Closed Bug 1001167 Opened 6 years ago Closed 6 years ago

Session Restore doesn't handle a corrupted sessionstore.js file properly

Categories

(Firefox :: Session Restore, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 32
Tracking Status
firefox29 --- verified
firefox30 + verified
firefox31 + verified
firefox32 --- verified
b2g-v1.4 --- fixed

People

(Reporter: vladan, Assigned: ttaubert)

References

Details

(Keywords: regression, Whiteboard: p=3 s=it-32c-31a-30b.1 [qa!])

Attachments

(2 files)

Nightly can't restore the session from the older-format sessionstore.js in bug 394492 (understandable), but surprisingly, it also doesn't overwrite the "corrupted" sessionstore.js with the new session.

See attachment for the error log.
Regression from bug 887780, even though this was probably broken already before.
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
Keywords: regression
Confirmed that the xpcshell test fails locally without the patch applied.
Attachment #8412562 - Flags: review?(smacleod)
Comment on attachment 8412562 [details] [diff] [review]
0001-Bug-1001167-Don-t-let-invalid-sessionstore.js-files-.patch

Review of attachment 8412562 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/sessionstore/test/unit/xpcshell.ini
@@ +10,5 @@
>  [test_backup.js]
>  [test_backup_once.js]
>  [test_startup_nosession_async.js]
>  [test_startup_session_async.js]
> +[test_startup_invalid_session.js]

Note to self, guess I should put this in alphabetical order.
At a quick glance, I believe that bug 883609 will also fix this.
(In reply to David Rajchenbach Teller [:Yoric] (please use "needinfo?" - I'll be away on April 9th-16th) from comment #5)
> At a quick glance, I believe that bug 883609 will also fix this.

From what I can tell the current patch wouldn't. But even if so I would totally prefer to fix this on its own just because it's a lot easier to uplift to Firefox 30, which we should do.
Attachment #8412562 - Flags: review?(smacleod) → review+
https://hg.mozilla.org/mozilla-central/rev/08dab2dcb519
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 32
Comment on attachment 8412562 [details] [diff] [review]
0001-Bug-1001167-Don-t-let-invalid-sessionstore.js-files-.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 887780 (and maybe before)
User impact if declined: SessionStore is broken and doesn't save user data when starting up with a corrupt session file.
Testing completed (on m-c, etc.): Good on m-c, contains a test that covers this issue.
Risk to taking this patch (and alternatives if risky): Tiny patch with a very low risk.
String or IDL/UUID changes made by this patch: None.
Attachment #8412562 - Flags: approval-mozilla-beta?
Attachment #8412562 - Flags: approval-mozilla-aurora?
Attachment #8412562 - Flags: approval-mozilla-beta?
Attachment #8412562 - Flags: approval-mozilla-beta+
Attachment #8412562 - Flags: approval-mozilla-aurora?
Attachment #8412562 - Flags: approval-mozilla-aurora+
Flags: firefox-backlog+
Whiteboard: p=3 s=it-32c-31a-30b.1 [qa+]
QA Contact: cornel.ionce
Verified fixed on Latest Nightly (build ID: 20140505030202) and latest Aurora (build ID: 20140505004003).

Testing was performed on Windows 7 64bit, Windows 8.1 32bit, Ubuntu 14.04 32bit and Mac OS X 10.9.
Depends on: 1005942
Comment on attachment 8412562 [details] [diff] [review]
0001-Bug-1001167-Don-t-let-invalid-sessionstore.js-files-.patch

[Triage Comment]
We are taking this for a non-urgent 29.0.1 release.
Attachment #8412562 - Flags: approval-mozilla-release+
Mozilla/5.0 (Windows NT 6.3; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Microsoft Surface Pro 2)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (X11; Linux i686; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0

Verified fixed on Firefox 30 beta 2, build ID: 20140505140302.
Also verified as fixed using Firefox 29.0.1, build ID: 20140506152807.

Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Microsoft Surface Pro 2)
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0
Status: RESOLVED → VERIFIED
Whiteboard: p=3 s=it-32c-31a-30b.1 [qa+] → p=3 s=it-32c-31a-30b.1 [qa!]
Blocks: 887780
Still not working crashed while playing an flash (graphic acceleration disabled!!!) 10 windows each with many tabs (hundreds...) till vers. FF 28.0  no problem..., now that about restore page empty, if I go ex. google.com and then back to about restore page the list with windows still empty even i copy in my FF Mozilla profile folder my backed up : sessionstore.bak, sessionstore.js, and sessionCheckpoints.json (containing: {"profile-after-change":true,"final-ui-startup":true,"sessionstore-windows-restored":true} or 
{"profile-after-change":true,"final-ui-startup":true,"sessionstore-windows-restored":true,"quit-application-granted":true,"quit-application":true,"sessionstore-final-state-write-complete":true,"profile-change-net-teardown":true,"profile-change-teardown":true,"profile-before-change":true}
following some tutorial found online (on same acting from FF29.0.1 yesterday night this procedure worked... now not!!!!!!!!!!!!!!)

I even replaced sessionstore.js with sessionstore.bak by changing extension no luck no restore button on start page, no restore session om menu item History I'm desperate to try to restore from history >1000 tabs in 10 windows!!!!!!!!

Please correct this or i'll never use Mozilla TOOOOOOOOOOOO FAULLTY !!!!!!

thx!!!
Still broken!!!!!! > FF 29.0.1 many crashes daily: works only by making an backup of sessionstore.bak, sessionstore.js, and sessionCheckpoints.json BEFORE restarting FF 29.0.1 in an folder ex. DD.MM.YYYY.z (z=1...n) restarting with option in Options > General > Show my windows and tabs from last time  >>> close Mozilla thru Exit from File menu or close button of the window, copy those files backed up earlier back in your profile folder by overwriting whats there... restart >>>> with option  in Options > General > Show my homepage close it from Exit again and restart Mozilla.... and chose restore icon from down options in the homepage > will appear about:restore page with the list of windows and tabs from previous session >>> click Restore button and voila ! wait the full process and wait for next crash :):):) which will happen soon !!!!!!!!!!!!!!!!!!!!
garfield1234, thanks for reporting. I unfortunately can't figure out what's going wrong for you other than that you seem to have a lot of crashes. If this is an ongoing issue can you please file a new bug? This bug is not the right place for that, thank you.
You need to log in before you can comment on or make changes to this bug.