Closed Bug 1001298 Opened 6 years ago Closed 6 years ago

[EMAIL] update search UI to latest VD

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

x86
macOS
defect
Not set

Tracking

(b2g-v2.0 fixed)

VERIFIED FIXED
2.0 S2 (23may)
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: arnau, Assigned: arnau)

References

Details

Attachments

(5 files)

Attached image list view
Email app is using an outdated UI for search fields, both in the email list and in the search view (the input should not be inside a header).
Assignee: nobody → arnau
Depends on: 992994
Comment on attachment 8421700 [details] [review]
patch in github

I am a bit confused, so switching off review until we can get some things sorted out:

Bug 951091 is filed for updating the visual design for search, and that bug is part of the meta bug 950208 for the 2.0 email visual refresh, at least that was my understanding.

The design guide in bug 951091 uses an orange header background for the search box, at least in search mode, which does not seem to match these changes.

So I am curious if you access to some other visual design guide or if bug 951091's visual design guide is out of date.

Also, in general, I am going to be starting a visual refresh branch for email to hold all the changes for the bugs associated with meta bug 950208, so that I can land one larger changeset that easier to roll back if issues.

However, I want to ask you and :ivanovpavel for how best to coordinate our efforts, as I feel I could avoid doing some work that you two may be doing already :)

So needinfoing to get a plan sorted.
Attachment #8421700 - Flags: review?(jrburke)
Flags: needinfo?(pivanov)
Flags: needinfo?(arnau)
James, Sorry for the confusion here. I had not seen the visuals in bug 951091.
AFAIK Inputs inside the header where obsolete, so I applied in my patch the same VD we have in Contacts and Music.
I'll talk to Patryk to see if we could have some consistency between apps.
Flags: needinfo?(arnau)
Maybe Patryk can help us with this because I work only on headers and I don't know anything about search in headers.
Flags: needinfo?(pivanov)
Hi guys, Sorry for the confusion. The search mode spec in bug 951091 was for 1.4 only. Since we have new search mode landed, We should make the email search bar design to match with Contacts and Music. Thanks!
Hi Arnau,
Just want to double check, is this search bar already been UI reviewed by any visual owner of Contact or Music? Because it looks like still have some alignment issues on search field. Just want to make sure this is the correct one we can follow. 

And beside the search bar, I think the edit button on the top of the keyboard should be removed is this update. Thanks!
Cool, so ni for Vicky and Peter to double check :)
Flags: needinfo?(vpg)
Flags: needinfo?(pla)
Thanks Arnau,
The screenshots you show are OK and in general, what I feel most important is to keep consistency in the use of our components.
Thanks!
Flags: needinfo?(vpg)
Comment on attachment 8421700 [details] [review]
patch in github

And I heard from the visual designer for email, Fang, and it was confirmed that this is the correct styling to use.

My summary then: for building blocks-type of shared UI elements, I should take the parts you all specify, and if it is something email-specific, then I will use those other designs in the email bugs.

Thanks for helping be get up to speed. Flipping review back to me, should get to it today.
Attachment #8421700 - Flags: review?(jrburke)
Flags: needinfo?(pla)
Awesome, thanks James
Attachment #8421700 - Flags: review?(jrburke) → review+
Merged: d2942c3c5fae75d9e25ade8f3a0b8e7a790dff20
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S2 (23may)
[Environment]
Gaia      101c500903a2477f9de1ea5ce523b9e0be4d45d0
Gecko     https://hg.mozilla.org/mozilla-central/rev/41a54c8add09
BuildID   20140519040204
Version   32.0a1
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013

[Result]
PASS
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.