Closed Bug 1001471 Opened 6 years ago Closed 6 years ago

My back button is trying to eat the plugin notification icon

Categories

(Firefox :: Theme, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 32
Tracking Status
firefox30 --- unaffected
firefox31 --- verified
firefox32 --- verified

People

(Reporter: mossop, Assigned: dao)

References

Details

(Keywords: regression, Whiteboard: [bugday-20140430] )

Attachments

(2 files)

Attached image screenshot
Remains after an update and restart to current nightly. Pages without plugins look fine.
Tentatively blaming bug 997131, just based on timing.
Blocks: 997131
Keywords: regression
Depends on: 1001995
Duplicate of this bug: 1002644
Hardware: x86 → All
Duplicate of this bug: 1003058
Attached patch patchSplinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #8414466 - Flags: review?(mdeboer)
Component: Toolbars and Customization → Theme
Comment on attachment 8414466 [details] [diff] [review]
patch

I approve! Thanks for fixing this Dão.
Attachment #8414466 - Flags: review?(mdeboer) → review+
Duplicate of this bug: 1003281
https://hg.mozilla.org/mozilla-central/rev/70f607cb0e35
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Comment on attachment 8414466 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 997131
User impact if declined: small visual glitch
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): very low
String or IDL/UUID changes made by this patch: none
Attachment #8414466 - Flags: approval-mozilla-aurora?
Hi,

I wasn't able to reproduce it in the affected version (merely because I don't know how to run an automatic update to a nightly which is *not* the latest nightly - but the affected one).

On the other hand, I can confirm that the bug is no longer present in the latest nightly: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140429030201 CSet: d7c07694f339.

Is this enough to consider it verified? Or is there a way to force the automatic update to a specific nightly, so to have the usual verification process?

Thanks,
Francesca
Whiteboard: [bugday-20140430]
Comment on attachment 8414466 [details] [diff] [review]
patch

Hello Francesca ;)
Attachment #8414466 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Francesca, I think you can ignore the updating process, and just look at the previously affected version of Nightly from the 25th, which I think is here: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-04-25-03-02-09-mozilla-central/.  Then you could check to see if you see the original bug.
Flags: needinfo?(madamezou)
Whiteboard: [bugday-20140430] → [bugday-20140430] [good first verify]
Hi Liz,

(In reply to Liz Henry :lizzard from comment #14)
> Francesca, I think you can ignore the updating process, and just look at the
> previously affected version of Nightly from the 25th, which I think is here:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-04-25-03-02-09-
> mozilla-central/.  Then you could check to see if you see the original bug.

thanks for the hint!
I've been able to verify the bug on the 25th Nightly build, and I can confirm is no longer present in:

- latest Nightly Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140512030202 CSet: 20ca234fd62b

- latest Aurora Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 ID:20140512004006 CSet: 77f4f17f54d3
Status: RESOLVED → VERIFIED
Whiteboard: [bugday-20140430] [good first verify] → [bugday-20140430]
Flags: needinfo?(madamezou)
You need to log in before you can comment on or make changes to this bug.