Closed Bug 1001690 Opened 6 years ago Closed 6 years ago

[B2G][Tarako][FMRadio][Audio][Headphones]Lower volume levels not audible using headphones on device

Categories

(Firefox OS Graveyard :: Vendcom, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED FIXED
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: mclemmons, Unassigned)

References

Details

(Whiteboard: [tarako-exploratory][POVB])

Attachments

(2 files)

Attached file Firewatch Log
User inserts headphone jack into device. User taps the FM Radio App and selects a station. When the user carefully adjusts the volume level using the side volume adjusters, the lower levels cannot be heard (tenth square bar and below), while the higher level bars can be heard but not invasive. In comparison on the Buri, reducing the lower level to the first square bar, audio can still be heard while the highest level is at a level that is dangerously loud. The concern is with the Tarako, the levels may be too low for a person with hearing disabilities and adjustments do not assist as well as with the Buri.

Prerequisites:
Insert headphones into device

Repro Steps:
1) Updated Tarako to BuildID: 20140424014003 
2) Tap FM Radio App and select a valid station (example 95.7 in Seattle area)
3) Carefully adjust the volume level up and down with the side adjusters and observe findings

Actual:
Tenth square bar on the audio measurement bar and below demonstrates difficult to hear or no sound. 

Expected:
Tenth square bar on the audio measurement bar and below demonstrate some sound level. 

Notes: 
Repro frequency: 10/10 – 100 percent 

See attached: Logcat, Firewatch

Environmental Variables: 
Device: Tarako 1.3T MOZ 
BuildID: 20140424014003 
Gaia: 706f474230432c8cb01e124aee2c055ec902aa1d 
Gecko: 26ef3dded9ff 
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac
This issue does not reproduce on 1.3 Buri. Following STR from Comment 0, audio can be heard at the first square bar on the audio measurement bar and demonstrates some sound level. 

Environmental Variables: 
Device: Buri 1.3 MOZ 
BuildID: 20140424024004 
Gaia: 32a9e3db738e0b3bc44a4d4d5c16512a2617a2cf 
Gecko: 97ca2fdf3cf4 
Version: 28.0
Firmware Version: v1.2-device.cfg
Hi mclemmons, Could you take a look to see what the outcome for the music app and video app is please?
Flags: needinfo?(mclemmons)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #3)
> Hi mclemmons, Could you take a look to see what the outcome for the music
> app and video app is please?

The outcome on both the music and video Apps were similar to FM Radio on the Tarako. 

The lowest volume bar was not audible on 1.3T for Music and increasing to the maximum bar was audible but not similar to 1.3 Buri. On 1.3 Buri, the lowest volume bar was audible and increasing to the maximum demonstrated uncomfortable listening experiences due to the volume intensity. 

The lowest volume bar was not audible on 1.3T for Video and it took increasing to the maximum to hear anything. On Buri, the lowest bar could be heard and increasing minimally allowed sound to be heard moreso. Reaching the maximum bar was not necessary.

Below are the Variables during testing. 

Environmental Variables: 
Device: Tarako 1.3T MOZ 
BuildID: 20140424014003 
Gaia: 706f474230432c8cb01e124aee2c055ec902aa1d 
Gecko: 26ef3dded9ff 
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac 

Environmental Variables: 
Device: Buri 1.3 MOZ 
BuildID: 20140424024004 
Gaia: 32a9e3db738e0b3bc44a4d4d5c16512a2617a2cf 
Gecko: 97ca2fdf3cf4 
Version: 28.0
Firmware Version: v1.2-device.cfg
Flags: needinfo?(mclemmons)
Jason and I made a test also where we tried both music and fm radio on our build, which is newer than the one in comment 4.  The bottom three bars are inaudible.  Middle 4 are barely audible.  

Gaia      8895b180ed636069473703d0e7b73086989601ce
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/7caf4b5abfce
BuildID   20140428014001
Probably a vendor problem.

Sam - Do you know why the volume is far lower than expected on Tarako?
Component: Gaia::FMRadio → Vendcom
Flags: needinfo?(sam.hua)
i will check the audio parameters with our audio team.
Flags: needinfo?(sam.hua)
Whiteboard: [tarako-exploratory] → [tarako-exploratory][POVB]
Duplicate of this bug: 1004599
We have fixed it on my side.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.