clicking links on this page doesn't produce focus rings

RESOLVED DUPLICATE of bug 65917

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 65917
17 years ago
16 years ago

People

(Reporter: Niels Aufbau, Assigned: Marc Attinasi)

Tracking

({testcase})

Trunk
mozilla1.1alpha
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Steps to reproduce:
1. Middle-click several numbered links links on http://x-3.net/category/teens/.
2. Spend a minute or two looking at the windows you just opened (optional).3.
Close the extra windows.
4. Try to find your spot on http://x-3.net/category/teens/.
5. Go back to step 1.
Actual Result: at step 4, there's no indication of which link was the last one
you followed.
Expected Result: there should be a dotted rectangle around the last link you
followed.

If you tab to a link instead of clicking on it, the focus ring appears (!)

Comment 1

17 years ago
-> events?
Assignee: aaronl → joki
Component: Keyboard Navigation → Event Handling
QA Contact: sairuh → madhur

Comment 2

17 years ago
Created attachment 49829 [details]
Simplified test case

Comment 3

17 years ago
I've created a simplified testcase (sorry no pictures). 
While creating the testcase I've found that the links that didn't show the focus
has this syntax: <a href=""> <b>text</b> </a>.
Removing the <b> fixed the problem.

Comment 4

17 years ago
Marking as new. Problem still exists with 2001-10-03-03
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
--> Layout, surely.
Assignee: joki → attinasi
Component: Event Handling → Layout
Keywords: testcase
QA Contact: madhur → petersen
(Assignee)

Comment 6

17 years ago
The problem is actually a little simpler: the anchors with the <b> inside of
them are not getting the :active or :focus rules applied to them. 

Thry this link:

<a href="http://www.mozilla.org/">LINK <b>LINK</b></a>

If you click on the first (non-bold) text, it gets the :active and :focus
applied, but not if you click on the bold text.

This could be an event issue - not sure yet.
(Assignee)

Comment 7

17 years ago
mpt - why is this 'surely' layout? If we tab to the link, we display the focus.
If you click we do not. Layout is not responsible for fielding the clicks, and
it is correctly styling the text when we do succeed in getting the focus to it.
I think this is more likely an event issue...
(Reporter)

Updated

17 years ago
Whiteboard: [Aufbau-P2]

Updated

17 years ago
Whiteboard: [Aufbau-P2]

Updated

17 years ago
Target Milestone: --- → mozilla1.1
*** Bug 148798 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
I said `Layout, surely' not because it was surely layout, but because it surely
wasn't Event Handling. I should have been more clear; my apologies.

*** This bug has been marked as a duplicate of 65917 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.