Address auto-complete should not assume domain

RESOLVED WONTFIX

Status

MailNews Core
Composition
--
enhancement
RESOLVED WONTFIX
17 years ago
10 years ago

People

(Reporter: Mark Swaffer, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

When typing in an address in a new message, the address autocomplete assumes
that I'm most likely to be sending the message to someone in my own domain.

An example:

Say I'm sending an email to John Smith who's address is jsmith@isp.net, and he
appears as such in my address book. If I start to type "joh" the auto-complete
will assume that I want to send my email to "joh@home.com" because @home.com is
the domain of my email address. Its second guess would be "John Smith
<jsmith@isp.net>". 

I find this "feature" to be incredibly annoying, because I almost never send
email to people that are not in my address book, and the likelihood of me
sending to someone on my own domain is rare. To have non-address book entries
take precidence over those in my address book is a little baffling to me, and
very annoying as I've accidentally sent hurried messages to people I don't know.
I'd like to be able to turn this off somehow.

Reproducible: Always
Steps to Reproduce:
1. Open new message window
2. Type the first few characters of the name of someone in your address book.
3. Watch in amazement as it assumes you'll want to send to blah@yourdomain.com

Actual Results:  Poor guessing

Expected Results:  Better guessing

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
QA Contact: sheelar → nbaca

Comment 1

17 years ago
Please look at Bug# 88315 and look for jglick's comments on 9/6/2001. Does her
description match more closely what you would expect? Can you try one of the
more recent builds to see how it behaves?
(Reporter)

Comment 2

17 years ago
Looked at Bug# 88315. This is not the same bug, and in fact, I should clarify
things.

Bug# 88315 referred to failing to selecting the first address in the address
book after hitting enter. Now come to think of it, some of my problems would
have been attributed to this bug, and hence are no longer in existence in 0.9.5.
However, the problem still remains that in that little drop down menu, Mozilla
still lists the made-up email address before any of the ones in the address
book. I personally wouldn't want it to list a made up address at all. If its not
in my address book, I'll just type the whole thing.

Also, if what you type into the address field is not enough to narrow it down to
only one entry, and you hit enter, it doesn't complete it at all. For example,
lets say I have to Johns in my address book and I type in J-O-H-N and hit enter,
it will address this email to "john". It used to guess john@isp.com as was
mentioned in Bug# 88315, but now it doesn't even guess at a valid email address,
which is just as useless. Maybe there are certain situations, like maybe on
intranets, where there are valid email addresses without the @whatever.tld, so
maybe this should just be left as-is, I wouldn't know.

So to summarize, this is a partial duplicate of Bug# 88315, but still isn't
quite completely fixed.
(Assignee)

Comment 3

17 years ago
>Maybe there are certain situations, like maybe on
>intranets, where there are valid email addresses without the @whatever.tld, so
>maybe this should just be left as-is, I wouldn't know.

Some SMTP server are smart enough to append a default doname when this one is
missing. It's the case for the Netscape internal smtp server.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
Agreed. I find this behavior very annoying. This guarantees that the first
choice is *never* what I want. A pref to control this would be nice. 
OS: Windows 2000 → All
Hardware: PC → All

Comment 5

17 years ago
Changing summary from "Address auto-complete a little misguided" to "Address
auto-complete should not assume domain"
Summary: Address auto-complete a little misguided → Address auto-complete should not assume domain

Comment 6

16 years ago
*** Bug 184406 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
Is there any reason this bug should still be open?  The default assumption of 
'xyz@local.tld' is currently only made if there are no matches in any of the 
address books.  It is true that, in the dropdown list, 'xyz@local.tld' appears 
at the top of the list, but it is not the item that is entered into the field as 
a default.

Mark Swaffer, if you are satisfied with the current behavior, please mark this 
bug:   Resolved|WorksForMe

Comment 8

14 years ago
This is "as designed" and not changing any time soon.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 9

14 years ago
*** Bug 262968 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
I'm over here because I entered this same bug report after  discussion of it in
a forum, not having found this bug when looking with search, and I got email
saying it was a duplicate of this bug.

Re:Is there any reason this bug should still be open?  The default assumption of 
'xyz@local.tld' is currently only made if there are no matches in any of the 
address books.  It is true that, in the dropdown list, 'xyz@local.tld' appears 
at the top of the list, but it is not the item that is entered into the field as 
a default.

It is unsettling and inconvenient for the user to see that false name as the
first one in the list, because their natural assumption is that that's the name
tbird will use, even though, fortunately, it isn't.  Even after "training", I
say aghh the wrong address no wait it will do the right thing every time I see
it.  No one likes this except people who email a lot inside their own companies.
 It would improve the user interface to make it an option and make both sets of
people happy.  How hard can it be to do this...

Comment 11

14 years ago
(In reply to comment #10)
> I'm over here because I entered this same bug report after  discussion of it in
> a forum, not having found this bug when looking with search, and I got email
> saying it was a duplicate of this bug.
> 
> Re:Is there any reason this bug should still be open?  The default assumption of 
> 'xyz@local.tld' is currently only made if there are no matches in any of the 
> address books.  It is true that, in the dropdown list, 'xyz@local.tld' appears 
> at the top of the list, but it is not the item that is entered into the field as 
> a default.
> 
> It is unsettling and inconvenient for the user to see that false name as the
> first one in the list, because their natural assumption is that that's the name
> tbird will use, even though, fortunately, it isn't.  Even after "training", I
> say aghh the wrong address no wait it will do the right thing every time I see
> it.  No one likes this except people who email a lot inside their own companies.
>  It would improve the user interface to make it an option and make both sets of
> people happy.  How hard can it be to do this...
> 
> 

How hard is it to ignore the autocomplete (it's only a suggestion), and continue
typing and type the @ ; the autocomplete disappears immediately. If you want to
use the suggestion, press return.

Comment 12

14 years ago
I'm just pointing out that it is a flaw in the user interface.  It makes a
product look unprofessional.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.