Closed Bug 1002993 Opened 6 years ago Closed 6 years ago

Fix the timeout of tap_import_from_sim method of contacts app

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 943897

People

(Reporter: askeing, Unassigned)

Details

The timeout of tap_import_from_sim is ms, but the timeout of Wait class should be second.
It will block the test run.

apps/contacts/regions/settings_form.py
=====
def tap_import_from_sim(self, number_of_contacts=1):
    ...
    self.wait_for_element_displayed(*Contacts._status_message_locator,
                                    timeout=number_of_contacts * self.marionette.timeout)
=====

15:36:29 TEST-START test_import_contacts_from_sim.py
15:36:30 test_import_contacts_from_SIM (test_import_contacts_from_sim.TestImportContactsFromSIM)
08:17:30 Insert a new prepaid SIM card (some contacts) in device and import the contacts ... ERROR
08:17:30 
08:17:30 ======================================================================
08:17:30 ERROR: None
08:17:30 ----------------------------------------------------------------------
08:17:30 Traceback (most recent call last):
08:17:30   File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest.non-smoketest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.6-py2.7.egg/marionette/marionette_test.py", line 163, in run
08:17:30     testMethod()
08:17:30   File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest.non-smoketest/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/contacts/test_import_contacts_from_sim.py", line 27, in test_import_contacts_from_SIM
08:17:30     contacts_settings.tap_import_from_sim(number_of_sim_contacts)
08:17:30   File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest.non-smoketest/workspace/tests/python/gaia-ui-tests/gaiatest/apps/contacts/regions/settings_form.py", line 56, in tap_import_from_sim
08:17:30     timeout=number_of_contacts * self.marionette.timeout)
08:17:30   File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest.non-smoketest/workspace/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 42, in wait_for_element_displayed
08:17:30     lambda m: m.find_element(by, locator).is_displayed())
08:17:30   File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest.non-smoketest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.7.6-py2.7.egg/marionette/wait.py", line 143, in until
08:17:30     cause=last_exc)
08:17:30 TimeoutException: TimeoutException: Timed out after 60000.1 seconds
Due to bug 943897 is reopened, set this bug as dup.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 943897
You need to log in before you can comment on or make changes to this bug.