Please, remove the Ajax request from the whatsnew page to Google Analytics

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: fayolle-florent, Unassigned)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140421221237

Steps to reproduce:

1. Open this page: https://www.mozilla.org/en-US/firefox/29.0/whatsnew/?oldversion=28.0
2. Press Ctrl-Shift-Q to open the Network panel of the DevTools
3. Click anywhere on that webpage


Actual results:

Any click made on that page triggers an Ajax request to Google Analytics.


Expected results:

Please, please, please, remove that!

We can't defend the user privacy, promote that and transgress it in such an indecent way. 
Users trust us to fight for their privacy. Please, don't doom everything especially in this page.

Florent
(Reporter)

Updated

5 years ago
Component: Untriaged → General
Product: Firefox → www.mozilla.org
Version: 29 Branch → Production
(Reporter)

Updated

5 years ago
OS: Linux → All
Hardware: x86_64 → All
Status: UNCONFIRMED → NEW
Ever confirmed: true
https://www.mozilla.org/en-US/privacy/websites/ is pretty specific about Google Analytics being used and even includes information on an add-on you can use to opt-out of tracking. Also, there's even an |_gaq.push(['_gat._anonymizeIp']);| option being passed, informing Google to anonymize the results.

This sounds like WONTFIX to me.
As Reed mentioned, the websites privacy policies discusses how we use Google Analytics to improve the website experiences. There were similar discussions in bug 858839 and you read up on the our GA setup. Also, we've opt-ed out, from a GA account perspective, of any 3rd party uses of the anonymous data. You can also opt-out of the GA data manually via: https://tools.google.com/dlpage/gaoptout.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
That's completely stupid, the marketing sell a product "who protect your private life" and you give our habits of usage to google ...
And after, people cry "We say that our product protect privacy and nobody believes us"

And please said google is supposed to anonymize result does not mean they do.
(In reply to Reed Loden [:reed] from comment #1)
> https://www.mozilla.org/en-US/privacy/websites/ is pretty specific about
> Google Analytics being used and even includes information on an add-on you
> can use to opt-out of tracking. Also, there's even an
> |_gaq.push(['_gat._anonymizeIp']);| option being passed, informing Google to
> anonymize the results.
> 
> This sounds like WONTFIX to me.

Are you joking? do you really trust Google to "anonymize the results" once you have "informed" them with "an option being passed"?
The need for metrics in the whole launch Firefox 29 operation is by no way an excuse to track users at the very moment when bombastic mottos are displayed on the screen.

And please do not answer with technical reasons, this is no technical issue, this is ethics.
If you cannot understand that and have no respect for the users, then sure it sounds WONTFIX to your deaf ears.
Maybe Mozilla should move from Analytics to a solution like Piwik which is self-hosted.
http://piwik.org/

Comment 6

5 years ago
(In reply to Antoine Turmel from comment #5)
> Maybe Mozilla should move from Analytics to a solution like Piwik which is
> self-hosted.
> http://piwik.org/
Let's try to avoid absolutes.
I think the right questions are:
* What does Mozilla want to know and "track" about their users?
* Which existing solution other than GA fit the bill to get these insights today?
* What is the transition cost?

Before the first question is answered, sending links to other solutions is a waste of time for everyone. This discussion should also happen in the proper place which isn't this bug and more likely:
https://groups.google.com/forum/?fromgroups#!forum/mozilla.dev.webdev
(In reply to David Bruant from comment #6)
> (In reply to Antoine Turmel from comment #5)
> > Maybe Mozilla should move from Analytics to a solution like Piwik which is
> > self-hosted.
> > http://piwik.org/
> Let's try to avoid absolutes.
> I think the right questions are:
> * What does Mozilla want to know and "track" about their users?
> * Which existing solution other than GA fit the bill to get these insights
> today?
> * What is the transition cost?
> 
> Before the first question is answered, sending links to other solutions is a
> waste of time for everyone. This discussion should also happen in the proper
> place which isn't this bug and more likely:
> https://groups.google.com/forum/?fromgroups#!forum/mozilla.dev.webdev

FYI a post relative to this issue has already been pushed to mozilla.governance group and currently waiting for moderation. I am not very confident it will surface.

I can't see the point of asking for anything to dev.webdev group, it looks to me this no webdev issue but a matter of value, policy and ethics.

Comment 8

5 years ago
(In reply to Jean-Bernard Marcon from comment #7)
> I can't see the point of asking for anything to dev.webdev group, it looks
> to me this no webdev issue but a matter of value, policy and ethics.
From knowing a good number of people in the webdev team, I can assure you that they care about privacy. I can imagine they aren't using GA lightly.
They have goals, things they want to know, understand about their users. Maybe they do A/B testing to be sure the content of the webpages they make meets the users, etc. Understanding users behaviors and adjusting websites as necessary is important to not miss the target audience (which turns into more people being more aware of what Mozilla is about and not losing download from poor website design).

That's the reason I'm interested in what the webdev team is actually doing with GA. It's possible GA is the only web analytics product in the market to provide the sort of insights they're interested in.

We've seen in the past that Mozilla easily trades value extremism for pragmatism (Firefox is available on Windows and iOS, Firefox implements cookies, H264 offered when there is an OS decoder, the list goes on.).
If you want to go anywhere and be convincing, I'd recommend to follow that path (hence me asking for what they actually do with the data and propose an alternative only if it fits the bill).
There was a thread on mozilla.governance when the switch to GA was made: https://groups.google.com/forum/#!msg/mozilla.governance/9IQvIubDOXU/0tWVVlrUJOQJ

Comment 10

5 years ago
This page could at least mention GA :
http://www.mozilla.org/en-US/privacy/ 
(in the "How do we learn information about you?" section)

Comment 11

5 years ago
Yeah, let's discuss about that on Google Groups \o/ .....

Mozilla is awesome. Mozilla is where it is now, because Mozilla knows when pragmatism has to be chosen instead of extremism. That's nice, and that's why the project is a success. But the privacy is really a core topic now, and I have the bad feeling that Mozilla doesn't invest itself enough on that key part.

How do you imagine the feelings of the users, when they see using our Lightbeam addon, that the page promoting privacy is tracking them?

There is clearly a problem in the way we are dealing with trust currently.

Comment 12

5 years ago
(In reply to percebois from comment #10)
> This page could at least mention GA :
> http://www.mozilla.org/en-US/privacy/ 
> (in the "How do we learn information about you?" section)
That's legitimate indeed. Filed bug 1003804
(Reporter)

Comment 13

5 years ago
For me, the problem is more about the AJAX requests being sent each time the user clicks.
The first impression to the people is that:
- The page is promoting Mozilla which defends privacy on the Web
- But at the same time, Mozilla is tracking every click on that page

And that looks inconsistent.

Even though the work you made to anonymise the data being collected in GA may protect user privacy (though I see that some identification cookies are sent, but maybe they are only related to Mozilla websites?), it is still bad for the image of Mozilla. And the impacts of a bad image are real. 
So please, if you don't want to listen the arguments concerning the ethics, please take care of that pragmatical issue.

BTW, the related discussion on mozilla.governance is here: https://groups.google.com/forum/?hl=fr#!topic/mozilla.governance/UZO9U2MTTwM

Florent

Comment 14

5 years ago
(In reply to fayolle-florent from comment #13)
> For me, the problem is more about the AJAX requests being sent each time the
> user clicks.
> The first impression to the people is that:
> - The page is promoting Mozilla which defends privacy on the Web
> - But at the same time, Mozilla is tracking every click on that page
> 
> And that looks inconsistent.
Is the problem with what's actually tracked or only with the perception of being tracked? From your wording, it looks like you'd be equally bothered if it the clicks weren't going to GA.

I acknowledge the inefficiency. They could store all the clicks first and make a single xhr later? ;-)
Mozilla could also choose to do in-browser tracking. Interesting that Mozilla isn't making that choice although it is technically in position of doing so. Something to think about for sure.

Note that a website is already capable to "track" every single click (to other pages within the same domain) and know your navigation patterns within the website. I'll go further by saying that this is possible even without cookies (look for "web keys" or "capability URLs". These weren't aimed at tracking, but could be use for that purpose).
I don't see how recording other clicks is that awful.

I know also that MDN does A/B testing, among other things to test which text on the (currently) "edit" button to figure out which wording is more engaging to users. Should Mozilla stop doing these A/B testings too because that's a form of tracking?

> Even though the work you made to anonymise the data being collected in GA
> may protect user privacy (though I see that some identification cookies are
> sent, but maybe they are only related to Mozilla websites?)
I imagine you're referring to cookies on the mozilla.org domain (and subdomains). Comment 9 links to a message that explains what these cookies are for. (mozilla.org/privacy has some answers too)
(Reporter)

Comment 15

5 years ago
Gareth has explained the purpose of these requests:
https://groups.google.com/d/msg/mozilla.governance/UZO9U2MTTwM/_HTDZ9x1680J

--

David, most of your remarks has been answered in my last reply in mozilla.governance, with some propositions:
https://groups.google.com/d/msg/mozilla.governance/UZO9U2MTTwM/ZsJ8fI5IcdYJ

(In reply to David Bruant from comment #14)
> Is the problem with what's actually tracked or only with the perception of being tracked? 
> From your wording, it looks like you'd be equally bothered if it the clicks weren't going to GA.
I am less happy that's GA. 

I also suggest that the requests are made when Telemetry is active if the population is representative. The people who have activated it had agreed to send information to Mozilla for their usage of Firefox. So in that context, it sounds relevant.

> I don't see how recording other clicks is that awful.
I expect Mozilla to be highly careful about privacy, and not rely only on some contracts (especially after the revelation of Prism).

> I know also that MDN does A/B testing, among other things to test which text on the 
> (currently) "edit"  > button to figure out which wording is more engaging to users. 
> Should Mozilla stop doing these A/B testings too because that's a form of tracking?

That's not targeting the same population (the whatsnew page is visited by most of the Firefox users). And I am not an MDN contributor, so I would be rude to suggest anything here. 
But at least, if we can consider not tracking when DNT is active in the Mozilla websites (and thus reopen bug 858839), I would be happier.

Florent
You need to log in before you can comment on or make changes to this bug.