Closed Bug 1003856 Opened 6 years ago Closed 6 years ago

Selecting address from recipient autocomplete broken for all scenarios except {Name beginsWith} topmost match (selecting from dropdown list disfunctional)

Categories

(Thunderbird :: Message Compose Window, defect, major)

31 Branch
defect
Not set
major

Tracking

(thunderbird31+ fixed)

VERIFIED FIXED
Thunderbird 32.0
Tracking Status
thunderbird31 + fixed

People

(Reporter: nONoNonO, Assigned: mkmelin)

References

Details

(Keywords: dogfood, regression)

Attachments

(1 file)

When you compose a new mail and start typing an email address, you get a autocompletion drop-down pick list.

If you use the arrow keys to move to another entry and then press Enter, the first recipient is still shown.

Also when you start typing something from the middle of an email address, it is shown as [typed text] >> [autocompletion result]. When you select that address, the suggestion stays there, for example:
"ekker >> Onno Ekker <o.e.ekker@gmail.com>"

This last error might be the same as in bug 749923 for Firefox.
Keywords: regression
Last good: 20140427
First bad: 20140428

Regression from bug 959209
Blocks: 959209
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Summary: Selecting an address from the address autocompletion list doesn't work → Selecting an address from the address autocompletion list with arrow keys+enter doesn't work
I suggest we will want to, relatively soon, land the fix for this on 31/aurora
Keywords: dogfood
Summary: Selecting an address from the address autocompletion list with arrow keys+enter doesn't work → Selecting an address from the address autocomplete list with arrow keys+enter doesn't work
(In reply to Wayne Mery (:wsmwk) from comment #2)
> I suggest we will want to, relatively soon, land the fix for this on
> 31/aurora

+1, definitely so. Bugs like this will make TB a laughing stock.
Severity: normal → major
Adjusting summary to match realities on Trunk (32.0a1 (2014-05-01)).

If the behaviour is different on 31/Aurora, feel free to revert summary as appropriate, and let me know if separate bug is needed for Trunk.
Summary: Selecting an address from the address autocomplete list with arrow keys+enter doesn't work → Selecting address from recipient autocomplete broken for all scenarios except {Name beginsWith} topmost match (selecting "contains" matches preserves "search terms >>", selecting from dropdown list disfunctional)
Attendee autocomplete in calendar is affected thereby as well (becomes obvious with the patch to bug 1002611 applied).
Have a patch for this. It's fallout from bug 754265 when landed in between the patch creation for bug 959209 and landing...
Assignee: nobody → mkmelin+mozilla
Blocks: 754265
Status: NEW → ASSIGNED
Duplicate of this bug: 1005289
Lets not track bug bug 749923 in here, though that is easily reproducible with toolkit autocomplete.
Attached patch proposed fixSplinter Review
Adds getFinalCompleteValueAt.
Attachment #8416933 - Flags: review?(standard8)
Summary: Selecting address from recipient autocomplete broken for all scenarios except {Name beginsWith} topmost match (selecting "contains" matches preserves "search terms >>", selecting from dropdown list disfunctional) → Selecting address from recipient autocomplete broken for all scenarios except {Name beginsWith} topmost match (selecting from dropdown list disfunctional)
Does this fix similar bug 348844?
See Also: → 348844
Comment on attachment 8416933 [details] [diff] [review]
proposed fix

Great, thanks r=Standard8.

I'll pre-approve this for Aurora as well, as we definitely want this there.
Attachment #8416933 - Flags: review?(standard8)
Attachment #8416933 - Flags: review+
Attachment #8416933 - Flags: approval-comm-aurora+
(In reply to Thomas D. from comment #10)
> Does this fix similar bug 348844?

Not directly, that's some bug in the autocomplete widget(s)
https://hg.mozilla.org/comm-central/rev/5c08b80e0daf -> FIXED
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 32.0
Duplicate of this bug: 1006911
Just realised I'd managed to leave aurora closed, so I've just landed this in time for today's builds:

https://hg.mozilla.org/releases/comm-aurora/rev/b3744e4ffff0
Status: RESOLVED → VERIFIED
See Also: → 632127
Blocks: 1009469
You need to log in before you can comment on or make changes to this bug.