Closed Bug 1003924 Opened 5 years ago Closed 5 years ago

Firefox 29.0 will not stop loading "what's new" tab on every startup

Categories

(Firefox :: Tours, defect)

29 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: josh.selling, Unassigned)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140421221237

Steps to reproduce:

I upgraded from FF 28.0 to FF 29.0.  I then started Firefox.  


Actual results:

I get my default home page tab, plus a second tab of "What's New".  No matter how often I completely exit Firefox, or reboot, this behavior does not change.

The instructions on https://support.mozilla.org/en-US/kb/firefox-says-its-just-updated-every-time-it-starts to work around this issue do NOT work.  My home page was not changed.  I can change any preference settings at all, and they are kept/saved just fine.


Expected results:

I should have seen the "what's new" page on the very first start, then never again.

It would be a nice feature to have a menu selection option that says to NEVER show me the "what's new" page after any upgrade or changes.
Hello Josh, thanks for the report. You are definitely not supposed be seeing this on every startup so I'd like more information to help figure out what's causing the problem for you:

1) How did you upgrade Firefox to 29? Did you download the installer from the website or did you update from within Firefox itself (automatically or via the About Dialog)?
2) What is the address of the unwanted page that is opening on startup?
3) Could you provide a copy of the raw data from about:support? Visit about:support in the address bar and click "Copy raw data to clipboard" and then add it as an attachment to this report by going to https://bugzilla.mozilla.org/attachment.cgi?bugid=1003924&action=enter and click the text link "paste text as attachment" and then paste into the textbox that appears, give a description and submit the form.

I'm confirming the bug since I saw at least one other report on input.

Thanks
Blocks: fx-UITour
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Flags: needinfo?(josh.selling)
4) Open the Browser Console (Tools/Menu button > (Web) Developer > Browser Console). Ctrl-Shift-J also opens it I believe. Right click in the window and choose Select All and then choose Copy. Paste it as another text attachment using the steps from #3 above.
Flags: needinfo?(josh.selling)
> 1) How did you upgrade Firefox to 29? Did you download the installer from
> the website or did you update from within Firefox itself (automatically or
> via the About Dialog)?

In-app - from the Help->About, it reported an update and asked to restart . . . voila problem.

> 2) What is the address of the unwanted page that is opening on startup?

I will reply after re-starting firefox in a moment.

> 3) Could you provide a copy of the raw data from about:support?

Done.
> 2) What is the address of the unwanted page that is opening on startup?

https://www.mozilla.org/en-US/firefox/29.0/whatsnew/?oldversion=rv:1.9.2.13
> 4) Open the Browser Console (Tools/Menu button > (Web) Developer > Browser
> Console). Ctrl-Shift-J also opens it I believe. Right click in the window
> and choose Select All and then choose Copy. Paste it as another text
> attachment using the steps from #3 above.

Done.
Thanks Josh!

(In reply to josh.selling from comment #5)
> > 2) What is the address of the unwanted page that is opening on startup?
> 
> https://www.mozilla.org/en-US/firefox/29.0/whatsnew/?oldversion=rv:1.9.2.13

Did you just upgrade from Firefox 3.6.13 (Gecko 1.9.2.13) recently? We're detecting that you were running that version before the restart so that's why we're offering the tour. Something is preventing browser.startup.homepage_override.mstone from getting saved. Just to confirm, if you close Firefox and start it immediately after (without a restart of the computer), you will see that page open?

(In reply to josh.selling from comment #3)
> Created attachment 8416254 [details]
> Requested dump from about:support

I see that there is a user.js file present in your profile. Would you mind attaching it on the bug? You can find it by clicking the button on the "profile folder" line of about:support and there should be a file named "user.js" in the profile folder. I'm wondering if it's locking the browser.startup.homepage_override.mstone preference.

Is this problem encountered in an enterprise environment?

Thanks
Flags: needinfo?(josh.selling)
> > https://www.mozilla.org/en-US/firefox/29.0/whatsnew/?oldversion=rv:1.9.2.13
> 
> Did you just upgrade from Firefox 3.6.13 (Gecko 1.9.2.13) recently? 

Whatever Firefox 28.0 was, that was the version before I upgraded.  So I can't trivially answer that question other than, I can't recall the last time I was running FF 3.x.  Wow.


> Just to
> confirm, if you close Firefox and start it immediately after (without a
> restart of the computer), you will see that page open?

Yes.  It's insanely annoying.

> > Created attachment 8416254 [details]
> > Requested dump from about:support
> 
> I see that there is a user.js file present in your profile. Would you mind
> attaching it on the bug? 

Will attach it momentarily.

> Is this problem encountered in an enterprise environment?

Yes.  A very heavily IT enforced Policy set of things, but Firefox or Chrome is the recommended browser for everything except one or two special purpose internal things.
Flags: needinfo?(josh.selling)
I see the set key which seems to not be replaced with the newer version.  Why is it failing?  On a lark, I manually edited the file (via notepad) and changed the number - it saved fine.  The file is not locked in any way.
> I see that there is a user.js file present in your profile. Would you mind
> attaching it on the bug?

Done.
(In reply to josh.selling from comment #10)
> Created attachment 8416316 [details]
> Requested "user.js" file
> 
> I see the set key which seems to not be replaced with the newer version. 
> Why is it failing?

It seems like your IT department (improperly) setup Firefox profiles to force browser.startup.homepage_override.mstone to be "rv:1.9.2.13" which is a bad idea as it will cause the whatsnew page to appear on every startup when we enabled the whatsnew page in product (we haven't used it since last year sometime). Whatever preferences are specified in user.js override any preferences set in the product.

I would guess the intention was to suppress any whatsnew/firstrun pages for employees but hard-coding the version number is not a good way to do this as it breaks when the version number changes.  The supported way to prevent these pages from ever appearing is to set that preference to the value "ignore" instead of the version number. Can you please contact your company's tech support department and let them know about this issue so they can fix it for all affected employees? You can point them to this bug report if they need more info. There is also an enterprise mailing list where managed Firefox environments are discussed: https://mail.mozilla.org/listinfo/enterprise

>  On a lark, I manually edited the file (via notepad) and changed the number - it saved fine. 

If you remove the browser.startup.homepage_override.mstone line it should fix the issue for you in that profile after a second startup. The default user.js file which is used on new Firefox profiles (e.g. after a reset) may still have the wrong mstone version number.

> The file is not locked in any way.

I was referring to preference locking but that is not the issue here. It's just that the preference is being set in user.js which overrides preferences set in Firefox. There isn't a way to detect that the value is coming from user.js although there are some possible workarounds which I will request feedback on in my next comment.
Flags: firefox-backlog+
Sounds like this is an issue specific to Josh's setup, so unfortunately not something we can directly address. Shall we mark this INVALID?
Flags: firefox-backlog+ → firefox-backlog-
(In reply to :Gavin Sharp (email gavin@gavinsharp.com) from comment #13)
> Sounds like this is an issue specific to Josh's setup, so unfortunately not
> something we can directly address. Shall we mark this INVALID?

Actually, I thought Matt's comment indicated that there might be a way to do better here:

(In reply to Matthew N. [:MattN] (away May 9 - 12) from comment #12)
> I was referring to preference locking but that is not the issue here. It's
> just that the preference is being set in user.js which overrides preferences
> set in Firefox. There isn't a way to detect that the value is coming from
> user.js although there are some possible workarounds which I will request
> feedback on in my next comment.


Additionally, there have been other reports of this (e.g. bug 1008574) and so I think we should still try to improve what we do here. Having the same page show up every startup (and override people's settings) is not OK.
Yes, one idea is that we can also check e.g. gecko.mstone (a much newer pref) and if it doesn't match browser.startup.homepage_override.mstone then we wouldn't show the homepage override. Of course this would also break if IT admins start mucking with gecko.mstone but I don't yet know of a reason they would want to do that. Due to the timing of the pref changes this may not be trivial but I think there are various similar ways that may not be difficult to implement. I do agree that this doesn't need to be in the backlog atm. since it's a longstanding issue that won't be user visible for a while again soon.

Josh, did you have any luck getting this fixed for other users in your organization via your IT department?
Flags: needinfo?(josh.selling)
FWIW, I don't have a user.js file per <I see that there is a user.js file present in your profile. Would you mind attaching it on the bug? You can find it by clicking the button on the "profile folder" line of about:support and there should be a file named "user.js" in the profile folder. I'm wondering if it's locking the browser.startup.homepage_override.mstone preference.>

My override setting in about:config says 29.0.1 so it shouldn't show the What's New by what I read above.  I reset 
browser.startup.homepage_override.buildID
browser.startup.homepage_override.mstone
and restarted but What's New still shows.  The BuildID and mstone settings get repopulated somehow.  I don't know if "override" actually means override something else.  I don't know how to physically delete the mstone line as implied above <If you remove the browser.startup.homepage_override.mstone line it should fix the issue for you in that profile after a second startup>

It's wrong to tolerate detritus like this, but we all have day jobs.
Moving open UITour bugs to Firefox::Tours. Filter on firefox-tours-20150121.
Component: General → Tours
We haven't heard back from Josh and it's pretty clear that in his case this was caused by how Firefox was deployed by his IT dept. There are possible workarounds (see comment 15) but I hope that IT departments that were using a user.js to prevent the whatsnew tour with a hard-coded version number will have fixed it in their deployments by now. We haven't seen many reports AFAIK.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(josh.selling)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.