Users don't know where the doorhanger went

RESOLVED DUPLICATE of bug 1004061

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1004061
5 years ago
3 years ago

People

(Reporter: jib, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
x86
macOS
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxprivacy])

We've gotten a number of requests where the usability problem is the same:

 1) A page needs to use the camera/mic, e.g. User receives a call.
 2) User does something that unintentionally causes the permission doorhanger to disappear:
    a. They temporarily leave the browser (adjust volume, position windows, gather notes)
    b. They temporarily visit another tab (do stuff immediately before call? Never!)
    c. They acci-click on page before it appears (like my uncle who double-clicks links)
    d. They click somewhere on the page (now you've done it. Some people...)
 3) User doesn't know what to do next - "Nothing is working".

The user waits for the web-app, and the web-app waits for the user --> UI deadlock.

I am pretty certain that the blocking usability problem here is that it is not clear at all where the doorhanger goes when it disappears. [1]

I am pretty certain, because last year, for about two months, I was one of those people who didn't get it. I didn't know that a hidden choice was still available to me, because I had not learned to look for it. I thought events had moved on, that it was too late for choices, so I didn't even know to look for it. The Firefox doorhangers didn't work like anything else I'd seen up until then, and I had no learned memory of it.

Now that I know how they work, I love our door-hangers!

So given a love-story of one, this seems easily rectified by teaching users how they work.
E.g. the first (few) time(s?) any doorhanger disappears, show users where it goes:

[#]
 |\_______________________________________
 | We've minimized a dialog for you.      |
 | It's here. Click icon to see it again! |
 '----------------------------------------'

This problem seems general to all our doorhangers, not just gUM. Chances are, before I learned it, I never cared enough where the geo-location doorhanger went, which is my loss.

---
[1] For those who don't know: doorhangers can be resurrected by clicking on the button at the head of the URL bar that the doorhanger extruded from.

Updated

5 years ago
See Also: → 1004061

Updated

5 years ago
See Also: → 947266
As I mentioned in https://bugzilla.mozilla.org/show_bug.cgi?id=947266 I know what the doorhangers are and how they behave, and I still miss them (especially the gUM one) when they've been hidden because of loss of focus.
Flags: firefox-backlog+
One potential way to avoid accidental dismissal is to have a short period where only an explicit action removes the doorhanger in cases like this.  That might help address bug 1004061 as well.  That might be in addition to :jib's suggestion, which I think is a good one.
Component: General → Device Permissions

Updated

3 years ago
Blocks: 1188147, WADI
Priority: -- → P3
Whiteboard: [fxprivacy]
I should mention I'm no longer advocating the "educational" tooltip in comment 0 from 2 years ago (even though https://talky.io/ does just this).

I think the fact that minimize looks like dismissal at all is the problem. We're discussing two approaches:

 1. Make doorhanger shrink but not disappear entirely on minimize, or
 2. Drop minimize.

Just based on time, unless there's support for #1, I suspect we'll get #2.
This was fixed in bug 1004061 with the second approach described in the previous comment.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1004061
You need to log in before you can comment on or make changes to this bug.