Closed Bug 1004985 Opened 8 years ago Closed 7 years ago

Clicking on screenshot notification doesnt discard it

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.0 S5 (4july)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.0M --- verified
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: daleharvey, Assigned: daleharvey)

References

Details

(Whiteboard: [systemsfe][partner-blocker])

Attachments

(2 files)

No description provided.
Assignee: nobody → dale
Attachment #8447784 - Flags: review?(timdream)
On my backlog of nitpicks
Comment on attachment 8447784 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/21146

Woot!

I am not sure the test failure is not related through.
Attachment #8447784 - Flags: review?(timdream) → review+
Yup most definitely unrelated

landed in: https://github.com/mozilla-b2g/gaia/commit/c64fb0239c669329fa6405aa6e3a5f27390f6064
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [systemsfe]
Target Milestone: --- → 2.0 S5 (4july)
Duplicate of this bug: 1025626
See Also: → 1084247
Comment on attachment 8447784 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/21146

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): see bug 1084247 comment 9
[User impact] if declined: It should be a inconsistent behavior that the notification doesn't dismiss after clicking.
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): very low.
[String changes made]: N/A
Attachment #8447784 - Flags: approval-gaia-v2.0?
Hi Wesly,

Could you help on triage? Thanks.


[Blocking Requested - why for this release]:
see bug 1084247 comment 9
blocking-b2g: --- → 2.0?
Flags: needinfo?(wehuang)
[Triage] 2.0+
blocking-b2g: 2.0? → 2.0+
Flags: needinfo?(wehuang)
Whiteboard: [systemsfe] → [systemsfe][partner-blocker]
Attachment #8447784 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
Keywords: verifyme
Issue verified fixed in Flame 2.1 and Flame 2.0. Issue does not occur in Flame 2.2

Actual Results: Tapping screenshot message in notification tray dismisses notification and opens screenshot preview

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141024001204
Gaia: 0f76e0baac733cca56d0140e954c5f446ebc061f
Gecko: 7d78ff7d25b6
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0  (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141024000201
Gaia: a2719af81cfdb330eecf37cd6f4725ec75123aed
Gecko: f8432250efb7
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame Master (319mb)(KitKat Base)(FullFlash)
Build ID: 20141024040202
Gaia: d893a9b971a0f3ee48e5a57dca516837d92cf52b
Gecko: a5ee2769eb27
Version: 36.0a1 (Master)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Verify passed, this issue can't be repro on Woodduck 2.0.
Attached: Verify_Woodduck_Notification.mp4
Reproducing rate: 0/5
Gaia-Rev        ee5cf148b4c546beea9bfb799d2a3ee62074957d
Gecko-Rev       73601b71861cbc2f180c4d2653cec3e9fbb39db5
Build-ID        20141114050313
Version         32.0
You need to log in before you can comment on or make changes to this bug.