Closed Bug 1004989 Opened 8 years ago Closed 8 years ago

[Homescreen] The downloading animation is not properly around the downloading icon

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(tracking-b2g:backlog, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S2 (23may)
tracking-b2g backlog
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: julienw, Assigned: crdlc)

References

Details

(Whiteboard: [ft:systemsfe], [priority][systemsfe])

Attachments

(5 files)

Attached image 2014-05-02-12-04-30.png
STR:
* launch Markerplace
* start the installation for "SOW"
* press home to see the "downloading" icon

=> See attachment

Image v1.4 for Peak from 2014-04-29:
Gecko: 44787e8
Gaia:  01b7794
Known bug & definitely not a blocker - VD glitch regression.
blocking-b2g: 1.4? → ---
Whiteboard: DUPEME
Just tried in master, it looks right.

So if this is not a blocker, let's close this.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
I saw on Rik's phone that it's not fixed.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
See Also: → 998093
My Peak is on 2.0,
Build identifier: 20140510071315
Git commit: 014d16ea
I believe this is an issue of HD vs non-HD.

Can we try on Open C on master?
Keywords: qawanted
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Attached image IconAlignedOnOpenC.png
Installing icon is properly aligned on Open C Master build. Unable to reproduce issue.

Master M-C Environmental Variables:
Device: Open C Master M-C MOZ
BuildID: 20140513040202
Gaia: de1c755411949b50ae395b42e124af215ed9b702
Gecko: 7f5a8526b55a
Version: 32.0a1
Firmware Version: P821A10v1.0.0B06_LOG_DL
Can you try again, installing several apps, so that we can have an icon that is not at this location?

see attachment 8408632 [details] and attachment 8416417 [details], both icons are in the 3rd column.
Keywords: qawanted
Assignee: nobody → crdlc
Status: REOPENED → ASSIGNED
Attached file Patch v1
Please, can you test it in your Peak? Thanks a lot
Attachment #8422286 - Flags: feedback?(felash)
blocking-b2g: --- → backlog
Whiteboard: DUPEME → DUPEME, [ft:systemsfe], [priority]
Attached image with-patch.png
This screenshot was taken by applying your patch via the App Manager (so I'm not 100% sure all styles were properly applied).
Comment on attachment 8422286 [details]
Patch v1

My screenshot comes from v1.4, Rik's screenshot from master.

You can see that the ring is a little too small, and maybe 1 pixel too much to the left, but otherwise it's way better.
Attachment #8422286 - Flags: feedback?(felash)
Duplicate of this bug: 998093
Comment on attachment 8422286 [details]
Patch v1

Following Julien's suggestion the circle looks perfect now. Thanks for the review Vivien and thanks for you help Julien!.

http://i.imgur.com/oSI6nyc.png
Attachment #8422286 - Flags: review?(21)
Is the 1.4 affected as well, right?
Flags: needinfo?(felash)
Thanks Anthony for your help!

(In reply to Anthony Ricaud (:rik) from comment #9)
> Created attachment 8422527 [details]
> with-patch.png
> 
> This screenshot was taken by applying your patch via the App Manager (so I'm
> not 100% sure all styles were properly applied).
(In reply to Cristian Rodriguez (:crdlc) from comment #14)
> Is the 1.4 affected as well, right?

yes definitely !
Flags: needinfo?(felash)
Merged in master:

https://github.com/mozilla-b2g/gaia/commit/6620361ef4b555a5d65aeffb79de96ca2ab518cc
Status: ASSIGNED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Whiteboard: DUPEME, [ft:systemsfe], [priority] → DUPEME, [ft:systemsfe], [priority][systemsfe]
Target Milestone: --- → 2.0 S2 (23may)
Thanks for this very quick fix!
Keywords: qawanted
Cristian, should we ask an approval here to land on v1.4, then?
Comment on attachment 8422286 [details]
Patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: misaligned the downloading icon
[Testing completed]: user tests (developers)
[Risk to taking this patch] (and alternatives if risky): close to null
[String changes made]: no changes
Attachment #8422286 - Flags: approval-gaia-v1.4?
Comment on attachment 8422286 [details]
Patch v1

Taking for 1.4
Attachment #8422286 - Flags: approval-gaia-v1.4? → approval-gaia-v1.4+
v1.4: https://github.com/mozilla-b2g/gaia/commit/3144dde2846cd5b1b8bba98ae9162f98eee29cbc
Whiteboard: DUPEME, [ft:systemsfe], [priority][systemsfe] → [ft:systemsfe], [priority][systemsfe]
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.