Closed Bug 1005074 Opened 5 years ago Closed 5 years ago

Re-enable 'Send Tab to Devices' on Beta and Release with a string swap

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 32
Tracking Status
firefox29 --- verified
firefox30 + verified
firefox31 + verified
firefox32 + verified
b2g-v1.4 --- fixed

People

(Reporter: mfinkle, Assigned: rnewman)

Details

Attachments

(3 files)

We removed the feature in bug 941744 because we were not happy with the overall experience. We planned to improve the feature in bug 1002628.

Since the release of Fx29, we have had a lot of feedback about the missing feature. We have decided to re-enable the feature but change the name of the Share intent from "Firefox Sync" to "Send Tab to Devices". Both strings are already in the code.

Change this line from &syncBrand.fullName.label; to &sync.title.send.tab.label;
http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/locales/en-US/sync_strings.dtd#11

We also need to revert the patches landed in bug 941744.
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
OS: Linux → Android
Hardware: x86_64 → All
Better than changing the string...
Attachment #8416531 - Flags: review?(mark.finkle)
Handily, 661f96cbf4ce undid the change that turned the feature off:

  Bug 970176 - Part 2: invoke LocaleManager locale switching code prior to handling strings or Locale in background services. r=nalexander

'cos it was never uplifted to a-s. That makes this job a little easier.
This is only needed on Beta and Release due to a happy accident.
Attachment #8416535 - Flags: review?(mark.finkle)
Comment on attachment 8416535 [details] [diff] [review]
Part 2: re-enable Send Tab on Beta and Release. Backed out changeset b30d5dfe0421 (Bug 941744) v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  Bug 941744.

User impact if declined: 
  No Send Tab feature.

Testing completed (on m-c, etc.): 
  None.

Risk to taking this patch (and alternatives if risky): 
  None. Backout of a build-disable.

String or IDL/UUID changes made by this patch:
  None.
Attachment #8416535 - Flags: approval-mozilla-release?
Attachment #8416535 - Flags: approval-mozilla-beta?
Attached image Appearance.
I really appreciate the thoughtful response to feedback about this feature. I'm thrilled that it'll be making it back for Fx29. [I'm also excited about the new & improved version being planned.]
Attachment #8416531 - Flags: review?(mark.finkle) → review+
Attachment #8416535 - Flags: review?(mark.finkle) → review+
Note for the historical record: we'd really like this string to be in sentence case, but we can't do that. (And we probably want a different string anyway: "Send tab to other devices" is a confusing destination for, say, sharing a link from Feedly.)
https://hg.mozilla.org/mozilla-central/rev/f1090026382e
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Comment on attachment 8416531 [details] [diff] [review]
Part 1: rename Send Tab activity. v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  None. UX decision.

User impact if declined: 
  Send tab intent will be named "Firefox Sync", not "Send Tab To Other Devices".

Testing completed (on m-c, etc.): 
  Landed on m-c. Label change verified by hand.

Risk to taking this patch (and alternatives if risky): 
  None.

String or IDL/UUID changes made by this patch:
  None; label changed to point to a different string, but no string changes.
Attachment #8416531 - Flags: approval-mozilla-release?
Attachment #8416531 - Flags: approval-mozilla-beta?
Attachment #8416531 - Flags: approval-mozilla-aurora?
Attachment #8416531 - Flags: approval-mozilla-beta?
Attachment #8416531 - Flags: approval-mozilla-beta+
Attachment #8416531 - Flags: approval-mozilla-aurora?
Attachment #8416531 - Flags: approval-mozilla-aurora+
Attachment #8416535 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
'Send Tab To Devices' option appears in the sharing list and it works as specified.
Verified as fixed in build 32.0a1 (2014-05-05);
Device: Google Nexus 5 (Android 4.4.2).
Comment on attachment 8416531 [details] [diff] [review]
Part 1: rename Send Tab activity. v1

We are taking this for a non-urgent 29.0.1 release.
Attachment #8416531 - Flags: approval-mozilla-release? → approval-mozilla-release+
Comment on attachment 8416535 [details] [diff] [review]
Part 2: re-enable Send Tab on Beta and Release. Backed out changeset b30d5dfe0421 (Bug 941744) v1

We are taking this for a non-urgent 29.0.1 release.
Attachment #8416535 - Flags: approval-mozilla-release? → approval-mozilla-release+
'Send Tab To Devices' option appears in the sharing list and it works as specified.
Verified as fixed in builds:
- 31.0a2 (2014-05-06);
- 30 beta 2;
- 29.0.1;
Device: Motorola Razr (Android 4.0.4).
You need to log in before you can comment on or make changes to this bug.