Closed Bug 941744 Opened 6 years ago Closed 6 years ago

Remove send tab feature from release builds so Firefox Sync doesn't show up as a share option

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 29
Tracking Status
firefox29 + verified
firefox30 + verified
relnote-firefox --- 29+
fennec 29+ ---

People

(Reporter: blassey, Assigned: rnewman)

References

Details

(Keywords: relnote, user-doc-needed)

Attachments

(2 files)

For every Firefox version you have installed, you get two fairly non-nonsensical sharing options.
I assume Firefox Sync is the "Send Tab" feature, but I don't know about why Firefox Beta is there.
Flags: needinfo?(rnewman)
Sriram - Any idea why Firefox Beta and Fennec are showing up?
Flags: needinfo?(sriram)
this is on the nexus 5
May be the list needs purging. I thought Android does that for us. Is there an STR to reproduce this? I don't have a Nexus 5 to test this.
Flags: needinfo?(sriram)
"Firefox Sync" (with subtitle "Your App Name" if you have more than one Fennec installed) is normal: that's Send Tab. It's the least-crummy name we could come up with for a share intent that would catch things that aren't just tabs.

I have no idea why the "Firefox Beta" share target is showing up; it's nothing to do with Sync. What intent fires in logcat when you tap it?
Flags: needinfo?(rnewman)
^
Flags: needinfo?(blassey.bugs)
tracking-fennec: ? → 29+
I no longer have the "Firefox Beta" sharing option showing up to see what intent it sends. Since it has an Android icon, I'm going to assume this is due to the list getting stale, which I think we already have a bug for.

Perhaps the thing to fix for this bug is "Firefox Sync" being entirely unclear. Can we remain that "Send tab"? It'll already have the Firefox icon to imply "Send tab to Firefox".
Flags: needinfo?(blassey.bugs) → needinfo?(ibarlow)
We named it Firefox Sync because unless you're in Firefox it's usually not a tab you're sending, and the name "Send Tab" doesn't make much sense to most people. There is no good name for this. 

(Consider that the most obvious interpretation of "Send Tab" is "I want to open this link in Firefox", which it doesn't do! I think we started on that road and rapidly changed direction. UX was already involved in that.) 

The right solution is for Hub/My List to grow a Share handler overlay, with some of the destinations being your other devices. Then you can send *something* to "Firefox", and we can give you better guidance as to what to do with it.

We'll have a bug for that work soon, I imagine, so I'm going to resolve this one.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Depends on: 948509
may I suggest we add logic to special case "Firefox Sync" and change it to "Send Tab" when it is in the Firefox share menu?

Alternatively we can call it something like "Send to Firefox" everywhere.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #10)
> may I suggest we add logic to special case "Firefox Sync" and change it to
> "Send Tab" when it is in the Firefox share menu?
> 
> Alternatively we can call it something like "Send to Firefox" everywhere.

I'll be honest, I don't understand how this feature is intended to work, so I would need a little clarification before adding my opinion about what to call this item. Because right now I'm more inclined to nuke it until we build the share intent overlay panel that Richard is describing.

As Richard said, "send to tab" implies that you are pushing a page to another device, and presumably that page appears somewhere in Firefox without you having to do anything. It doesn't actually do that though. In fact I don't know what it actually does that background sync isn't already meant to do.
Flags: needinfo?(ibarlow)
(In reply to Ian Barlow (:ibarlow) from comment #11)
> It doesn't actually do that though. In
> fact I don't know what it actually does that background sync isn't already
> meant to do.

It takes a URL -- from Twitter, from Fennec, wherever -- and sends it to another instance of Firefox connected to your Sync account, which will automatically open it when you start using that device.

From *within* Firefox this is "Send tab to another Firefox via the cloud". From outside Firefox this is "Push this thing into the Firefox Sync cloud" -- users seem to grasp the concept of their data being in the cloud.

By contrast, background sync will show you which tabs are open on your other browsers. Pull versus push.

The naming issue is that "Send Tab" is meaningless unless the thing you're sending is a tab, and that's only the case within Firefox (see Brad's Comment 8). "Send to Firefox" is confusing 'cos that's not what it does ("wait, why isn't it opening in Firefox?").

As I said, the proper fix seems to be Bug 948509.
(In reply to Richard Newman [:rnewman] from comment #12)
> (In reply to Ian Barlow (:ibarlow) from comment #11)
> > It doesn't actually do that though. In
> > fact I don't know what it actually does that background sync isn't already
> > meant to do.
> 
> It takes a URL -- from Twitter, from Fennec, wherever -- and sends it to
> another instance of Firefox connected to your Sync account, which will
> automatically open it when you start using that device.

Yeah, the problem is that it doesn't actually work, I have yet to successfully send a page from my phone to my computer. :(
 
> As I said, the proper fix seems to be Bug 948509.

I agree, and unless this is a feature that actually works properly for other people I would suggest disabling this share intent item in the mean time...
(In reply to Ian Barlow (:ibarlow) from comment #13)

> Yeah, the problem is that it doesn't actually work, I have yet to
> successfully send a page from my phone to my computer. :(

Did you sync on your computer? (We have no push notification mechanism, so that's the best we can do.)

If so, I'd be interested in seeing some Sync logs, if you have time tomorrow to test for me.

> I agree, and unless this is a feature that actually works properly for other
> people I would suggest disabling this share intent item in the mean time...

You're the first person who's reported that it doesn't work. We know there's a very small set of users, relatively speaking (compounded fractions).
product says to yank this
Assignee: nobody → rnewman
Summary: Firefox sync and Fennec showing up as share options → Remove send tab feature so Firefox Sync doesn't show up as a share option
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 965811
Status: RESOLVED → REOPENED
OS: Mac OS X → Android
Hardware: x86 → All
Resolution: DUPLICATE → ---
Summary: Remove send tab feature so Firefox Sync doesn't show up as a share option → Remove send tab feature from release builds so Firefox Sync doesn't show up as a share option
Not yet tested, but this should work.
Attachment #8404421 - Flags: review?(nalexander)
N.B., the exported=true is to maintain previous behavior -- that other apps can hit Send Tab if they use the class name. That's the default if there's an intent filter, which we're conditionally removing, and false otherwise.
Comment on attachment 8404421 [details] [diff] [review]
Remove Send Tab intent filter from RELEASE_BUILDs. v1

Review of attachment 8404421 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm.  Make sure that RELEASE_BUILD is defined in android-sync when you land.
Attachment #8404421 - Flags: review?(nalexander) → review+
> Make sure that RELEASE_BUILD is defined in android-sync when you land.

See the first commit in the pull request :D
Comment on attachment 8404421 [details] [diff] [review]
Remove Send Tab intent filter from RELEASE_BUILDs. v1

Let's also start the process of making changes to the client that move us in the direction we want to go.
Attachment #8404421 - Flags: feedback+
Trees closed; someone please land this!
Status: REOPENED → ASSIGNED
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/dcc47ae72ae8
Status: ASSIGNED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Comment on attachment 8404421 [details] [diff] [review]
Remove Send Tab intent filter from RELEASE_BUILDs. v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  Product decision.

User impact if declined: 
  Users will see Send Tab to Device on release and beta builds, which UX and product doesn't want.

Testing completed (on m-c, etc.): 
  Tested with a local 'beta' build. Will only get final verification after uplift.

Risk to taking this patch (and alternatives if risky): 
  The only risk is that it doesn't work. Otherwise, should be zero.

String or IDL/UUID changes made by this patch:
  None.
Attachment #8404421 - Flags: approval-mozilla-beta?
Attachment #8404421 - Flags: approval-mozilla-aurora?
Flags: needinfo?(rnewman)
Attachment #8404421 - Flags: approval-mozilla-beta?
Attachment #8404421 - Flags: approval-mozilla-beta+
Attachment #8404421 - Flags: approval-mozilla-aurora?
Attachment #8404421 - Flags: approval-mozilla-aurora+
Erin, could you propose a description for the relnotes?
ok, ibarlow hooked us up: The old Firefox Sync 'send tab' feature has been limited to our experimental Nightly builds, because it doesn't deliver an experience we think will satisfy most users yet. If you would like to continue using this, you can download a Nightly build at nightly.mozilla.org. I know you can't really publish sentences but hopefully this works as a guideline.
I use Firefox Beta on Android, mostly to give feedback. To be honest, I am frustrated by this removal. This was one of the most valued and used features for me. I know you are going to ignore this anyway, but I would be very happy to get it back (in Beta, not in nightly builds).
(In reply to Adam Victor Nazareth Brandizzi from comment #30)
> I use Firefox Beta on Android, mostly to give feedback. 

Awesome. We encourage you to continue to provide us with feedback when we make changes as it helps us evaluate and make decisions. 

We do not ignore comments made by our users. We always take them into consideration. I too, wish we would have shipped this as is for Firefox 29 but it was not entirely what we wished to ship in our vision. I too hope it returns sometime soon.
Verified as fixed in builds:
- 29 release;
- 30 beta 1;
Device: Samsung Galaxy R (Android 2.3.4).
Target Milestone: Firefox 31 → Firefox 29
Added a note to 29 mobile release notes as "Changed"	Removed ability to 'send tab' to remote device
I share Adam's frustration with the decision to excise this bug/feature (whichever way you view it) from the latest beta and/or stable branch. 

Only got to know more about this listing thanks to Mr. Nick Alexander via Twitter (thanks bro). 

My $0.02 would be this though. We know for a fact that there are users of send-to-other-device, namely, this bug/feature. How I wish that a separate implementation could have been shipped first before removing this one, if only to prevent loss of functionality. It doesn't occur to me that this one's a show-stopper anyway, but that's just me.
Agreed, it was already shipping and functional. I suggest, and I will, be following bug https://bugzilla.mozilla.org/show_bug.cgi?id=1002628 where we there will soon be discussions for touch-ups for the feature.
This was my favorite feature of Firefox Mobile. I rarely want to read a long article on my Android device and sending things to my laptop to read later is really useful.

It seems odd to me to take a feature (even if it is one with a small but passoniate group of users) and make it available only in Nightly. Nighly is a tough place to be because of all the other stuff that goes wwrong. I would very much like this feature to return to Beta.
As this is intended only for release builds, I will set the bug to verified fixed.
Status: RESOLVED → VERIFIED
Removing the 'status-firefox31: fixed' flag since the 'Send Tab to Devices' feature will be re enabled in bug 1005074.
You need to log in before you can comment on or make changes to this bug.