Closed Bug 1005085 Opened 6 years ago Closed 5 years ago

In about:accounts, can't tab navigate to the "Manage" button.

Categories

(Firefox :: Sync, defect)

29 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 38
Iteration:
38.1 - 26 Jan

People

(Reporter: davidb, Assigned: vladikoff)

References

Details

(Keywords: access)

Attachments

(1 file)

This is the sighted keyboard user use case.

(I tested on OSX with the following system setting:
System Preferences -> Keyboard -> Shortcuts -> at bottom under "Full Keyboard Access "All controls" is selected)

STR:
1. go to about:accounts (type that into location bar)
2. confirm you see a page that says "Welcome to Sync"
3. repeated press [tab] key to see where focus cycles.

Expected:
The "Manage" button should get focus at some point.

Actual:
It doesn't get focus.
This also applies to when you see the "Get Started" button instead.
Might be helped by bug 998051?
Flags: firefox-backlog+
:davidb, do you have any opinion on whether we should continue to block accessibility-review of FxA on this bug?  It's not looking like anyone is going to get to this soon; bug 996243 has now been open for nearly a year, and we have millions of FxA's in the wild.  I'm rather at a loss for what the next step should be.

Thanks very much for any guidance.
Flags: needinfo?(dbolter)
Well, it needs to be fixed before it passes review. This might be as simple as setting an attribute tabindex="0" in:
<a id="buttonGetStarted" class="button" href="#">
in aboutaccounts.xhtml
Flags: needinfo?(dbolter)
FWIW, I cannot reproduce this bug on Windows in Nightly. The Manage button does get focus for me. I just don't know if it is indicated visually. If so, the only thing needed might be an adjustment to the CSS for :focus of that element. An a with any kind of href should get focus in any case, the only a tags that don't are those that create a named anchor.
It would be good if someone else can try to reproduce based on my STR (on OSX)... If that fails I'll dig deeper into why this still reproduces for me.
OK, I could reproduce this on OS X, but definitely not on Windows.

Wonder if it is the about:config pref (which I currently don't know the name of) that overrides the tab key behavior on OS X, or not, depending on what it's set to? This has been the cause for headaches with keyboard users in the past ever since we introduced that. Could this just be another case?
I can reproduce it on the mac as well, and tabindex="0" does fix the issue.
The "Manage" and "Getting Started" are buttons that ship with Firefox. They aren't managed by the content server.
Thank you, :ckarlof.  This seems like a quick fix; is there anyone on the cc list for this bug who has a moment to implement it?
In IRC, it looks like :vlad was interested in helping out.
Besides setting `tabindex` we also need to convert the anchors to buttons to make them actionable (using SPACE or ENTER keys). 
Demo: http://vf.io/i/bugzilla1005085-d4a.gif
Attachment #8552108 - Flags: review?(kthiessen)
Attachment #8552108 - Flags: review?(ckarlof)
Assignee: nobody → vlad
Comment on attachment 8552108 [details] [diff] [review]
0001-bug-1005085-Fixes-about-accounts-keyboard-navigation.patch

Review of attachment 8552108 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not a module owner or a peer here, but this patch does what it's supposed to, consistent with my knowledge.
Attachment #8552108 - Flags: review?(kthiessen) → review+
:jgruen is going to take a look.
Flags: needinfo?(jgruen)
Attachment #8552108 - Flags: ui-review?(jgruen)
Built Vlad's patch on OSX, LGTM!
Flags: needinfo?(jgruen)
Attachment #8552108 - Flags: review?(ckarlof) → review+
Attachment #8552108 - Flags: ui-review?(jgruen) → ui-review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e41ae9819719
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 38
Iteration: --- → 38.1 - 26 Jan
Flags: qe-verify?
QA Whiteboard: [good first verify]
Flags: qe-verify? → qe-verify-
You need to log in before you can comment on or make changes to this bug.