Last Comment Bug 1005436 - OMXCodec failed to initialize video decoder for "@??" - mp4 playback not working after OTA 4.4.2 upgrade of Samsung Galaxy Note 2 from Android 4.3
: OMXCodec failed to initialize video decoder for "@??" - mp4 playback not work...
Status: RESOLVED FIXED
: reproducible
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: 29 Branch
: ARM Android
-- normal (vote)
: ---
Assigned To: James Willcox (:snorp) (jwillcox@mozilla.com)
:
: Maire Reavy [:mreavy] Please needinfo me
Mentors:
https://ns.ibnlive.in.com/ipadmp4/04_...
: 1046968 (view as bug list)
Depends on: mediacodec
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-02 22:42 PDT by Ayan
Modified: 2015-03-11 08:09 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
affected
affected
affected
affected
affected


Attachments
Screenshot_2014-05-03-11-00-40.png (194.85 KB, image/png)
2014-05-02 22:42 PDT, Ayan
no flags Details
tmp_Screenshot_2014-05-03-17-36-53-995882750.png (22.26 KB, image/png)
2014-05-03 05:09 PDT, Ayan
no flags Details

Description User image Ayan 2014-05-02 22:42:40 PDT
Created attachment 8416852 [details]
Screenshot_2014-05-03-11-00-40.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140421221237

Steps to reproduce:

Samsung Note 2 running Android 4.3 got the OTA 4.4.2 upgrade last night


Actual results:

After the upgrade, with the FF version remaining the same, embedded videos on sites were no longer playing

http://m.ibnlive.com/news/masandsverdict/transcendence-review-the-film-is-clunky-and-lifeless/466095-8.html


Expected results:

Like the Android 4.3 with FF 29, embedded videos should play
Comment 1 User image Ayan 2014-05-03 05:09:37 PDT
Created attachment 8416888 [details]
tmp_Screenshot_2014-05-03-17-36-53-995882750.png
Comment 2 User image Ayan 2014-05-03 05:10:59 PDT
Cnn's site has the same problem. Screenshot attached

http://www.cnn.com
Comment 3 User image Kevin Brosnan [:kbrosnan] 2014-05-03 12:16:48 PDT
Aaron do you have a Note 2?
Comment 4 User image Aaron Train [:aaronmt] 2014-05-03 13:37:39 PDT
I do. I upgraded my device to 4.4.2 and I do see the same issue here. I double-checked before upgrading and I did see video playback work correctly:

URL used from aforementioned test-case URL: https://ns.ibnlive.in.com/ipadmp4/04_2014/transcendence_review.mp4

Related OMX output:

I/MediaPluginHost( 7798): Loading OMX Plugin: libomxpluginkk.so
I/OMXClient( 7798): Using client-side OMX mux.
I/MediaPluginHost( 7798): OMX plugin successfully loaded
D/OMX     ( 1951): SendBroadCasting VIDEO_PLAYBACK_START
E/OMXNodeInstance( 1951): OMX_GetExtensionIndex OMX.google.android.index.storeMetaDataInBuffers failed
W/OMXNodeInstance( 1951): OMX_GetExtensionIndex OMX.google.android.index.prepareForAdaptivePlayback failed
D/OMX     ( 1951): SendBroadCasting VIDEO_PLAYBACK_STOP
D/OMX     ( 1951): SendBroadCasting VIDEO_PLAYBACK_START
E/OMXNodeInstance( 1951): OMX_GetExtensionIndex OMX.google.android.index.storeMetaDataInBuffers failed
W/OMXNodeInstance( 1951): OMX_GetExtensionIndex OMX.google.android.index.prepareForAdaptivePlayback failed
D/OMX     ( 1951): SendBroadCasting VIDEO_PLAYBACK_STOP
E/OMXNodeInstance( 1951): OMX_GetExtensionIndex OMX.google.android.index.storeMetaDataInBuffers failed
W/OMXNodeInstance( 1951): OMX_GetExtensionIndex OMX.google.android.index.prepareForAdaptivePlayback failed
D/OMX     ( 1951): SendBroadCasting VIDEO_PLAYBACK_START
E/OMXNodeInstance( 1951): OMX_GetExtensionIndex OMX.google.android.index.storeMetaDataInBuffers failed
W/OMXNodeInstance( 1951): OMX_GetExtensionIndex OMX.google.android.index.prepareForAdaptivePlayback failed
D/OMX     ( 1951): SendBroadCasting VIDEO_PLAYBACK_STOP
E/OMXNodeInstance( 7798): OMX_GetExtensionIndex OMX.google.android.index.storeMetaDataInBuffers failed
W/OMXNodeInstance( 7798): OMX_GetExtensionIndex OMX.google.android.index.prepareForAdaptivePlayback failed
I/OmxPlugin( 7798): Decoder OMX.SEC.avc.dec can output colour format 0x15.
I/OmxPlugin( 7798): Found compatible decoder OMX.SEC.avc.dec with colour format 0x15.
I/OMXCodec( 7798): Attempting to allocate OMX node 'OMX.SEC.avc.dec'
D/OMX     ( 1951): SendBroadCasting VIDEO_PLAYBACK_START
I/OMXCodec( 7798): Successfully allocated OMX node 'OMX.SEC.avc.dec'
I/OMXCodec( 7798): [OMX.SEC.avc.dec] AVC profile = 66 (Baseline), level = 13
I/OMXCodec( 7798): [OMX.SEC.avc.dec] FrameRate (25)
I/OMX     ( 1951): width (640), height (512), fps (25)
I/OMX     ( 1951): width (640), height (512), fps (25)
I/OMXCodec( 7798): [OMX.SEC.avc.dec] video dimensions are 640 x 512
I/OMXCodec( 7798): [OMX.SEC.avc.dec] Crop rect is 640 x 512 @ (0, 0)
W/OMXCodec( 7798): Failed to configure codec 'OMX.SEC.avc.dec'
D/OMX     ( 1951): SendBroadCasting VIDEO_PLAYBACK_STOP
I/OmxPlugin( 7798): OMXCodec failed to initialize video decoder for "@??"

Of particular interest is the failure to initialize the video decoder.
Comment 5 User image Mark Finkle (:mfinkle) (use needinfo?) 2014-05-08 10:27:03 PDT
Poor video playback is one of our top 3 feedback complaints. Should we even be using OMX on 4.4.2? Snorp thinks there might be an official Java API for video playback. The MediaCodec class?
Comment 6 User image Mathieu Pellerin 2014-05-15 00:16:29 PDT
Having same problem here. Mp4 <video>s can't play within Firefox on my updated Samsung note 2 (android 4.4.2).
Comment 7 User image James Willcox (:snorp) (jwillcox@mozilla.com) 2014-05-15 08:00:04 PDT
Things seem to be working fine on Nexus 10, so apparently some Exynos-based devices are not affected.
Comment 8 User image Anthony Jones (:kentuckyfriedtakahe, :k17e) 2014-05-21 19:58:30 PDT
(In reply to Mark Finkle (:mfinkle) from comment #5)
> Poor video playback is one of our top 3 feedback complaints. Should we even
> be using OMX on 4.4.2? Snorp thinks there might be an official Java API for
> video playback. The MediaCodec class?

See bug 941302 specifically c28 in relation to patching libstagefright being the preferred approach on b2g.
Comment 9 User image Anthony Jones (:kentuckyfriedtakahe, :k17e) 2014-05-21 20:13:34 PDT
Blake Wu tells me that this specific issue doesn't exist on Android.
Comment 10 User image Blake Wu [:bwu][:blakewu] 2014-05-22 07:38:56 PDT
This is a fennec issue. I think it should not be related to bug 941302 which is for B2G only.
Comment 11 User image James Willcox (:snorp) (jwillcox@mozilla.com) 2014-05-22 08:21:50 PDT
I filed bug 1014614 for investigation into MediaCodec
Comment 12 User image Mathieu Pellerin 2014-07-12 04:50:08 PDT
Any chance one of the developers involved in this drop a small update on status of this bug? Broken .mp4 support forces me to go back to the stock browser every day, it's painful :)
Comment 13 User image Aaron Train [:aaronmt] 2014-07-12 10:07:52 PDT
Unfortunately nobody is looking at this bug.
Comment 14 User image Anthony Jones (:kentuckyfriedtakahe, :k17e) 2014-07-13 18:42:19 PDT
(In reply to Aaron Train [:aaronmt] from comment #13)
> Unfortunately nobody is looking at this bug.

It will need to wait for 1014614 along with enabling the internal MP4 parser.
Comment 15 User image Mathieu Pellerin 2014-07-13 18:50:39 PDT
Ok, thanks for the update. As Samsung's Galaxy Note 2 is one of the key Android-based smartphone, wanted to make sure Mozilla has a strategy ;-P
Comment 16 User image Anthony Jones (:kentuckyfriedtakahe, :k17e) 2014-07-13 19:07:58 PDT
The Android platform has fragmentation problems and especially in relation to video. Mostly due to the lack of an officially supported API. There is now a Java API which shows some promise. Unfortunately it involves further work to port to support the new API.
Comment 17 User image Aaron Train [:aaronmt] 2014-08-02 17:06:23 PDT
*** Bug 1046968 has been marked as a duplicate of this bug. ***
Comment 18 User image James Willcox (:snorp) (jwillcox@mozilla.com) 2014-08-28 10:55:23 PDT
The way forward here is going to be to use the MediaCodec Java API, bug 1014614.
Comment 19 User image James Willcox (:snorp) (jwillcox@mozilla.com) 2015-03-11 08:09:39 PDT
Bug 1014614 fixed this.

Note You need to log in before you can comment on or make changes to this bug.