Closed Bug 100552 Opened 21 years ago Closed 21 years ago

[FLOATER]left-floated table spills over right-floated table

Categories

(Core :: Layout, defect)

x86
Windows 98
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla1.1alpha

People

(Reporter: piteq, Assigned: alexsavulov)

References

()

Details

Attachments

(2 files)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

Please just check the text positioning on the main page. Text of the first few
news is badly positioned over the pictures, making it unreadable. Pls compare in
msie. 

Reproducible: Always
Steps to Reproduce:
1. Just visit www.valhalla.pl ;)
2. Scroll down about one screen
3. Look & cry
Confirming issue text flows over several images located in the center of page.
Need to break down to test case.
Status: UNCONFIRMED → NEW
Ever confirmed: true
See reduced test. Overlapping tables is causing the problem. First table is
aligned right and second table is aligned left. If you removed the left aligned
attribute from the second table, the second table renders to the edge of the
first table.
Attached file Overlapping tables
Looking at the testcase, it seems to be a problem with the intereaction of the
left floated table and the right floated table.

Works OK in NS6.1 - regression. CC'ing waterson and dbaron for their wisdom.
Status: NEW → ASSIGNED
Summary: looks ugly, because of layer positioning and size → left-floated table spills over right-floated table
It's only the second float that has to be a table, not the first.
I wonder if ComputeBlockAvailSpace gets called here -- I suspect it shouldn't
be, but if it is, we shouldn't go through the separate branch for tables. 
(Haven't actually checked anything yet.)
I don't know if it has any connections with the bug I have reported (it's more
related to child layer positioning) , but could you please check also page
www.pccentrum.com.pl ? I have checked it with some 9.3.x builds, also with
20010913 9.4 one, and the result is always similar: nothing is on its place. It
looks perfect with Netscape 4.7x and msie 5.x and above. (According to my ISP
information there may be some problems with reaching above address)
*** Bug 102822 has been marked as a duplicate of this bug. ***
Summary: left-floated table spills over right-floated table → [FLOATER]left-floated table spills over right-floated table
Target Milestone: --- → mozilla0.9.9
[FLOAT] bugs to Alex :)
Assignee: attinasi → alexsavulov
Status: ASSIGNED → NEW
retargeting
Target Milestone: mozilla0.9.9 → mozilla1.0
Depends on: 99461
Moving to Mozilla1.1. Engineers are overloaded with higher priority bugs.
Target Milestone: mozilla1.0 → mozilla1.1
fixed by fix for bug 122200
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Keywords: nsbeta1+
Marking verified in April 22 trunk build (2002-04-22-03).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.