[ZTE Open C v1.3] [Proximity Sensor] - Screen does not automatically turn back on after it's turned off from Proximity Sensor

RESOLVED INVALID

Status

defect
RESOLVED INVALID
5 years ago
3 years ago

People

(Reporter: rdaub, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: zteopenc)

Attachments

(1 attachment)

Reporter

Description

5 years ago
STEPS TO REPRODUCE:
1. Make a call
2. Take the phone to the ear
The phone automatically turns off because of the proximity sensor

4. Pick the phone back up to look at the screen

EXPECTED RESULTS:
The screen should automatically turn back on, so that the user can chose to end the call, conference call, or dial numbers.

ACTUAL RESULTS:
The screen remains turned off until the volume or power buttons are pressed.


Please let me know if there is any information I could provide to help with the investigation and troubleshooting of this issue.

Thanks!!
Ralph - Can you indicate what build ID you used to reproduce the bug? You can find the build ID in settings --> device information.
Flags: needinfo?(rdaub)
Reporter

Comment 2

5 years ago
Hi Jason, definitely.

Model: Open C
Software: FFOS_US_EBAY_OPENCV1.0.0B01
Build ID: 20140324033956
OS Version: 1.3.0.0
Hardware revision: P821A10B01

Please let me know if there is any other information you may need from me. Thanks for your help!
Flags: needinfo?(rdaub)
I get the feeling that this is a vendor issue, so over to Vendcom.
Component: Gaia → Vendcom
Reporter

Updated

5 years ago
Whiteboard: zteopenc
I'll add qawanted here though to see if we can reproduce this on the latest 1.3 build for Open C.
Keywords: qawanted
QA Contact: ckreinbring
Able to repro on the latest Open C 1.3 base build.  Attaching logcat logs.

Build ID: 20140505052400
Firmware version: P821A10V1.0.0B06_LOG_DL
Keywords: qawanted

Comment 6

5 years ago
Same problem in europe Zte Open C version BUILD FFOS_EU_EBAY_OPENCV1.0.0B04

I am not shure that proximity senso is present.....
Hey Vance, does the Open C have a proximity sensor?  Or a light sensor?
Or are they hitting a time out?
Flags: needinfo?(vchen)
Proximity sensor (if present in an Open C) is not deactivating the screen during a call.  I've tested all the base images that are available to us.  I did see that the screen can timeout during a call confirming Comment 7, which could be what was observed in Comment 0 since this enables the lockscreen and that does not deactivate after removing device from your ear.

Base Images tested:
P821A10v1.0.0B06_LOG_DL_US_EBAY
P821A10-ENG_20140401
P821A10-ENG_20140410
P821A10-ENG_20140508
Reporter

Comment 9

5 years ago
For tracking purposes - 
Another user is inquiring about this issue on the SUMO forums: https://support.mozilla.org/en-US/questions/1007578
I've just tested this issue on friend's Open C who had encountered the original issue here (the screen doesn't turn on again at the end of a call). His phone received an OTA update just a few days ago and now the problem is reversed: the screen doesn't turn off during a call if he puts the phone close to its ear. This is even more problematic than before because he can accidentally press buttons during a call since the screen is fully on for the whole time.

Comment 11

5 years ago
Been following this topic with interest ... ever since I got my Open C with broken proximity detection ;)

I haven't delved deeply enough into my device yet to confirm what I'm about to say, but I think there are two issues here:

1) Sadly, there simply is no proximity sensor on the Open C, or it's widely defective on this phone.
2) The screen-off behaviour is actually timer-based, and has nothing to do with lightness/proximity sensing.

The reason I believe #2 is correct, is that the display's behaviour changes depending on the type of call.  If you receive an incoming call and answer it, the screen will immediately dim and then switch off after 4-5 seconds.  This occurs regardless of anything (your head, hand, a firefox toy, etc) being proximal to the top of the phone's screen.  

Conversely, if you make an outgoing call which is answered, the screen will never dim or switch off.  This concurs with the behaviour observed in comment #10.

Because of these factors, and by checking the phone's debug menu (open the dialer and type:  *983*0#  then hit the green "dial" key) for a sensor - which isn't there - I can only conclude that the Open C does not have one or it's broken.  Or, perhaps, a driver isn't installed.

There is an older but semi-related issue on Google Groups, here: https://groups.google.com/forum/#!msg/mozilla.dev.b2g/Ly1LWN6SRJ0/8dq1FnBj6NEJ

And FWIW, I've been talking to ZTE via their ebay shop and the best they have come back with so far is an offer of financial compensation for the inconvenience.  I might be reading between the lines, but this suggests to me that they have no plans to issue an OTA update with a fix.
As I know, Open C comes with 2 different hardware SKU, the eBay Open C doesn't have a P/L sensor, and the one sold in France does come with a P/L sensor.

Steve's comment provides a good way to check if your device have a P/L sensor or not. I am now checking with ZTE to see for the eBay Open C(the one w/o P/L sensor), what is the screen on/off mechanism while in-call. Will update here later

Thanks
Flags: needinfo?(vchen)
Vance was right. That device has no proximity sensor.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.