Closed Bug 1005656 Opened 6 years ago Closed 6 years ago

OS window widgets misaligned vs. native windows

Categories

(Firefox :: Theme, defect)

x86
Windows 8
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 718184

People

(Reporter: Dolske, Unassigned)

References

()

Details

Attachments

(2 files)

Via http://www.osnews.com/comments/27705:

"This is a bit of a weird topic, but I think it might be interesting to figure out what, exactly, is going on here. Ever since its very first release Chrome has had a very small, barely noticeable visual bug in its user interface: its window widgets (or buttons) are not aligned properly. As you can see in the screenshot below, they are shifted slightly to the right compared to a window without the bug. ... Since yesterday, I've been using Firefox 29, and I noticed that it has the exact same bug:"

Aside: generally high quality comments on the article, and major kudos to user dpJudas for downloading the source and poking through nsWindow.cpp. :)
Attached image Windows 7 too
Hmmm. The XXX here seems like it could be suspicious. Came in via bug 574454.

http://mxr.mozilla.org/mozilla-central/source/widget/windows/nsNativeThemeWin.cpp#2953

2953     case NS_THEME_WINDOW_BUTTON_CLOSE:
2954     case NS_THEME_WINDOW_BUTTON_MINIMIZE:
2955     case NS_THEME_WINDOW_BUTTON_MAXIMIZE:
2956     case NS_THEME_WINDOW_BUTTON_RESTORE:
2957       aResult->width = GetSystemMetrics(SM_CXSIZE);
2958       aResult->height = GetSystemMetrics(SM_CYSIZE);
2959       // XXX I have no idea why these caption metrics are always off,
2960       // but they are.
2961       aResult->width -= 2;
2962       aResult->height -= 4;
2963       if (aWidgetType == NS_THEME_WINDOW_BUTTON_MINIMIZE) {
2964         AddPaddingRect(aResult, CAPTIONBUTTON_MINIMIZE);
2965       }
2966       else if (aWidgetType == NS_THEME_WINDOW_BUTTON_MAXIMIZE ||
2967                aWidgetType == NS_THEME_WINDOW_BUTTON_RESTORE) {
2968         AddPaddingRect(aResult, CAPTIONBUTTON_RESTORE);
2969       }
2970       else if (aWidgetType == NS_THEME_WINDOW_BUTTON_CLOSE) {
2971         AddPaddingRect(aResult, CAPTIONBUTTON_CLOSE);
2972       }
2973     break;
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 718184
You need to log in before you can comment on or make changes to this bug.