Closed Bug 100567 Opened 20 years ago Closed 17 years ago

Show shortcut for Paste As Quotation in Compose window menu

Categories

(SeaMonkey :: MailNews: Message Display, defect)

All
Windows 98
defect
Not set
trivial

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mhearn, Assigned: neil)

References

Details

Attachments

(1 file)

Paste is Ctrl-V, but I most often use the Paste As Quotation command. Could that
have an accelerator as well please? Perhaps Ctrl-B as it is close and Ctrl-Q is
used...

thanks -mike
QA Contact: esther → olgam
reassigning to varada
Assignee: sspitzer → varada
Adding jglick in case she's interested in this being added.
Change severity from Minor to Enhancement for further decision.
Severity: minor → enhancement
I noticed this some time back, but just discovered (on OS X) that apple-shift-v
does the trick. My "bug" would be: no accelerator listed in the menu, even
though there is one.

Turns out on Windows it also works, but there it's ctrl-shift-v of course.

And, in the only place that really matters, on Linux ctrl-shift-v also works.

So it looks like all that needs to be done is including a menu entry to let the
userverse know this.
*** Bug 163571 has been marked as a duplicate of this bug. ***
taking all of varada's bugs.
Assignee: varada → sspitzer
Updating bug per comment 4.  Ctrl+Shift+V does indeed work under Windows.
Severity: enhancement → trivial
Summary: Paste As Quotation in Compose window needs keyboard accelerator. → Show shortcut for Paste As Quotation in Compose window menu
Attached patch Proposed patchSplinter Review
The second hunk is necessary because messengercompose.xul already imports
pastequotationkb so this direct declaration is unwanted. The first change then
makes the menuitem link up with the correct key.
Assignee: sspitzer → neil.parkwaycc.co.uk
Status: NEW → ASSIGNED
Comment on attachment 144691 [details] [diff] [review]
Proposed patch

r=brade
Attachment #144691 - Flags: review+
Attachment #144691 - Flags: superreview?(mscott)
Attachment #144691 - Flags: superreview?(mscott) → superreview+
Comment on attachment 144691 [details] [diff] [review]
Proposed patch

Trivial patch to link the menuitem to the keybinding.
Attachment #144691 - Flags: approval1.7?
Comment on attachment 144691 [details] [diff] [review]
Proposed patch

a=chofmann for 1.7
Attachment #144691 - Flags: approval1.7? → approval1.7+
Fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Verified with
  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040326

Thanks, Neil.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.